Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0023242
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSminoralways2013-03-06 09:332013-06-06 12:00
ReportercaristuView Statuspublic 
Assigned Tomarvintm 
PriorityhighResolutionfixedFixed in VersionRMP23
StatusclosedFix in branchFixed in SCM revisione59d5eef5292
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toguilleaer
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0023242: Some taxes are not applied properly on WebPOS

DescriptionThe receipt total is not taking into account some taxes if they are configured as part of a parent tax rate.
Steps To Reproduce1) In the backend configure the organization price list with taxes excluded
2) In the [Tax Category] window create a new tax category.
3) In the [Tax Rate] window create three taxes: A, B and C. Make the three taxes belong to the tax category created on step 2). Select A as Parent Tax Rate of B and C.
4) Assign the tax category created on step 2) to a product.
5) Create a receipt on WebPOS for that product. Notice that in the receipt, in the tax breakdown part, the B and C taxes appears, but only one of them is applied on the total of the receipt.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0058510)
hgbot (developer)
2013-05-08 18:35

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: e59d5eef529284a9509cd5e0e2f56706b205be21
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Wed May 08 18:35:17 2013 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/e59d5eef529284a9509cd5e0e2f56706b205be21 [^]

Fixed issue 23242. Non-cascade taxes in pricelists without including taxes will be computed correctly.

---
M web/org.openbravo.retail.posterminal/js/data/dataordertaxes.js
---
(0058858)
hgbot (developer)
2013-05-23 07:51

Repository: erp/pmods/org.openbravo.retail.posterminal.ch
Changeset: e59d5eef529284a9509cd5e0e2f56706b205be21
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Wed May 08 18:35:17 2013 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal.ch/rev/e59d5eef529284a9509cd5e0e2f56706b205be21 [^]

Fixed issue 23242. Non-cascade taxes in pricelists without including taxes will be computed correctly.

---
M web/org.openbravo.retail.posterminal/js/data/dataordertaxes.js
---
(0058993)
guilleaer (developer)
2013-05-28 13:37

verified
(0059020)
hgbot (developer)
2013-05-29 12:18

Repository: erp/pmods/org.openbravo.retail.posterminal.multiorder
Changeset: e59d5eef529284a9509cd5e0e2f56706b205be21
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Wed May 08 18:35:17 2013 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal.multiorder/rev/e59d5eef529284a9509cd5e0e2f56706b205be21 [^]

Fixed issue 23242. Non-cascade taxes in pricelists without including taxes will be computed correctly.

---
M web/org.openbravo.retail.posterminal/js/data/dataordertaxes.js
---
(0059242)
guilleaer (developer)
2013-06-06 12:00

closed again because it has changed "automatically" to resolved

- Issue History
Date Modified Username Field Change
2013-03-06 09:33 caristu New Issue
2013-03-06 09:33 caristu Assigned To => adrianromero
2013-03-27 09:53 caristu Assigned To adrianromero => marvintm
2013-03-27 09:54 caristu Issue Monitored: networkb
2013-03-27 17:25 sureshbabu Assigned To marvintm => guilleaer
2013-04-18 10:48 guilleaer Assigned To guilleaer => marvintm
2013-05-08 18:35 hgbot Checkin
2013-05-08 18:35 hgbot Note Added: 0058510
2013-05-08 18:35 hgbot Status new => resolved
2013-05-08 18:35 hgbot Resolution open => fixed
2013-05-08 18:35 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/e59d5eef529284a9509cd5e0e2f56706b205be21 [^]
2013-05-23 07:51 hgbot Checkin
2013-05-23 07:51 hgbot Note Added: 0058858
2013-05-23 07:51 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/e59d5eef529284a9509cd5e0e2f56706b205be21 [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal.ch/rev/e59d5eef529284a9509cd5e0e2f56706b205be21 [^]
2013-05-28 13:37 guilleaer Review Assigned To => guilleaer
2013-05-28 13:37 guilleaer Note Added: 0058993
2013-05-28 13:37 guilleaer Status resolved => closed
2013-05-28 13:37 guilleaer Fixed in Version => RMP23
2013-05-29 12:18 hgbot Checkin
2013-05-29 12:18 hgbot Note Added: 0059020
2013-05-29 12:18 hgbot Status closed => resolved
2013-05-29 12:18 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal.ch/rev/e59d5eef529284a9509cd5e0e2f56706b205be21 [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal.multiorder/rev/e59d5eef529284a9509cd5e0e2f56706b205be21 [^]
2013-06-06 12:00 guilleaer Note Added: 0059242
2013-06-06 12:00 guilleaer Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker