Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0023153
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] B. User interfaceminoralways2013-02-24 01:042013-06-20 02:08
ReporterpjuvaraView Statuspublic 
Assigned Toshankarb 
PrioritynormalResolutionfixedFixed in Version3.0MP25
StatusclosedFix in branchFixed in SCM revisiond334e84e2fb2
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product Version3.0MP20SCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0023153: Empty account tree is shown when focus is not on an account record

DescriptionIn the Account Tree window if you put the focus on one of the records in the Element Value block, you can open the account tree using the tree icon.

If the focus is in the block but not on a specific icon, the account tree window opens up but it is empty containing only the root node.
See attachment.

This might be a regression. I was able to easily reproduce it in MP19 and MP20 but in older versions (MP17 and before), I had never seen it.
Steps To Reproduce1) Navigate to Account Tree window
2) Navigate to Element Value tab, putting focus in the filters and not on the records
3) Open the tree
Proposed SolutionEither the tree icon is disabled or the account tree should open correctly.
TagsNo tags attached.
Attached Filespng file icon Openbravo Account Tree F B España S.A....png [^] (131,480 bytes) 2013-02-24 01:04

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00237023.0MP25 closedjecharri Account Tree is not properly loaded when focus is not located in Element Value and "Tree" icon is pressed 

-  Notes
(0059317)
hgbot (developer)
2013-06-11 10:09

Repository: erp/devel/pi
Changeset: d334e84e2fb20ac67daeccc448849f1eb01b1172
Author: Shankar Balachandran <shankar.balachandran <at> openbravo.com>
Date: Tue Jun 11 12:45:55 2013 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/d334e84e2fb20ac67daeccc448849f1eb01b1172 [^]

Fixes Issue 0023153: Empty account tree is shown when focus is not on an account record

The tree icon is disabled if no records are selected in grid.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/toolbar/ob-toolbar.js
---
(0059329)
shankarb (developer)
2013-06-11 12:25

The value of C_Element_ID is used to display the Account Tree. But the value of the parent C_Element_ID is available in vars only if any record is selected. Hence it returns null for root element. So an empty tree was shown. Since it was not possible to retrieve the element value, the button has been disabled if no record is selected in the grid.
(0059473)
AugustoMauch (developer)
2013-06-17 18:12

Code reviewed and verified in pi@4a37945c258d
(0059561)
hudsonbot (developer)
2013-06-20 02:08

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/5caf871044ad [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2013-02-24 01:04 pjuvara New Issue
2013-02-24 01:04 pjuvara Assigned To => dbaz
2013-02-24 01:04 pjuvara File Added: Openbravo Account Tree F B España S.A....png
2013-02-24 01:04 pjuvara Modules => Core
2013-02-24 01:04 pjuvara Triggers an Emergency Pack => No
2013-02-28 17:50 dbaz Assigned To dbaz => AugustoMauch
2013-03-05 17:15 AugustoMauch Assigned To AugustoMauch => dmiguelez
2013-05-15 12:35 dmiguelez Assigned To dmiguelez => AugustoMauch
2013-06-10 07:40 shankarb Assigned To AugustoMauch => shankarb
2013-06-11 09:20 shankarb Review Assigned To => AugustoMauch
2013-06-11 09:20 shankarb Issue Monitored: AugustoMauch
2013-06-11 10:09 hgbot Checkin
2013-06-11 10:09 hgbot Note Added: 0059317
2013-06-11 10:09 hgbot Status new => resolved
2013-06-11 10:09 hgbot Resolution open => fixed
2013-06-11 10:09 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/d334e84e2fb20ac67daeccc448849f1eb01b1172 [^]
2013-06-11 12:25 shankarb Note Added: 0059329
2013-06-17 16:27 jecharri Relationship added related to 0023702
2013-06-17 18:12 AugustoMauch Note Added: 0059473
2013-06-17 18:12 AugustoMauch Status resolved => closed
2013-06-17 18:12 AugustoMauch Fixed in Version => 3.0MP25
2013-06-20 02:08 hudsonbot Checkin
2013-06-20 02:08 hudsonbot Note Added: 0059561


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker