Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0022971
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 00. Application dictionarymajoralways2013-02-04 18:142013-02-20 04:49
ReportercaristuView Statuspublic 
Assigned ToAugustoMauch 
PriorityurgentResolutionfixedFixed in Version3.0MP21
StatusclosedFix in branchFixed in SCM revisioncf082b976da9
ProjectionnoneETAnoneTarget Version3.0MP21
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Toshankarb
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0022971: Export as CSV is not working properly on Widgets if it contains null values

DescriptionIf we create a widget that has a column with null values and we export it as csv, the resulting file is not properly generated.

There are two situations:

a) If all the values in the column are null, then the column is not exported
b) If some of the values are not null, then the column is not exported too and the not null values are not correctly placed (see attachments)
Steps To Reproduce1) As [system administrator], go to [Widget] window and create a new Query/List widget. In the Query tab, insert an hql query with a column that contains null values

2) Add the widget to the [Workspace]

3) Click on the pencil button of the widget and choose 'Export as CSV'
TagsNo tags attached.
Attached Filescsv file icon wrongExportation.csv [^] (881 bytes) 2013-02-04 23:07
diff file icon issue22971.diff [^] (812 bytes) 2013-02-05 12:21 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0056157)
AugustoMauch (manager)
2013-02-05 12:22

A fix for this issue has been attached. It will be pushed to pi once it is unfrozen for MP21 issues.
(0056219)
jonalegriaesarte (reporter)
2013-02-06 11:45

Patch provided, changing the priority
(0056345)
hgbot (developer)
2013-02-11 17:44

Repository: erp/devel/pi
Changeset: cf082b976da9ff9afb08de39d9f1a3c0cdc1f583
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Mon Feb 11 17:44:28 2013 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/cf082b976da9ff9afb08de39d9f1a3c0cdc1f583 [^]

Fixes issue 22971: Columns with null values can be exported to CSV

The problem was that the convertPrimitiveValue method of the DataToJsonConverter class was returning null when a null object was provided. If then that null object is used in the JSONObject.put(key, value) in the value field, the field was not added at all.

This has been fixed by returning an empty string instead of a null object.

---
M modules/org.openbravo.service.json/src/org/openbravo/service/json/DataToJsonConverter.java
---
(0056369)
shankarb (developer)
2013-02-12 11:52

Code Reviewed and Verified in pi changeset 5265a23b7dbe
(0056568)
hudsonbot (developer)
2013-02-20 04:49

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/d828167a9e83 [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2013-02-04 18:14 caristu New Issue
2013-02-04 18:14 caristu Assigned To => AugustoMauch
2013-02-04 18:14 caristu Modules => Core
2013-02-04 18:14 caristu Triggers an Emergency Pack => No
2013-02-04 18:18 caristu Priority urgent => immediate
2013-02-04 18:26 caristu Resolution time => 1360018800
2013-02-04 18:26 caristu version => pi
2013-02-04 18:26 caristu Target Version => 3.0MP21
2013-02-04 23:07 caristu File Added: wrongExportation.csv
2013-02-05 12:21 AugustoMauch File Added: issue22971.diff
2013-02-05 12:22 AugustoMauch Note Added: 0056157
2013-02-05 12:22 AugustoMauch Status new => scheduled
2013-02-05 12:22 AugustoMauch fix_in_branch => pi
2013-02-06 11:45 jonalegriaesarte Note Added: 0056219
2013-02-06 11:45 jonalegriaesarte Priority immediate => urgent
2013-02-06 11:45 jonalegriaesarte fix_in_branch pi =>
2013-02-11 17:38 AugustoMauch Issue Monitored: shankarb
2013-02-11 17:39 AugustoMauch Review Assigned To => shankarb
2013-02-11 17:44 hgbot Checkin
2013-02-11 17:44 hgbot Note Added: 0056345
2013-02-11 17:44 hgbot Status scheduled => resolved
2013-02-11 17:44 hgbot Resolution open => fixed
2013-02-11 17:44 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/cf082b976da9ff9afb08de39d9f1a3c0cdc1f583 [^]
2013-02-12 11:52 shankarb Note Added: 0056369
2013-02-12 11:52 shankarb Status resolved => closed
2013-02-12 11:52 shankarb Fixed in Version => 3.0MP21
2013-02-20 04:49 hudsonbot Checkin
2013-02-20 04:49 hudsonbot Note Added: 0056568


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker