Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0022904
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2013-01-28 10:182013-02-01 22:28
ReporterAugustoMauchView Statuspublic 
Assigned ToAugustoMauch 
PrioritynormalResolutionfixedFixed in Version3.0MP20
StatusclosedFix in branchFixed in SCM revisiond000753ca50c
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0022904: Pin field in multi selector window appears several times

DescriptionIf there is no module in development (consequently the application windows are cached), every time a parameter window containing a multiselector is opened, a pin field is added to the multi selector window.
Steps To ReproduceMake sure the no modules are in development.
- Create a parameter window that contains a multi selector. You can follow this example: http://wiki.openbravo.com/wiki/How_to_create_a_Standard_Process_Definition. [^]
- Open the parameter window, and open the multi selector window. See that the pin field appears once.
- Close the parameter window, open it again, and open the multi selector window. See that the pin field is duplicated.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0055897)
hgbot (developer)
2013-01-28 10:33

Repository: erp/devel/pi
Changeset: d000753ca50caebe1cf198e5bc8101f50eee9d20
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Mon Jan 28 10:25:08 2013 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/d000753ca50caebe1cf198e5bc8101f50eee9d20 [^]

Fixes issue 22904: Pin field is not duplicated on multi selector windows

The cause of this issue is that the pin field was being added to the multi selector grid fields without checking if it had been added previously. Now the pin f
ield will only be added if the first grid field is not a pin.

---
M modules/org.openbravo.userinterface.selector/web/org.openbravo.userinterface.selector/js/ob-multi-selector-item.js
---
(0055928)
alostale (developer)
2013-01-29 08:05

Code reviewed and verified on pi@8917ff30b35c
(0056066)
hudsonbot (developer)
2013-02-01 22:28

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b070aa80fc76 [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2013-01-28 10:18 AugustoMauch New Issue
2013-01-28 10:18 AugustoMauch Assigned To => AugustoMauch
2013-01-28 10:18 AugustoMauch Modules => Core
2013-01-28 10:18 AugustoMauch Triggers an Emergency Pack => No
2013-01-28 10:32 AugustoMauch Issue Monitored: alostale
2013-01-28 10:32 AugustoMauch Review Assigned To => alostale
2013-01-28 10:33 hgbot Checkin
2013-01-28 10:33 hgbot Note Added: 0055897
2013-01-28 10:33 hgbot Status new => resolved
2013-01-28 10:33 hgbot Resolution open => fixed
2013-01-28 10:33 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/d000753ca50caebe1cf198e5bc8101f50eee9d20 [^]
2013-01-29 08:05 alostale Note Added: 0055928
2013-01-29 08:05 alostale Status resolved => closed
2013-01-29 08:05 alostale Fixed in Version => 3.0MP20
2013-02-01 22:28 hudsonbot Checkin
2013-02-01 22:28 hudsonbot Note Added: 0056066


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker