Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0022885
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2013-01-24 13:202013-01-28 05:59
ReporterngarciaView Statuspublic 
Assigned ToAugustoMauch 
PriorityimmediateResolutionfixedFixed in Version3.0MP20
StatusclosedFix in branchFixed in SCM revisiond0d2ca046bbb
ProjectionnoneETAnoneTarget Version3.0MP20
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toshankarb
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0022885: Sometimes dropdown reference column filters do not show any values

DescriptionSometimes dropdown reference column filters do not show any values
Steps To ReproduceAs group admin role:
   Go to Sales Order window and create two headers (one for F&B España Region Norte and one for F&B España Region Sur)
   Enter in the Order Date filter the date of the orders manually in the From an To fields
   Open the Organization filter and notice that there are no items to show
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0055867)
hgbot (developer)
2013-01-25 14:32

Repository: erp/devel/pi
Changeset: d0d2ca046bbb2b054d43a31a4cba76d02949e4e0
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Fri Jan 25 14:31:21 2013 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/d0d2ca046bbb2b054d43a31a4cba76d02949e4e0 [^]

Fixes issue 22885: Dates in filters are serialized as Date, and not DateTime

The problem was that the Date was being serialized as a DateTime, and javascript was converting the resulting datetime to the UTC format.

I.e. if the user entered 24-01-2013, the date sent to the server for filtering was 23-01-2013 23:00:00. This conversion was being done when smartclient serialized the date. If the date had the logicalDate property set to true, then the conversion was done properly.

The change has been done only in the ob-formitem-minidaterange.js to ensure that the DateTime fields are serialized with both its date and time parts.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-minidaterange.js
---
(0055869)
AugustoMauch (developer)
2013-01-25 14:33

Test plan:
- Follow the steps to reproduce to check that the issue has been fixed. Try several date filter configurations:
    * Enter a date manually in the filter
    * Enter a From and a To date
    * Enter only a From date
    * ...
(0055877)
hudsonbot (developer)
2013-01-26 02:22

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/81e70c75d9a8 [^]

Maturity status: Test
(0055891)
shankarb (developer)
2013-01-28 05:59

Code Reviewed and Verified in pi changeset 6075f911fafd.

- Issue History
Date Modified Username Field Change
2013-01-24 13:20 ngarcia New Issue
2013-01-24 13:20 ngarcia Assigned To => AugustoMauch
2013-01-24 13:20 ngarcia Modules => Core
2013-01-24 13:20 ngarcia Triggers an Emergency Pack => No
2013-01-24 13:22 ngarcia Issue Monitored: networkb
2013-01-24 13:24 ngarcia Target Version => 3.0MP20
2013-01-25 14:25 AugustoMauch Issue Monitored: shankarb
2013-01-25 14:25 AugustoMauch Review Assigned To => shankarb
2013-01-25 14:32 hgbot Checkin
2013-01-25 14:32 hgbot Note Added: 0055867
2013-01-25 14:32 hgbot Status new => resolved
2013-01-25 14:32 hgbot Resolution open => fixed
2013-01-25 14:32 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/d0d2ca046bbb2b054d43a31a4cba76d02949e4e0 [^]
2013-01-25 14:33 AugustoMauch Note Added: 0055869
2013-01-26 02:22 hudsonbot Checkin
2013-01-26 02:22 hudsonbot Note Added: 0055877
2013-01-28 05:59 shankarb Note Added: 0055891
2013-01-28 05:59 shankarb Status resolved => closed
2013-01-28 05:59 shankarb Fixed in Version => 3.0MP20


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker