Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0022835
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POScriticalalways2013-01-18 08:402013-04-03 11:47
ReportermarvintmView Statuspublic 
Assigned Tomarvintm 
PriorityimmediateResolutionfixedFixed in VersionRMP19
StatusclosedFix in branchFixed in SCM revisione0ab141b5327
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toguilleaer
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0022835: Log in doesn't work if there are no orders in the selected terminal

DescriptionCurrently, log in does not work if there are no sales orders in the selected POS terminal. The login works correctly if there are already some orders in this terminal.
Steps To Reproduce- Create a new POS terminal.
- Try to log in the Web POS with this terminal. You will receive an error message: "There was an error loading the POS terminal"
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0055590)
hgbot (developer)
2013-01-18 08:41

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 6db103812932fe857e23d27e8da46867343e7fc9
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Fri Jan 18 08:40:54 2013 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/6db103812932fe857e23d27e8da46867343e7fc9 [^]

Fixed issue 22835. Login will no longer fail if there are no sales orders in this terminal.

---
M src/org/openbravo/retail/posterminal/POSUtils.java
---
(0055591)
hgbot (developer)
2013-01-18 08:42

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 34250a56bcd2d26aeefa485840aed863a521b24a
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Fri Jan 18 08:42:17 2013 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/34250a56bcd2d26aeefa485840aed863a521b24a [^]

Related to issue 22835. Login will no longer fail if there are no sales orders in this terminal.

---
M src/org/openbravo/retail/posterminal/POSUtils.java
---
(0055593)
guilleaer (developer)
2013-01-18 08:48

verified and tested
(0055594)
hgbot (developer)
2013-01-18 09:32

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 5f0511c6d011ff588aa728da24693f4443f021cc
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Fri Jan 18 09:32:32 2013 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/5f0511c6d011ff588aa728da24693f4443f021cc [^]

Related to issue 22835. Login will no longer fail if there are no sales orders in this terminal.

---
M src/org/openbravo/retail/posterminal/POSUtils.java
---
(0055675)
hgbot (developer)
2013-01-21 14:07

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: e0ab141b53272a2f9ffcd7d5b3bfedca1bc6212b
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Fri Jan 18 08:40:54 2013 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/e0ab141b53272a2f9ffcd7d5b3bfedca1bc6212b [^]

Fixed issue 22835. Login will no longer fail if there are no sales orders in this terminal.

---
M src/org/openbravo/retail/posterminal/POSUtils.java
---
(0055676)
hgbot (developer)
2013-01-21 14:07

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 7c72ceb9e9a62a89d373409ca791b5a61fda6294
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Fri Jan 18 08:42:17 2013 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/7c72ceb9e9a62a89d373409ca791b5a61fda6294 [^]

Related to issue 22835. Login will no longer fail if there are no sales orders in this terminal.

---
M src/org/openbravo/retail/posterminal/POSUtils.java
---
(0055677)
hgbot (developer)
2013-01-21 14:07

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: d98e134b62f4cabfffff767f1269f3b3fedf02e3
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Fri Jan 18 09:32:32 2013 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/d98e134b62f4cabfffff767f1269f3b3fedf02e3 [^]

Related to issue 22835. Login will no longer fail if there are no sales orders in this terminal.

---
M src/org/openbravo/retail/posterminal/POSUtils.java
---
(0055868)
guilleaer (developer)
2013-01-25 14:32

closed again.

It was reopened because the emergency pack
(0057575)
hgbot (developer)
2013-04-02 20:02

Repository: erp/pmods/org.openbravo.retail.posterminal-core
Changeset: e0ab141b53272a2f9ffcd7d5b3bfedca1bc6212b
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Fri Jan 18 08:40:54 2013 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal-core/rev/e0ab141b53272a2f9ffcd7d5b3bfedca1bc6212b [^]

Fixed issue 22835. Login will no longer fail if there are no sales orders in this terminal.

---
M src/org/openbravo/retail/posterminal/POSUtils.java
---
(0057576)
hgbot (developer)
2013-04-02 20:02

Repository: erp/pmods/org.openbravo.retail.posterminal-core
Changeset: 7c72ceb9e9a62a89d373409ca791b5a61fda6294
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Fri Jan 18 08:42:17 2013 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal-core/rev/7c72ceb9e9a62a89d373409ca791b5a61fda6294 [^]

Related to issue 22835. Login will no longer fail if there are no sales orders in this terminal.

---
M src/org/openbravo/retail/posterminal/POSUtils.java
---
(0057577)
hgbot (developer)
2013-04-02 20:02

Repository: erp/pmods/org.openbravo.retail.posterminal-core
Changeset: d98e134b62f4cabfffff767f1269f3b3fedf02e3
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Fri Jan 18 09:32:32 2013 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal-core/rev/d98e134b62f4cabfffff767f1269f3b3fedf02e3 [^]

Related to issue 22835. Login will no longer fail if there are no sales orders in this terminal.

---
M src/org/openbravo/retail/posterminal/POSUtils.java
---

- Issue History
Date Modified Username Field Change
2013-01-18 08:40 marvintm New Issue
2013-01-18 08:40 marvintm Assigned To => marvintm
2013-01-18 08:41 hgbot Checkin
2013-01-18 08:41 hgbot Note Added: 0055590
2013-01-18 08:41 hgbot Status new => resolved
2013-01-18 08:41 hgbot Resolution open => fixed
2013-01-18 08:41 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/6db103812932fe857e23d27e8da46867343e7fc9 [^]
2013-01-18 08:42 hgbot Checkin
2013-01-18 08:42 hgbot Note Added: 0055591
2013-01-18 08:48 guilleaer Review Assigned To => guilleaer
2013-01-18 08:48 guilleaer Note Added: 0055593
2013-01-18 08:48 guilleaer Status resolved => closed
2013-01-18 08:48 guilleaer Fixed in Version => RMP19
2013-01-18 09:32 hgbot Checkin
2013-01-18 09:32 hgbot Note Added: 0055594
2013-01-21 14:07 hgbot Checkin
2013-01-21 14:07 hgbot Note Added: 0055675
2013-01-21 14:07 hgbot Status closed => resolved
2013-01-21 14:07 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/6db103812932fe857e23d27e8da46867343e7fc9 [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/e0ab141b53272a2f9ffcd7d5b3bfedca1bc6212b [^]
2013-01-21 14:07 hgbot Checkin
2013-01-21 14:07 hgbot Note Added: 0055676
2013-01-21 14:07 hgbot Checkin
2013-01-21 14:07 hgbot Note Added: 0055677
2013-01-25 14:32 guilleaer Note Added: 0055868
2013-01-25 14:32 guilleaer Status resolved => closed
2013-04-02 20:02 hgbot Checkin
2013-04-02 20:02 hgbot Note Added: 0057575
2013-04-02 20:02 hgbot Status closed => resolved
2013-04-02 20:02 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/e0ab141b53272a2f9ffcd7d5b3bfedca1bc6212b [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal-core/rev/e0ab141b53272a2f9ffcd7d5b3bfedca1bc6212b [^]
2013-04-02 20:02 hgbot Checkin
2013-04-02 20:02 hgbot Note Added: 0057576
2013-04-02 20:02 hgbot Checkin
2013-04-02 20:02 hgbot Note Added: 0057577
2013-04-03 11:47 marvintm Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker