Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0022810
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2013-01-16 16:532013-02-20 04:51
ReportermiruritaView Statuspublic 
Assigned ToAugustoMauch 
PriorityhighResolutionfixedFixed in Version3.0MP20
StatusclosedFix in branchFixed in SCM revisiona7dea24ffd6d
ProjectionnoneETAnoneTarget Version3.0MP20
OSLinux 32 bitDatabasePostgreSQLJava version1.6.0_18
OS VersionCommunity ApplianceDatabase version8.3.9Ant version1.7.1
Product VersionpiSCM revision 
Review Assigned Tomtaal
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0022810: Coming from OB.Utilities.openDirectTab, isOpenDirectModeLeaf is always set to true

DescriptionIf you open a tab with OB.Utilities.openDirectTab
In the same tab you call a process definition which thorws an error (purposely)
In the callback of the process definition, closeProcessPopup() is called
The record is opened in form view and the message bar gets cleared.

If you execute again it works fine, you keep the view (form or grid) and the message gets displayed.

the problem is on 'ob-view-grid.js' with the isOpenDirectModeLeaf property that is set to true.

if (!this.view.isShowingForm && this.isOpenDirectModeLeaf) {
        this.view.editRecord(gridRecord);
      }

Steps To Reproduce[contact me directly if you have any problem to reproduce the issue]

1) Install the following modules
https://code.openbravo.com/erp/mods/org.openbravo.contract/ [^]
https://code.openbravo.com/private/eulen/org.openbravo.contract.hierarchical/ [^]
https://code.openbravo.com/private/eulen/org.openbravo.contract.hierarchical.billing.eulen/ [^]
https://code.openbravo.com/private/eulen/org.openbravo.contract.hierarchical.template/ [^]
https://code.openbravo.com/erp/pmods/org.openbravo.contract.services/ [^]
https://code.openbravo.com/private/eulen/org.openbravo.contract.services.template/ [^]
https://code.openbravo.com/private/eulen/org.openbravo.project.budget/ [^]
https://code.openbravo.com/private/eulen/org.openbravo.contract.hierarchical.eulen/ [^]

2) Apply all the datasets (enterprise module management)

3) Open the Invoice Process Configurator and deactivate the Eulen Contract Billing Process process

4) Open the Role window, select the F&B International Group role, open the View Implementation tab, and add the OBSCNTR_ContractInvoicing view implementation.

5) Log out and Log in.

6) Create a new Contract Header
     Org: Spain
     Business Partner: alimentos
     Start Date: 01-01-2013
     End Date: 31-01-2013
7) Create a new Contract Line
     Select any product
8) Go to Alimentos business partner and block the invoicing
9) Go to "Contract Invoicing" window
     Start Date: 01-01-2013
     End Date: 31-01-2013
10) Click on "Search" button
11) Select first record and click on Process button
12) Realize that the record is opened in form view and you lost the message
   
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00170273.0RC7 closedmtaal After enabling or disabling Heartbeat, the action button goes hidden 

-  Notes
(0056000)
AugustoMauch (developer)
2013-01-31 10:25

Test plan:
- Test that this issue is no longer reproducible
- Test that issue 17027 keeps being not reproducible.
(0056001)
hgbot (developer)
2013-01-31 10:26

Repository: erp/devel/pi
Changeset: a7dea24ffd6d92133cb98c4b1ec5fd0a8e37c401
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Thu Jan 31 10:22:23 2013 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/a7dea24ffd6d92133cb98c4b1ec5fd0a8e37c401 [^]

Fixes issue 22810: Record is not opened in form view, message is not lost

The problem was the after opening a tab using the openDirectTabView function, the first time the ob-view-grid.delayedHandleTargetRecord function was called, the selected record would open in the form view and the grid message would be lost. This behaviour is controlled using the isOpenDirectModeLeaf property.

This property only makes sense when the openDirectTabView function has been called with a targetRecordId (a specific record will be opened). To fix this issue, when the data arrives to the grid, the isOpenDirectModeLeaf property will be deleted unless the property targetRecordId has been set.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
---
(0056096)
hudsonbot (developer)
2013-02-01 22:28

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b070aa80fc76 [^]

Maturity status: Test
(0056542)
hgbot (developer)
2013-02-19 11:14

Repository: erp/devel/pi
Changeset: d9f9d5079dfb14b5495e166d51433f02e92a525c
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Tue Feb 19 11:13:15 2013 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/d9f9d5079dfb14b5495e166d51433f02e92a525c [^]

Related to issue 22810:isOpenDirectModeLeaf deletedin delayedHandleTargetRecord

The property isOpenDirectModeLeaf should not only be deleted in dataArrived when there is not targetRecordId, but also in the delayedHandleTargetRecord function

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
---
(0056543)
mtaal (developer)
2013-02-19 11:15

Reviewed
(0056625)
hudsonbot (developer)
2013-02-20 04:51

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/d828167a9e83 [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2013-01-16 16:53 mirurita New Issue
2013-01-16 16:53 mirurita Assigned To => AugustoMauch
2013-01-16 16:53 mirurita Modules => Core
2013-01-16 16:53 mirurita Triggers an Emergency Pack => No
2013-01-30 15:58 AugustoMauch Steps to Reproduce Updated View Revisions
2013-01-30 18:38 AugustoMauch Steps to Reproduce Updated View Revisions
2013-01-31 09:57 AugustoMauch Relationship added related to 0017027
2013-01-31 10:25 AugustoMauch Note Added: 0056000
2013-01-31 10:25 AugustoMauch Issue Monitored: mtaal
2013-01-31 10:25 AugustoMauch Review Assigned To => mtaal
2013-01-31 10:26 hgbot Checkin
2013-01-31 10:26 hgbot Note Added: 0056001
2013-01-31 10:26 hgbot Status new => resolved
2013-01-31 10:26 hgbot Resolution open => fixed
2013-01-31 10:26 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/a7dea24ffd6d92133cb98c4b1ec5fd0a8e37c401 [^]
2013-02-01 22:28 hudsonbot Checkin
2013-02-01 22:28 hudsonbot Note Added: 0056096
2013-02-19 11:14 hgbot Checkin
2013-02-19 11:14 hgbot Note Added: 0056542
2013-02-19 11:15 mtaal Note Added: 0056543
2013-02-19 11:15 mtaal Status resolved => closed
2013-02-19 11:15 mtaal Fixed in Version => 3.0MP20
2013-02-20 04:51 hudsonbot Checkin
2013-02-20 04:51 hudsonbot Note Added: 0056625


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker