Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0022750
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2013-01-09 11:432013-02-01 22:28
ReporterxabiermerinoView Statuspublic 
Assigned ToAugustoMauch 
PriorityurgentResolutionfixedFixed in Version3.0MP20
StatusclosedFix in branchFixed in SCM revisione035b2855377
ProjectionnoneETAnoneTarget Version3.0MP20
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product Version3.0MP18.1SCM revision 
Review Assigned Tomtaal
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0022750: Wrong behaviour when you filter an amount in grid view

DescriptionWith the Format.xml attached, when you introduce a number of four digits in the box of an amount filter the application will eliminate the first digit
Steps To Reproduce- With the format attached
- Go to Sales invoice
- In grid view introduce 4563 in the box of Total Gross Amount
- Push enter
- Realize that the number is changed to 563
TagsNo tags attached.
Attached Filesxml file icon Format.xml [^] (3,260 bytes) 2013-01-09 11:43

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0055502)
AugustoMauch (developer)
2013-01-14 11:16

The number is being impropertly formatted in this line: https://code.openbravo.com/erp/devel/pi/file/ffb8ac325407/modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-number.js#l593 [^]
(0055566)
shankarb (developer)
2013-01-17 14:04

Closed incorrectly.
(0055588)
hgbot (developer)
2013-01-18 05:21

Repository: erp/devel/pi
Changeset: 91afe03823f7063a563ee4fd722b2fe8506f1c18
Author: Shankar Balachandran <shankar.balachandran <at> openbravo.com>
Date: Fri Jan 18 09:18:50 2013 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/91afe03823f7063a563ee4fd722b2fe8506f1c18 [^]

Fixes Issue 0022750: Wrong behaviour when you filter an amount in grid view

Modified the parameters of OB.Utilities.Number.JSToOBMasked to pick up format from OB.Format instead of the current type.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-number.js
---
(0055599)
hgbot (developer)
2013-01-18 10:32

Repository: erp/devel/pi
Changeset: f798272afb9cd97416acd2a8c205d2a444bee16c
Author: Shankar Balachandran <shankar.balachandran <at> openbravo.com>
Date: Fri Jan 18 15:01:40 2013 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/f798272afb9cd97416acd2a8c205d2a444bee16c [^]

Fixes Issue 22750 : Removed Grouping Symbol

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-number.js
---
(0055600)
AugustoMauch (developer)
2013-01-18 11:03

Before the fix, with the default format, if the user entered i.e. 12345.1 in the Total Gross Amount filter, the value that was shown in the filter was 12345.10. Now, the resulting displayed value is 12345.1.
(0055712)
hudsonbot (developer)
2013-01-22 15:32

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/449aae8be624 [^]

Maturity status: Test
(0055716)
hudsonbot (developer)
2013-01-22 15:32

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/449aae8be624 [^]

Maturity status: Test
(0055794)
hgbot (developer)
2013-01-24 07:27

Repository: erp/devel/pi
Changeset: 7b90716e2170a6b0fa471b8e292575826d5c4c44
Author: Shankar Balachandran <shankar.balachandran <at> openbravo.com>
Date: Thu Jan 24 11:44:21 2013 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/7b90716e2170a6b0fa471b8e292575826d5c4c44 [^]

Related to Issue 22750 : Back out changes

Backout all changes done related to this issue.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-number.js
---
(0055822)
hudsonbot (developer)
2013-01-24 21:40

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/fbbe21bdfeff [^]

Maturity status: Test
(0055916)
hgbot (developer)
2013-01-28 16:30

Repository: erp/devel/pi
Changeset: e035b285537757fe7993c60c6ce028c7e9235879
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Mon Jan 28 16:29:49 2013 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/e035b285537757fe7993c60c6ce028c7e9235879 [^]

Fixes issue 22750: Number format works with decSeparator = ','

Using the format file attached to the issue https://issues.openbravo.com/view.php?id=22750, [^] when a number higher than 999 was entered in a numeric filter, only the last 3 digist remained (i.e., if 1234 was entered, only 234 remained).

This has been fixed by including the group separator and the default grouping size in the call to JSToOBMasked used to format a numeric value.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-number.js
---
(0055932)
mtaal (developer)
2013-01-29 08:52

Reviewed, seems to work fine, strange that the type.groupInterval is not set, but that's not part of this issue.
(0056072)
hudsonbot (developer)
2013-02-01 22:28

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b070aa80fc76 [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2013-01-09 11:43 xabiermerino New Issue
2013-01-09 11:43 xabiermerino Assigned To => AugustoMauch
2013-01-09 11:43 xabiermerino File Added: Format.xml
2013-01-09 11:43 xabiermerino Modules => Core
2013-01-09 11:43 xabiermerino Triggers an Emergency Pack => No
2013-01-09 11:43 xabiermerino Issue Monitored: networkb
2013-01-09 17:02 AugustoMauch Target Version 3.0MP19 => 3.0MP20
2013-01-14 11:16 AugustoMauch Note Added: 0055502
2013-01-17 14:02 shankarb Status new => closed
2013-01-17 14:02 shankarb Resolution open => unable to reproduce
2013-01-17 14:04 shankarb Note Added: 0055566
2013-01-17 14:04 shankarb Status closed => new
2013-01-17 14:04 shankarb Resolution unable to reproduce => open
2013-01-17 14:08 shankarb Assigned To AugustoMauch => shankarb
2013-01-18 05:20 shankarb Status new => scheduled
2013-01-18 05:20 shankarb fix_in_branch => pi
2013-01-18 05:20 shankarb Review Assigned To => AugustoMauch
2013-01-18 05:20 shankarb fix_in_branch pi =>
2013-01-18 05:21 shankarb Issue Monitored: AugustoMauch
2013-01-18 05:21 hgbot Checkin
2013-01-18 05:21 hgbot Note Added: 0055588
2013-01-18 05:21 hgbot Status scheduled => resolved
2013-01-18 05:21 hgbot Resolution open => fixed
2013-01-18 05:21 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/91afe03823f7063a563ee4fd722b2fe8506f1c18 [^]
2013-01-18 10:32 hgbot Checkin
2013-01-18 10:32 hgbot Note Added: 0055599
2013-01-18 10:32 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/91afe03823f7063a563ee4fd722b2fe8506f1c18 [^] => http://code.openbravo.com/erp/devel/pi/rev/f798272afb9cd97416acd2a8c205d2a444bee16c [^]
2013-01-18 11:03 AugustoMauch Note Added: 0055600
2013-01-18 11:03 AugustoMauch Status resolved => new
2013-01-18 11:03 AugustoMauch Resolution fixed => open
2013-01-22 15:32 hudsonbot Checkin
2013-01-22 15:32 hudsonbot Note Added: 0055712
2013-01-22 15:32 hudsonbot Checkin
2013-01-22 15:32 hudsonbot Note Added: 0055716
2013-01-24 07:27 hgbot Checkin
2013-01-24 07:27 hgbot Note Added: 0055794
2013-01-24 21:40 hudsonbot Checkin
2013-01-24 21:40 hudsonbot Note Added: 0055822
2013-01-28 14:24 AugustoMauch Assigned To shankarb => AugustoMauch
2013-01-28 16:29 AugustoMauch Issue End Monitor: AugustoMauch
2013-01-28 16:30 AugustoMauch Issue Monitored: mtaal
2013-01-28 16:30 AugustoMauch Review Assigned To AugustoMauch => mtaal
2013-01-28 16:30 hgbot Checkin
2013-01-28 16:30 hgbot Note Added: 0055916
2013-01-28 16:30 hgbot Status new => resolved
2013-01-28 16:30 hgbot Resolution open => fixed
2013-01-28 16:30 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/f798272afb9cd97416acd2a8c205d2a444bee16c [^] => http://code.openbravo.com/erp/devel/pi/rev/e035b285537757fe7993c60c6ce028c7e9235879 [^]
2013-01-29 08:52 mtaal Note Added: 0055932
2013-01-29 08:52 mtaal Status resolved => closed
2013-01-29 08:52 mtaal Fixed in Version => 3.0MP20
2013-02-01 22:28 hudsonbot Checkin
2013-02-01 22:28 hudsonbot Note Added: 0056072


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker