Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0022645
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2012-12-20 13:372013-01-28 14:32
ReporterngarciaView Statuspublic 
Assigned Toalostale 
PriorityurgentResolutionfixedFixed in Version3.0MP20
StatusclosedFix in branchFixed in SCM revisionc141a066c7d0
ProjectionnoneETAnoneTarget Version3.0MP20
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomtaal
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0022645: A tab without a reference to its parent identifier is not refreshed

DescriptionA tab without a reference to its parent identifier is not refreshed
Steps To ReproduceAn specific example:
Create a new tab for the sales order window
Its associated table should have the C_BPartner_ID column
Add the following sentence to the HQL Where Clause field
   e.businessPartner.id=@Order.businessPartner@
Go to the Sales Order window and select a record
Notice that its child records are not shown until you refresh the tab
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to feature request 0017522 newplatform Information changed in lines tab does not get automatically refreshed while in header does. 

-  Notes
(0055117)
ngarcia (developer)
2012-12-20 13:38

I have a module with this tab implemented, so you could ask me for it
(0055873)
alostale (developer)
2013-01-25 16:05
edited on: 2013-01-25 16:06

Steps to reproduce:
* In Sales Order window create a new tab (level 1)
* Table: AD_User
* HQL Where Clause: e.businessPartner.id=@Order.businessPartner@
* Create fields for this new tab
* Go to the Sales Order window and select a record
* Notice that its child records are not shown until you refresh the tab

(0055874)
hgbot (developer)
2013-01-25 18:57

Repository: erp/devel/pi
Changeset: c141a066c7d09d1cae7ba6c7fe39ae90dd3cbab7
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Fri Jan 25 18:55:48 2013 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/c141a066c7d09d1cae7ba6c7fe39ae90dd3cbab7 [^]

fixed bug 22645: tabs without explicit reference to parent id are not refreshed

The problem was as the subtab was not explicitly setting its parent record (it
was done through where clause), when changing selection in parent an empty
criteria was created preventing request to datasource of being done.

The fix creates for this case a dummy criteria to force request to be triggered.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
---
(0055875)
alostale (developer)
2013-01-25 19:00

This fix touches ob-view-grid which is a very central part of the client application, though it should affect only to this very specific case: sub tabs (this.view.parentView exists) without a specific relationship with its parent (there is no this.view.parentProperty), other possible implications should be checked.
(0055885)
hudsonbot (developer)
2013-01-27 11:34

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/7b271be20db9 [^]

Maturity status: Test
(0055910)
mtaal (developer)
2013-01-28 14:32

Reviewed

- Issue History
Date Modified Username Field Change
2012-12-20 13:37 ngarcia New Issue
2012-12-20 13:37 ngarcia Assigned To => AugustoMauch
2012-12-20 13:37 ngarcia Modules => Core
2012-12-20 13:37 ngarcia Triggers an Emergency Pack => No
2012-12-20 13:37 ngarcia Issue Monitored: networkb
2012-12-20 13:38 ngarcia Note Added: 0055117
2013-01-25 14:08 alostale Relationship added related to 0017522
2013-01-25 14:18 AugustoMauch Assigned To AugustoMauch => alostale
2013-01-25 16:05 alostale Note Added: 0055873
2013-01-25 16:06 alostale Note Edited: 0055873 View Revisions
2013-01-25 16:06 alostale Review Assigned To => mtaal
2013-01-25 18:57 hgbot Checkin
2013-01-25 18:57 hgbot Note Added: 0055874
2013-01-25 18:57 hgbot Status new => resolved
2013-01-25 18:57 hgbot Resolution open => fixed
2013-01-25 18:57 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/c141a066c7d09d1cae7ba6c7fe39ae90dd3cbab7 [^]
2013-01-25 19:00 alostale Note Added: 0055875
2013-01-27 11:34 hudsonbot Checkin
2013-01-27 11:34 hudsonbot Note Added: 0055885
2013-01-28 14:32 mtaal Note Added: 0055910
2013-01-28 14:32 mtaal Status resolved => closed
2013-01-28 14:32 mtaal Fixed in Version => 3.0MP20


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker