Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0022605
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] B. User interfaceminorhave not tried2012-12-17 18:232013-02-01 22:28
ReporteregoitzView Statuspublic 
Assigned ToAugustoMauch 
PriorityhighResolutionfixedFixed in Version3.0MP20
StatusclosedFix in branchFixed in SCM revisionc2a31ef051f5
ProjectionnoneETAnoneTarget Version3.0MP20
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product Version3.0MP18SCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0022605: The window personalization window has mandatory fields with a display login but shown in relation but not filled

DescriptionThe window personalization window has the fields tab and window that have a display login depending on the type selected.
When you save a view from the view toolbar button, row is saved automcatically on that table.
Then if you go to the window to see the record saved, on grid view you can not edit the line because on of the mandatory fields is empty
Steps To Reproduce-Activate the instance with a license
-Go a the sales order windo
-go to form view
-click on view toolbar button
-Save the view to the role that you are using
-Go to window personalization window
-See that a new row has been created
-Edit on grid view. See that the window field is mandatory but it is empty
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0055018)
egoitz (developer)
2012-12-17 18:30

A possible solution is to put the fiels window and form as not mandatory and use a n eventhandler to check if each field has been properly filled or not depending on the type.
(0055620)
hgbot (developer)
2013-01-18 17:45

Repository: erp/devel/pi
Changeset: 6e68249a33aa79469f202131690185d6953f60a9
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Fri Jan 18 17:44:56 2013 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/6e68249a33aa79469f202131690185d6953f60a9 [^]

Related to issue 22605: WindowPersonalization.window field set not mandatory

The window field in the OBUIAPP_UIPersonalization is not mandatory per se, it is mandatory only when the type of the personalization is window. This will be checked using an event handler in a changeset yet to be pushed.

---
M modules/org.openbravo.client.application/src-db/database/sourcedata/AD_COLUMN.xml
---
(0055708)
hgbot (developer)
2013-01-22 14:03

Repository: erp/devel/pi
Changeset: 2070e16b1aee3521be633b47477837d438ac4b16
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Tue Jan 22 14:02:40 2013 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/2070e16b1aee3521be633b47477837d438ac4b16 [^]

Fixes bug 22605: If personalization type is 'Window', window field is mandatory

An Event Handler has been added to check that if a personalization type is 'Window', the window field cannot be null. If the personalization type is 'Tab' then the window field can be null.

---
M modules/org.openbravo.client.application/src-db/database/sourcedata/AD_MESSAGE.xml
A modules/org.openbravo.client.application/src/org/openbravo/client/application/event/WindowPersonalizationEventHandler.java
---
(0055709)
AugustoMauch (developer)
2013-01-22 14:10

Test plan:
In an activated instance, Open Window Personalization as System Admin.
- Open any row with Type = 'Form' (if there isn't any, open any window, click on the Form Personalization toolbar button and change the visibility of a field).
- Try to change the personalization type to window without setting the Window field. Try to save, an error message will be shown. Enter a window in the Window field, and try to save again. The records will be saved successfully.
(0055724)
hudsonbot (developer)
2013-01-22 15:33

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/449aae8be624 [^]

Maturity status: Test
(0055745)
hudsonbot (developer)
2013-01-23 01:15

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/8d2ab0cc2b3d [^]

Maturity status: Test
(0055930)
alostale (developer)
2013-01-29 08:39

When personalization type is Window, it cannot be edited because Tab field is still mandatory: when editing in grid, tab needs to be set (it is not correct), when in form, tab is not even shown because of display logic.
(0055934)
hgbot (developer)
2013-01-29 09:46

Repository: erp/devel/pi
Changeset: c2a31ef051f5ce315a06a1dc6af1fa825ddc6c6f
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Tue Jan 29 09:44:54 2013 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/c2a31ef051f5ce315a06a1dc6af1fa825ddc6c6f [^]

Fixes issue 22605: If personalization type is 'Form', tab field is mandatory

The tab field of the Window Personalization window should not be always mandatory, only when the type field is 'Form'. The tab column is no longer checked as mandatory, and its value is now checked using the WindowPersonalizationHandler.

---
M modules/org.openbravo.client.application/src-db/database/sourcedata/AD_COLUMN.xml
M modules/org.openbravo.client.application/src-db/database/sourcedata/AD_MESSAGE.xml
M modules/org.openbravo.client.application/src/org/openbravo/client/application/event/WindowPersonalizationEventHandler.java
---
(0055981)
alostale (developer)
2013-01-31 07:52

code reviewed + verified in pi@bcabcc4c3b37
(0056075)
hudsonbot (developer)
2013-02-01 22:28

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b070aa80fc76 [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2012-12-17 18:23 egoitz New Issue
2012-12-17 18:23 egoitz Assigned To => dbaz
2012-12-17 18:23 egoitz Modules => Core
2012-12-17 18:23 egoitz Triggers an Emergency Pack => No
2012-12-17 18:30 egoitz Note Added: 0055018
2012-12-17 18:38 dbaz Assigned To dbaz => AugustoMauch
2013-01-18 17:45 hgbot Checkin
2013-01-18 17:45 hgbot Note Added: 0055620
2013-01-22 14:02 AugustoMauch Issue Monitored: alostale
2013-01-22 14:03 AugustoMauch Review Assigned To => alostale
2013-01-22 14:03 hgbot Checkin
2013-01-22 14:03 hgbot Note Added: 0055708
2013-01-22 14:03 hgbot Status new => resolved
2013-01-22 14:03 hgbot Resolution open => fixed
2013-01-22 14:03 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/2070e16b1aee3521be633b47477837d438ac4b16 [^]
2013-01-22 14:10 AugustoMauch Note Added: 0055709
2013-01-22 15:33 hudsonbot Checkin
2013-01-22 15:33 hudsonbot Note Added: 0055724
2013-01-23 01:15 hudsonbot Checkin
2013-01-23 01:15 hudsonbot Note Added: 0055745
2013-01-29 08:39 alostale Note Added: 0055930
2013-01-29 08:39 alostale Status resolved => new
2013-01-29 08:39 alostale Resolution fixed => open
2013-01-29 09:46 hgbot Checkin
2013-01-29 09:46 hgbot Note Added: 0055934
2013-01-29 09:46 hgbot Status new => resolved
2013-01-29 09:46 hgbot Resolution open => fixed
2013-01-29 09:46 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/2070e16b1aee3521be633b47477837d438ac4b16 [^] => http://code.openbravo.com/erp/devel/pi/rev/c2a31ef051f5ce315a06a1dc6af1fa825ddc6c6f [^]
2013-01-31 07:52 alostale Note Added: 0055981
2013-01-31 07:52 alostale Status resolved => closed
2013-01-31 07:52 alostale Fixed in Version => 3.0MP20
2013-02-01 22:28 hudsonbot Checkin
2013-02-01 22:28 hudsonbot Note Added: 0056075


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker