Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0021955
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] Y. DBSourceManagermajoralways2012-10-16 17:202012-12-04 15:22
ReporteregoitzView Statuspublic 
Assigned ToAugustoMauch 
PriorityurgentResolutionfixedFixed in Version3.0MP18
StatusclosedFix in branchFixed in SCM revision92fed4a43a8c
ProjectionnoneETAnoneTarget Version3.0MP18
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product Version3.0MP16SCM revision 
Review Assigned Tomarvintm
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0021955: The naming exceptions do not work with unique constraints

DescriptionIf you add on the exceptions tab of a module a unique constraint because you want to change it, after export it is correctly exported to your module but fails on the update.
The error message can be as following:


There are multiple uniques or indices in table M_PRODUCT_CATEGORY with the name M_PRODUCT_CATEGORY_VALUE
Steps To Reproduce-Define a new module and check is as indeveloment
-go to exception tab and add a new line for unique constraint.
Table=M_PRODUCT_CATEGORY
object name=M_PRODUCT_CATEGORY_VALUE
-Export the module with ant export.database.
-After that execute the update.dabase

You get the following error:


There are multiple uniques or indices in table M_PRODUCT_CATEGORY with the name M_PRODUCT_CATEGORY_VALUE
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0053765)
egoitz (developer)
2012-10-29 13:36

The exceptions are used to modify elements from other modules. In the case of the unique constraint adding a new column to the constraint has a risk because selects of the application can be designed for the constraint defined. Changing it can make the select to return different values than expected producing an incorrect behavior on the application.
(0054314)
hgbot (developer)
2012-11-19 13:49

Repository: erp/devel/pi
Changeset: 142819e9e1e38d992c985b05d781cc09cbbd52ed
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Mon Nov 19 13:49:27 2012 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/142819e9e1e38d992c985b05d781cc09cbbd52ed [^]

Fixes issue 21955: Naming exceptions works with unique constraints

There was a bug that prevented exisint unique constraints from being removed. After fixing this bug, the update.database task no longer fails after creating a unique constraint naming exception

---
M src-db/database/lib/dbsourcemanager.jar
---
(0054315)
hgbot (developer)
2012-11-19 15:01

Repository: erp/devel/dbsm-main
Changeset: 92fed4a43a8c3304716ad952d101739af30cd006
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Mon Nov 19 15:00:49 2012 +0100
URL: http://code.openbravo.com/erp/devel/dbsm-main/rev/92fed4a43a8c3304716ad952d101739af30cd006 [^]

Fixes issue 21955: Naming exceptions works with unique constraints

---
M src/org/apache/ddlutils/model/Table.java
---
(0054398)
hudsonbot (developer)
2012-11-21 06:07

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/c3c5e61b0164 [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2012-10-16 17:20 egoitz New Issue
2012-10-16 17:20 egoitz Assigned To => marvintm
2012-10-16 17:20 egoitz Modules => Core
2012-10-16 18:13 egoitz Issue Monitored: networkb
2012-10-29 13:36 egoitz Note Added: 0053765
2012-10-29 13:36 egoitz Target Version 3.0MP17 => 3.0MP18
2012-11-19 13:43 AugustoMauch Review Assigned To => marvintm
2012-11-19 13:43 AugustoMauch Assigned To marvintm => AugustoMauch
2012-11-19 13:43 AugustoMauch Issue Monitored: marvintm
2012-11-19 13:49 hgbot Checkin
2012-11-19 13:49 hgbot Note Added: 0054314
2012-11-19 13:49 hgbot Status new => resolved
2012-11-19 13:49 hgbot Resolution open => fixed
2012-11-19 13:49 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/142819e9e1e38d992c985b05d781cc09cbbd52ed [^]
2012-11-19 15:01 hgbot Checkin
2012-11-19 15:01 hgbot Note Added: 0054315
2012-11-19 15:01 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/142819e9e1e38d992c985b05d781cc09cbbd52ed [^] => http://code.openbravo.com/erp/devel/dbsm-main/rev/92fed4a43a8c3304716ad952d101739af30cd006 [^]
2012-11-21 06:07 hudsonbot Checkin
2012-11-21 06:07 hudsonbot Note Added: 0054398
2012-12-04 15:22 marvintm Status resolved => closed
2012-12-04 15:22 marvintm Fixed in Version => 3.0MP18


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker