Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0021764
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajorhave not tried2012-09-26 13:552012-09-28 14:39
ReporterAugustoMauchView Statuspublic 
Assigned ToAugustoMauch 
PriorityimmediateResolutionfixedFixed in Version3.0MP16
StatusclosedFix in branchpiFixed in SCM revision22cb1b467fde
ProjectionnoneETAnoneTarget Version3.0MP16
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Todbaz
Web browser
ModulesCore
Regression levelPre packaging ( pi )
Regression date2012-09-11
Regression introduced in release
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/7b629f7cbfe32c335da14d978b46253380c7254d [^]
Triggers an Emergency PackNo
Summary

0021764: Wrong records appear when processing several invoices.

DescriptionWhen several invoices are completed, after the complete process finishes some unexpected records appear in the lines tab.
Steps To Reproduce1- Open the Sales Invoice window
2- In grid mode, create a sales invoice
3- In grid mode, create a line, and complete the invoice.
4- In grid mode, create another Sales Invoice
5- In grid mode, create a new line for the new sales invoice.
6- Complete the new sales invoice. When the process finishes, the line of the invoice that was created in the step 2 will appear along with the line that was created in the step 5.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0052631)
hgbot (developer)
2012-09-26 14:16

Repository: erp/devel/pi
Changeset: 22cb1b467fde7b0037ab26d75287fa30dbe68074
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Wed Sep 26 14:15:54 2012 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/22cb1b467fde7b0037ab26d75287fa30dbe68074 [^]

Fixes issue 21764: Only the proper records are shown after completing an order

The problem was caused by the fix of the issue 21437. Some logic was added to ensure that the recently created records were shown after completing a process, even if the do not comply with the filters. The problem was that this was done on a tab level, without taking into account that their parent record might not be the same.

This has been fixed, and only the child records of the current parent record are shown.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/ob-view-form.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/main/ob-standard-view.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/toolbar/ob-action-button.js
---
(0052632)
AugustoMauch (developer)
2012-09-26 14:17

Reopened to enter closed by field
(0052635)
dbaz (developer)
2012-09-26 16:29

Reviewed @ changeset: 18025 - 22cb1b467fde
(0052910)
hudsonbot (developer)
2012-09-28 14:39

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6d2f8cffd4b1 [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2012-09-26 13:55 AugustoMauch New Issue
2012-09-26 13:55 AugustoMauch Assigned To => AugustoMauch
2012-09-26 13:55 AugustoMauch Modules => Core
2012-09-26 13:57 AugustoMauch Regression level => Pre packaging ( pi )
2012-09-26 13:57 AugustoMauch Regression date => 2012-09-11
2012-09-26 13:57 AugustoMauch Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/7b629f7cbfe32c335da14d978b46253380c7254d [^]
2012-09-26 14:16 hgbot Checkin
2012-09-26 14:16 hgbot Note Added: 0052631
2012-09-26 14:16 hgbot Status new => resolved
2012-09-26 14:16 hgbot Resolution open => fixed
2012-09-26 14:16 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/22cb1b467fde7b0037ab26d75287fa30dbe68074 [^]
2012-09-26 14:17 AugustoMauch Note Added: 0052632
2012-09-26 14:17 AugustoMauch Status resolved => new
2012-09-26 14:17 AugustoMauch Resolution fixed => open
2012-09-26 14:17 AugustoMauch Issue Monitored: dbaz
2012-09-26 14:18 AugustoMauch Closed by => dbaz
2012-09-26 14:18 AugustoMauch Status new => scheduled
2012-09-26 14:18 AugustoMauch fix_in_branch => pi
2012-09-26 14:18 AugustoMauch Status scheduled => resolved
2012-09-26 14:18 AugustoMauch Resolution open => fixed
2012-09-26 16:29 dbaz Issue End Monitor: dbaz
2012-09-26 16:29 dbaz Note Added: 0052635
2012-09-26 16:29 dbaz Status resolved => closed
2012-09-26 16:29 dbaz Fixed in Version => 3.0MP16
2012-09-28 14:39 hudsonbot Checkin
2012-09-28 14:39 hudsonbot Note Added: 0052910


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker