Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0021728
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] B. User interfaceminorhave not tried2012-09-24 14:092012-10-11 18:42
ReporterplujanView Statuspublic 
Assigned Todbaz 
PrioritynormalResolutionfixedFixed in Version3.0MP17
StatusclosedFix in branchpiFixed in SCM revision9b7cc13eaec9
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionmainSCM revision 
Review Assigned ToAugustoMauch
Web browserApple Safari, Google Chrome
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0021728: Focus "splits" in completed invoices

DescriptionWhen navigating from child to parent row, if parent row is a completed invoice, the focus (color orange in borders) change to the header, but is still possible to move and edit the lines using keyboard.
Steps To ReproduceNote: issue "real" steps start on step 6, the previous ones are data preparation.

1. Login as Openbravo
2. Go to Sales Invoice window
3. Create a new record for "Alimentos y Supermercados" partner and save it.
4. Create 3 lines for this header
5. Complete the Invoice
6. Open the invoice in Form view. All the fields but "Description" are disabled.
7. Use Alt+DownArrow to go to child tabs (that are in grid vew)
8. Press Esc to move focus to Lines' grid and hit Down arrow twice to get positioned in the second record,
9. Use Alt+UpArrow to return to parent tab. Orange side bar and header's top orange bar show focus has been moved to header. However, if you use Arrow Up and Down keys, you can still move the Lines' grid.
TagsNo tags attached.
Attached Filesdiff file icon fix.diff [^] (1,384 bytes) 2012-10-01 17:09 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0052968)
dbaz (developer)
2012-10-01 17:10
edited on: 2012-10-01 17:13

Added "fix.diff" with the proposed fix.

The problem was that Smartclient returns as
this.viewForm.getFocusItem
the first input of the form, and sometimes is not focusable.

Now the logic is:
* Check if last focused element can still be focused, if it is the case, focus it and done
* Check if this.viewForm.getFocusItem is focusable, if it is the case, focus it and done
* Iterate in all form items and focus the first one that can be focusable.

(0053059)
hgbot (developer)
2012-10-04 20:19

Repository: erp/devel/pi
Changeset: 9b7cc13eaec95832971341318b7e2f93512cbf22
Author: David Baz Fayos <david.baz <at> openbravo.com>
Date: Thu Oct 04 20:15:29 2012 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/9b7cc13eaec95832971341318b7e2f93512cbf22 [^]

Fixed issue 21728: Now when going back to child/parent tab, the focus remains in the same previous place

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/main/ob-standard-view.js
---
(0053239)
hudsonbot (developer)
2012-10-11 07:50

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/63dfc135f2a1 [^]

Maturity status: Test
(0053325)
AugustoMauch (developer)
2012-10-11 18:42

Code reviewed and verified in pi@ae79cd15bab6

- Issue History
Date Modified Username Field Change
2012-09-24 14:09 plujan New Issue
2012-09-24 14:09 plujan Assigned To => dbaz
2012-09-24 14:09 plujan Web browser => Apple Safari, Google Chrome
2012-09-24 14:09 plujan Modules => Core
2012-10-01 17:09 dbaz Review Assigned To => AugustoMauch
2012-10-01 17:09 dbaz Web browser Apple Safari, Google Chrome => Apple Safari, Google Chrome
2012-10-01 17:09 dbaz Issue Monitored: AugustoMauch
2012-10-01 17:09 dbaz File Added: fix.diff
2012-10-01 17:10 dbaz Note Added: 0052968
2012-10-01 17:13 dbaz Note Edited: 0052968 View Revisions
2012-10-02 09:39 AugustoMauch Status new => scheduled
2012-10-02 09:39 AugustoMauch fix_in_branch => pi
2012-10-04 20:19 hgbot Checkin
2012-10-04 20:19 hgbot Note Added: 0053059
2012-10-04 20:19 hgbot Status scheduled => resolved
2012-10-04 20:19 hgbot Resolution open => fixed
2012-10-04 20:19 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/9b7cc13eaec95832971341318b7e2f93512cbf22 [^]
2012-10-11 07:50 hudsonbot Checkin
2012-10-11 07:50 hudsonbot Note Added: 0053239
2012-10-11 18:42 AugustoMauch Note Added: 0053325
2012-10-11 18:42 AugustoMauch Status resolved => closed
2012-10-11 18:42 AugustoMauch Fixed in Version => 3.0MP17


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker