Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0021592
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajoralways2012-09-10 18:012012-10-24 17:28
ReporterjecharriView Statuspublic 
Assigned Toguilleaer 
PriorityhighResolutionfixedFixed in Version
StatusclosedFix in branchpiFixed in SCM revisionb88633826b3b
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned To
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0021592: WebPOS does not take into account the flag "allow stock negative"

DescriptionWebPOS does not take into account the flag "allow stock negative".

It does matter if you have or not have checked this flag in window "Client" because WebPOS does not verify when is completing a "goods shipments"
Steps To Reproduce-Go to window "Client" --> tab "Information" and uncheck "Allow negative stock".

-Go to window "physical inventory" and put one product without stock (equal to 0)

-Go to WebPOS and create and pay a ticket with this product.

-Go to "stock report" and verify that a new entry has been created with negative stock
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0051975)
jecharri (developer)
2012-09-10 18:05

12/10/2012 7:03 AM
Ticket 16823
(0052139)
hgbot (developer)
2012-09-14 14:08

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: b88633826b3bdefea60ae35c19ae62e49c3229a6
Author: Guillermo Álvarez de Eulate <guillermo.alvarez <at> openbravo.com>
Date: Fri Sep 14 14:07:30 2012 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/b88633826b3bdefea60ae35c19ae62e49c3229a6 [^]

fixed issue 21592. If client doesn't allow negative stock the orders which results on a negative stock are not processed and added to the error list

---
M src-db/database/sourcedata/AD_MESSAGE.xml
M src/org/openbravo/retail/posterminal/OrderLoader.java
---
(0052314)
guilleaer (developer)
2012-09-24 12:05

Reopened because the fix is not valid.

Bellow is explained the desired behavior:

1. Solution will be provided as a module.
2. If web POS is working online the stock will be validated before add a product to the list of sold products.
  2.1 No stock: A modal pop up will be shown explaining the problem that is happening. The pronduct won't be added to the ticket lines
  2.2 stock avalable: Go ahead

3. If web POS is working offline, a modal pop up will be shown (this can be set by a global preference), after add lines to the ticket. This modal will explain that a stock check cannot be done. The user can continue with the process or cancel it.
  3.1: cancel. The product won't be added to the ticket lines
  3.2: continue. The product will be added to the product line. When the ticket is closed the order will be stored in the local database and then (when the system change to online) will be processed by the backend. The backend will process the order in all cases, also if there is not stock
(0052806)
hgbot (developer)
2012-09-26 18:06

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: e0a84b893e1cc9304cfb5673ad4f6aaaf6105c3d
Author: Guillermo Álvarez de Eulate <guillermo.alvarez <at> openbravo.com>
Date: Wed Sep 26 18:05:42 2012 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/e0a84b893e1cc9304cfb5673ad4f6aaaf6105c3d [^]

related to issue 21592: The fix has been removed because is not valid

---
M src-db/database/sourcedata/AD_MESSAGE.xml
M src/org/openbravo/retail/posterminal/OrderLoader.java
---
(0052937)
hgbot (developer)
2012-09-30 13:52

Repository: erp/pmods/org.openbravo.retail.posterminal-discounts
Changeset: e0a84b893e1cc9304cfb5673ad4f6aaaf6105c3d
Author: Guillermo Álvarez de Eulate <guillermo.alvarez <at> openbravo.com>
Date: Wed Sep 26 18:05:42 2012 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal-discounts/rev/e0a84b893e1cc9304cfb5673ad4f6aaaf6105c3d [^]

related to issue 21592: The fix has been removed because is not valid

---
M src-db/database/sourcedata/AD_MESSAGE.xml
M src/org/openbravo/retail/posterminal/OrderLoader.java
---
(0053020)
guilleaer (developer)
2012-10-03 17:39

This issue has been closed because a module has been created to support this functionality.

This module checks the stock when a product is added to the ticket and when the quantity of a ticket line is changed.

Here is the documentation:
http://wiki.openbravo.com/w/index.php?title=Projects:RetailStockValidation [^]
Here is the module:
https://code.openbravo.com/erp/pmods/org.openbravo.retail.stockvalidation/ [^]

This module will be published at the same time of RMP16
(0053661)
adrianromero (manager)
2012-10-24 17:28

Closed for RMP16

- Issue History
Date Modified Username Field Change
2012-09-10 18:01 jecharri New Issue
2012-09-10 18:01 jecharri Assigned To => adrianromero
2012-09-10 18:05 jecharri Note Added: 0051975
2012-09-14 14:08 hgbot Checkin
2012-09-14 14:08 hgbot Note Added: 0052139
2012-09-14 14:08 hgbot Status new => resolved
2012-09-14 14:08 hgbot Resolution open => fixed
2012-09-14 14:08 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/b88633826b3bdefea60ae35c19ae62e49c3229a6 [^]
2012-09-24 12:05 guilleaer Assigned To adrianromero => guilleaer
2012-09-24 12:05 guilleaer Note Added: 0052314
2012-09-24 12:05 guilleaer Status resolved => new
2012-09-24 12:05 guilleaer Resolution fixed => open
2012-09-24 12:05 guilleaer Status new => scheduled
2012-09-24 12:05 guilleaer fix_in_branch => pi
2012-09-26 18:06 hgbot Checkin
2012-09-26 18:06 hgbot Note Added: 0052806
2012-09-30 13:52 hgbot Checkin
2012-09-30 13:52 hgbot Note Added: 0052937
2012-10-03 17:39 guilleaer Note Added: 0053020
2012-10-03 17:39 guilleaer Status scheduled => resolved
2012-10-03 17:39 guilleaer Resolution open => fixed
2012-10-24 17:28 adrianromero Note Added: 0053661
2012-10-24 17:28 adrianromero Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker