Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0021525
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2012-08-31 14:572012-09-26 17:18
ReportermiruritaView Statuspublic 
Assigned ToAugustoMauch 
PriorityhighResolutionfixedFixed in Version3.0MP15
StatusclosedFix in branchFixed in SCM revision280ef09a637d
ProjectionnoneETAnoneTarget Version
OSLinux 32 bitDatabasePostgreSQLJava version1.6.0_18
OS VersionCommunity ApplianceDatabase version8.3.9Ant version1.7.1
Product VersionpiSCM revision 
Review Assigned Tomarvintm
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0021525: package.module WAD validation is failing in some circunstances

DescriptionAssume a project can define which is the parent project (c_project_parent_id).
C_PROJECT
 + c_project_id
 + name
 + value
 + c_project_parent_id

In the previous scenario if you create a tab based on c_project table and you show parent project information using property path it works but when you package the module the wad validation throws an error.
Steps To ReproduceScenario I
1) Prepare an workspace the following pi branch with https://code.openbravo.com/erp/devel/pi-contract [^]
3) Make a clone of the following module
https://code.openbravo.com/private/eulen/org.openbravo.contract.hierarchical/ [^]
4) Log in as system administrator
5) Go to Contract window
6) Go to Lines tab
7) Create a new field:
 - Module: Hierarchical Contract Management
 - Name: test
 - Property: obhcntrProjectParent.searchKey
 - Displayed: Y
 - Displayed Length: 20
8) ant export.database
9) ant package.module -Dmodule=org.openbravo.contract.hierarchical

package.module:
     [echo] Validating Module...
[WADValidation] 0 [main] ERROR org.openbravo.wad.validation.WADValidationResult - +++++++++++++++++++++++++++++++++++++++++++++++++++
[WADValidation] 26 [main] ERROR org.openbravo.wad.validation.WADValidationResult - Errors for Validation type: Tabs with multiple fields for same column
[WADValidation] 39 [main] ERROR org.openbravo.wad.validation.WADValidationResult - +++++++++++++++++++++++++++++++++++++++++++++++++++
[WADValidation] 51 [main] ERROR org.openbravo.wad.validation.WADValidationResult - Error in field Search Key. There are more than one fields pointing to the column Search Key in the tab Lines of the Contract window.
[WADValidation] 67 [main] ERROR org.openbravo.wad.validation.WADValidationResult - Error in field test. There are more than one fields pointing to the column Search Key in the tab Lines of the Contract window.
[WADValidation] 74 [main] INFO org.openbravo.wad.validation.WADValidationResult - Module Hierarchical Contract Management does not comply with Openbravo naming rules.
[WADValidation] 81 [main] INFO org.openbravo.wad.validation.WADValidationResult - The rebuild process has completed successfully but this module
[WADValidation] 87 [main] INFO org.openbravo.wad.validation.WADValidationResult - might cause conflicts with other modules in the future.
[WADValidation] 95 [main] INFO org.openbravo.wad.validation.WADValidationResult - Please request the author of this module to produce a new version
[WADValidation] 102 [main] INFO org.openbravo.wad.validation.WADValidationResult - that addresses these violations.
Proposed SolutionThe tab is working and displaying the information. Probably this validation should be ignored for this particular case.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
has duplicate defect 0023522 closedAugustoMauch Wad validation error while creating two different property fields on a window pointing to the same ad_column_id 
related to defect 0021943 acknowledgedplatform smartbuild WAD validation is failing in some circunstances 

-  Notes
(0051715)
mirurita (developer)
2012-08-31 15:02

This is an important issue for Contract management project.
(0051925)
hgbot (developer)
2012-09-07 12:07

Repository: erp/devel/pi
Changeset: 280ef09a637d929a2dce30db91968e51360d64b4
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Fri Sep 07 12:06:24 2012 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/280ef09a637d929a2dce30db91968e51360d64b4 [^]

Fixes issue 21525: Adaps WAD validation to support property paths

One of the WAD validations checks if there exists in a tab multiple fields that point to the same column. This validation does not apply to property paths, because even though they point to the same column, they show the information about a parent tab.

---
M src-wad/src/org/openbravo/wad/validation/WADValidator_data.xsql
---
(0052710)
hudsonbot (developer)
2012-09-26 17:18

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b780e90c6452 [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2012-08-31 14:57 mirurita New Issue
2012-08-31 14:57 mirurita Assigned To => alostale
2012-08-31 14:57 mirurita Modules => Core
2012-08-31 15:02 mirurita Note Added: 0051715
2012-09-03 09:47 azabaleta Issue Monitored: azabaleta
2012-09-03 10:17 AugustoMauch Assigned To alostale => AugustoMauch
2012-09-07 12:03 AugustoMauch Closed by => marvintm
2012-09-07 12:07 hgbot Checkin
2012-09-07 12:07 hgbot Note Added: 0051925
2012-09-07 12:07 hgbot Status new => resolved
2012-09-07 12:07 hgbot Resolution open => fixed
2012-09-07 12:07 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/280ef09a637d929a2dce30db91968e51360d64b4 [^]
2012-09-25 11:15 marvintm Status resolved => closed
2012-09-25 11:15 marvintm Fixed in Version => 3.0MP15
2012-09-26 17:18 hudsonbot Checkin
2012-09-26 17:18 hudsonbot Note Added: 0052710
2012-10-16 08:35 mirurita Relationship added related to 0021943
2013-04-10 13:28 AugustoMauch Relationship added has duplicate 0023522


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker