Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0021475
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 02. Master data managementminoralways2012-08-29 11:322012-09-28 14:39
ReporterpsanjuanView Statuspublic 
Assigned Tovmromanos 
PriorityurgentResolutionfixedFixed in Version
StatusclosedFix in branchpiFixed in SCM revisionf8feb3f59b04
ProjectionnoneETAnoneTarget Version
OSLinux 32 bitDatabaseOracleJava version1.6
OS VersionUbuntu 8.04.1Database version11.1.0.6.0Ant version1.7.0
Product VersionSCM revision 
Review Assigned Todmiguelez
Web browserGoogle Chrome
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0021475: There are few "Movement Type" which must be hidden from the list

DescriptionThere are few "Movement Type" which must be hidden from the list
Steps To ReproduceNavigate to product window, transactions tab.
Go to Movement Type and display the list of Movement Type.
Realize that there are 2 which are not used and cause confusion with "Customer/Vendor Return" new feature.
Those ones are:

Customer Return
Vendor Return

A customer return creates a + good shipment movement type
A vendor return creates a - good receipt movement type

therefore those movements are not used and could cause confusion.

Same applies to Work Order + and Work Order -
Above ones are no longer used.

It does not apply, it must be an error, this kind of transaction does not create any warehouse movement. In manufacturing, just the previous transaction type refers to movement. I have spoken with Gorka and he agrees
Proposed SolutionHide from the movement type list below two movements:

Customer Return
Vendor Return
Work Order +
Work Order -
TagsOB3 Documentation
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00216703.0MP16 closedioritzCia Some M_transaction "movement types" are not used 

-  Notes
(0052589)
vmromanos (developer)
2012-09-25 16:52

The Product | Transactions tab is a readonly tab which is automatically populated by external processes.

There is no way to list the different Movement types because you can't not create a new record inside this tab.

Moreover, in the list the Customer Returns and Vendor Returns elements are currently deactivated so it's impossible to show them. (Work Order + and Work Order - are active)

I can't understand where the bug is.
Could you please explain deeply the steps to reproduce and your proposed solution?
(0052594)
dmiguelez (developer)
2012-09-25 17:55

In Issue 21670 the Movement Types Customer Return and Vendor Return has been deactivated.

It is only left to deactivate Work Order + and Work Order -
(0052595)
psanjuan (manager)
2012-09-26 09:21

Agree. Please deactivate Work Order + and Work Order -
Thanks.
(0052612)
hgbot (developer)
2012-09-26 10:38

Repository: erp/devel/pi
Changeset: f8feb3f59b0441bb632e3cefecd3f8e99438be7f
Author: Víctor Martínez Romanos <victor.martinez <at> openbravo.com>
Date: Wed Sep 26 09:56:30 2012 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/f8feb3f59b0441bb632e3cefecd3f8e99438be7f [^]

Fixed bug 21475: Deactivate two Movement Types:
Work Order +
Work Order -

---
M src-db/database/sourcedata/AD_REF_LIST.xml
---
(0052638)
dmiguelez (developer)
2012-09-26 16:45

Code Review + Testing OK
(0052906)
hudsonbot (developer)
2012-09-28 14:39

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6d2f8cffd4b1 [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2012-08-29 11:32 psanjuan New Issue
2012-08-29 11:32 psanjuan Assigned To => mirurita
2012-08-29 11:32 psanjuan Web browser => Google Chrome
2012-08-29 11:32 psanjuan Modules => Core
2012-08-29 11:33 psanjuan Tag Attached: OB3 Documentation
2012-08-30 14:53 psanjuan Web browser Google Chrome => Google Chrome
2012-08-30 14:53 psanjuan Steps to Reproduce Updated View Revisions
2012-08-30 14:53 psanjuan Proposed Solution updated
2012-09-18 13:32 psanjuan Web browser Google Chrome => Google Chrome
2012-09-18 13:32 psanjuan Type design defect => defect
2012-09-25 16:36 vmromanos Assigned To mirurita => vmromanos
2012-09-25 16:36 vmromanos Status new => scheduled
2012-09-25 16:36 vmromanos fix_in_branch => pi
2012-09-25 16:52 vmromanos Note Added: 0052589
2012-09-25 16:52 vmromanos Status scheduled => feedback
2012-09-25 17:54 dmiguelez Relationship added related to 0021670
2012-09-25 17:55 dmiguelez Note Added: 0052594
2012-09-26 09:21 psanjuan Note Added: 0052595
2012-09-26 09:48 vmromanos Status feedback => scheduled
2012-09-26 10:38 hgbot Checkin
2012-09-26 10:38 hgbot Note Added: 0052612
2012-09-26 10:38 hgbot Status scheduled => resolved
2012-09-26 10:38 hgbot Resolution open => fixed
2012-09-26 10:38 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/f8feb3f59b0441bb632e3cefecd3f8e99438be7f [^]
2012-09-26 16:45 dmiguelez Closed by => dmiguelez
2012-09-26 16:45 dmiguelez Note Added: 0052638
2012-09-26 16:45 dmiguelez Status resolved => closed
2012-09-28 14:39 hudsonbot Checkin
2012-09-28 14:39 hudsonbot Note Added: 0052906


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker