Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0021470
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 00. Application dictionarymajoralways2012-08-28 15:362012-09-26 17:18
ReporterVictorVillarView Statuspublic 
Assigned ToAugustoMauch 
PriorityurgentResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision86cade425389
ProjectionnoneETAnoneTarget Version3.0MP16
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product Version3.0MP13SCM revision 
Review Assigned Tomigueldejuana
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0021470: operator 'Starts with' and 'contains' does not work properly in Suggestion box and in Popup window

Descriptionoperator 'Starts with' and 'contains' does not work properly in Suggestion box and in Popup window
Steps To ReproduceAs Systema admin role,
Go to reference window
  select Product reference
in the defined selector tab check that it is defined Starts with in Suggestion Text Match Style and in Popup Text Match Style "Starts with"

As Group admin role,
Go to Sales Order window
  Create a new one for Org: F&B ESpaña
 Go to lines tab
    create a new one,
       write "energéticas" in the product suggestion box realise that "Bebidas Energéticas" appears, but it should not. because we defined the text match as Starts with, and "energéticas" is not the beggining of the name.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00220313.0MP17 closedshankarb Now selectors are working properly but not as before 

-  Notes
(0051922)
hgbot (developer)
2012-09-07 11:51

Repository: erp/devel/pi
Changeset: 86cade425389ee03239042916bcbe98d473cce25
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Fri Sep 07 11:50:33 2012 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/86cade425389ee03239042916bcbe98d473cce25 [^]

Fixes issue 21470: Selectors with 'startsWith' text match style fixed

Before the fix, when some text was entered in a selector control, all options that contained that text were shown. This happened even if the suggestion text match style was set to 'Starts with', where in that case only the options that contains the text as a prefix should have been shown.

---
M modules/org.openbravo.userinterface.selector/web/org.openbravo.userinterface.selector/js/ob-selector-item.js
---
(0052105)
VictorVillar (developer)
2012-09-14 09:29

Verified
(0052708)
hudsonbot (developer)
2012-09-26 17:18

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b780e90c6452 [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2012-08-28 15:36 VictorVillar New Issue
2012-08-28 15:36 VictorVillar Assigned To => alostale
2012-08-28 15:36 VictorVillar Modules => Core
2012-08-28 15:37 VictorVillar Issue Monitored: networkb
2012-08-29 11:48 VictorVillar Target Version 3.0MP15 => 3.0MP16
2012-09-06 11:29 AugustoMauch Assigned To alostale => AugustoMauch
2012-09-06 11:29 AugustoMauch Status new => acknowledged
2012-09-06 11:30 AugustoMauch Status acknowledged => scheduled
2012-09-06 11:30 AugustoMauch fix_in_branch => pi
2012-09-07 11:48 AugustoMauch Closed by => migueldejuana
2012-09-07 11:48 AugustoMauch fix_in_branch pi =>
2012-09-07 11:51 hgbot Checkin
2012-09-07 11:51 hgbot Note Added: 0051922
2012-09-07 11:51 hgbot Status scheduled => resolved
2012-09-07 11:51 hgbot Resolution open => fixed
2012-09-07 11:51 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/86cade425389ee03239042916bcbe98d473cce25 [^]
2012-09-14 09:29 VictorVillar Note Added: 0052105
2012-09-14 09:29 VictorVillar Status resolved => closed
2012-09-26 17:18 hudsonbot Checkin
2012-09-26 17:18 hudsonbot Note Added: 0052708
2012-10-22 16:16 jecharri Relationship added related to 0022031


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker