Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0021259
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajorhave not tried2012-07-31 10:532012-09-26 17:19
ReportershuehnerView Statuspublic 
Assigned Tomarvintm 
PrioritynormalResolutionfixedFixed in Version3.0MP16
StatusclosedFix in branchFixed in SCM revisiona8f432b843b5
ProjectionnoneETAnoneTarget Version3.0MP16
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision0e920d5062b1 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0021259: export.sample.data/export-client fails with ad_ref_data* having rows pointing to no longer installed modules.

DescriptionWhen installing modules containing datasets, and applying those datasets in a new client technically rows in the ad_ref_data* tables are created which among others have a field ad_module_id pointing to the module containing the datasets.

When now one of those modules are uninstalled this ad_module_id field still has a module-uuid but it is not pointing to a ad_module table row. This is allowed in db-level as intentionally no fk is in place for that column.

However dal when used by export.sample.data/export-client does check the FK relation and makes the export.sample.data fail.

Reproducible in current retail demo sampledata.
Steps To ReproduceInstall spanish pack + rebuild/restart
Create a new client and apply the datasets from the spanish pack in that new client
Uninstall all modules from the spanish pack + rebuild/restart
Try to export the client
Proposed SolutionDAL should not check this one reference same as it is not checked on db level.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
has duplicate defect 00215913.0MP16 closedmarvintm AD_Module_Id column in AD_Ref_data_loaded should not have reference tabledir 
related to defect 0021260 acknowledgedplatform Error message in export.client/export.sample.data when FK is broken is not useful 

-  Notes
(0052013)
hgbot (developer)
2012-09-12 11:38

Repository: erp/devel/pi
Changeset: a8f432b843b5e8ddf6c9f6ef56254dcb46507944
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Wed Sep 12 11:37:41 2012 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/a8f432b843b5e8ddf6c9f6ef56254dcb46507944 [^]

Fixed issue 21259. Changed reference of module column in ad_ref_data_loaded to string.
Currently, the ad_module_id column in Ad_Ref_Data_Loaded has a tabledir reference. This actually doesn't make sense, as there could be records which point to a non-existant module (for example, if the module was uninstalled after its reference data has been applied).
Its reference therefore has been changed to string. This is an api change, but it's important to remark that the api was broken anyway (due to the reason just explained), and the change fixes a potential problem when importing a client which contains reference data which belongs to an uninstalled module.

---
M src-db/database/sourcedata/AD_COLUMN.xml
M src/org/openbravo/service/db/DataImportService.java
---
(0052024)
AugustoMauch (developer)
2012-09-12 15:47

Code reviewed and verified in pi@07103a1a84bb
(0052732)
hudsonbot (developer)
2012-09-26 17:19

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b780e90c6452 [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2012-07-31 10:53 shuehner New Issue
2012-07-31 10:53 shuehner Assigned To => alostale
2012-07-31 10:53 shuehner Modules => Core
2012-07-31 10:57 shuehner Relationship added related to 0021260
2012-08-02 14:01 shuehner Assigned To alostale => marvintm
2012-09-11 12:35 AugustoMauch Fixed in Version => 3.0MP16
2012-09-11 12:36 AugustoMauch Relationship added has duplicate 0021591
2012-09-11 19:35 AugustoMauch Fixed in Version 3.0MP16 =>
2012-09-11 19:35 AugustoMauch Target Version => 3.0MP16
2012-09-12 11:38 hgbot Checkin
2012-09-12 11:38 hgbot Note Added: 0052013
2012-09-12 11:38 hgbot Status new => resolved
2012-09-12 11:38 hgbot Resolution open => fixed
2012-09-12 11:38 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/a8f432b843b5e8ddf6c9f6ef56254dcb46507944 [^]
2012-09-12 15:47 AugustoMauch Closed by => AugustoMauch
2012-09-12 15:47 AugustoMauch Note Added: 0052024
2012-09-12 15:47 AugustoMauch Status resolved => closed
2012-09-12 15:47 AugustoMauch Fixed in Version => 3.0MP16
2012-09-26 17:19 hudsonbot Checkin
2012-09-26 17:19 hudsonbot Note Added: 0052732


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker