Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0021249
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajorhave not tried2012-07-30 13:252012-08-09 13:07
ReporterAugustoMauchView Statuspublic 
Assigned Tomtaal 
PriorityimmediateResolutionfixedFixed in Version3.0MP14
StatusclosedFix in branchFixed in SCM revisionf9d149854a7f
ProjectionnoneETAnoneTarget Version3.0MP14
OSLinux 32 bitDatabasePostgreSQLJava version1.6.0_18
OS VersionProfessional ApplianceDatabase version8.3.9Ant version1.7.1
Product VersionSCM revision 
Review Assigned To
Web browser
ModulesCore
Regression levelProduction - QA Approved
Regression date
Regression introduced in release
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/f060d41ab218 [^]
Triggers an Emergency Packyes
Summary

0021249: Wrong grid layout when restoring original view in grid

DescriptionIf a view is created and set as default, and then the window is closed and opened again, the grid layout will break when restoring the standard view
Steps To Reproduce- Open Unit of Measure window
- Hide the EDI Code column
- Save the view as TEST, and check the Set as Default checkbox
- Close the window, open it again
- Click on the Save View button and select the Standard View
- The grid layout will be broken
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0051030)
AugustoMauch (developer)
2012-07-31 13:06

This [1] is the line where the layout gets broken.

[1] https://code.openbravo.com/erp/devel/pi/file/f7250e458578/modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js#l546 [^]
(0051032)
hgbot (developer)
2012-07-31 15:21

Repository: erp/devel/pi
Changeset: f9d149854a7f0267290d0d3da8e34e31f16e78e1
Author: Martin Taal <martin.taal <at> openbravo.com>
Date: Tue Jul 31 15:20:54 2012 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/f9d149854a7f0267290d0d3da8e34e31f16e78e1 [^]

Fixes issue 21249: Wrong grid layout when restoring original view in grid
Filtereditor had focus, unfocus during set viewstate resulted in an error because
the filtereditor was using an old field definition, resolve by resetting focus
and then recomputing it after viewstate. Recompute focus after viewstate needs to
be done anyway as the setviewstate can have removed the current focus field.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/main/ob-standard-window.js
---
(0051033)
AugustoMauch (developer)
2012-07-31 16:04

Code reviewed and verified in pi@f9d149854a7f
(0051203)
hudsonbot (developer)
2012-08-09 13:07

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/ef9a070edd19 [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2012-07-30 13:25 AugustoMauch New Issue
2012-07-30 13:25 AugustoMauch Assigned To => AugustoMauch
2012-07-30 13:25 AugustoMauch Modules => Core
2012-07-31 12:11 AugustoMauch Regression level => Production - QA Approved
2012-07-31 12:11 AugustoMauch Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/f060d41ab218 [^]
2012-07-31 13:06 AugustoMauch Note Added: 0051030
2012-07-31 13:06 AugustoMauch Assigned To AugustoMauch => dbaz
2012-07-31 13:08 AugustoMauch Assigned To dbaz => mtaal
2012-07-31 15:21 hgbot Checkin
2012-07-31 15:21 hgbot Note Added: 0051032
2012-07-31 15:21 hgbot Status new => resolved
2012-07-31 15:21 hgbot Resolution open => fixed
2012-07-31 15:21 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/f9d149854a7f0267290d0d3da8e34e31f16e78e1 [^]
2012-07-31 16:04 AugustoMauch Note Added: 0051033
2012-07-31 16:04 AugustoMauch Status resolved => closed
2012-07-31 16:04 AugustoMauch Fixed in Version => 3.0MP14
2012-08-09 13:07 hudsonbot Checkin
2012-08-09 13:07 hudsonbot Note Added: 0051203


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker