Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0020890
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2012-06-28 13:132012-06-30 05:10
ReporterngarciaView Statuspublic 
Assigned ToAugustoMauch 
PriorityimmediateResolutionfixedFixed in Version3.0MP12.1
StatusclosedFix in branchFixed in SCM revision419121245486
ProjectionnoneETAnoneTarget Version3.0MP12
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned To
Web browser
ModulesCore
Regression levelProduction - QA Approved
Regression date2012-03-05
Regression introduced in release
Regression introduced by commit
Triggers an Emergency Packyes
Summary

0020890: The update.database process of MP12 deletes some translations of the messages

DescriptionThe update.database process of MP12 deletes some translations of the messages
Steps To ReproduceAs group admin role:
   Having MP11 and the Spanish translation pack installed
   Update to MP12
   Notice that the texts in the main window (Application, Help, Workspace...) are not translated
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00203453.0MP12 closedAugustoMauch Verify Language process is creating more records than needed 

-  Notes
(0050269)
hgbot (developer)
2012-06-29 10:01

Repository: erp/devel/pi
Changeset: 419121245486f9d90b05f7c8793f330acc9873c4
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Fri Jun 29 09:53:19 2012 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/419121245486f9d90b05f7c8793f330acc9873c4 [^]

Fixes issue 20890: Installed translations are not being removed

Due to an error in the SQL query, not only the redundant translations were being removed, but some needed ones too. The error has been fixed, and now only the redundant translations are removed.

---
M src-util/modulescript/build/classes/org/openbravo/modulescript/DeleteRedundantTranslationsData.class
M src-util/modulescript/src/org/openbravo/modulescript/DeleteRedundantTranslations_data.xsql
---
(0050275)
AugustoMauch (developer)
2012-06-29 11:03

In order to recover the missing translations, the following task should be executed:

ant apply.module -DforceRefData=true
(0050299)
hudsonbot (developer)
2012-06-30 05:10

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/ce760b148e29 [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2012-06-28 13:13 ngarcia New Issue
2012-06-28 13:13 ngarcia Assigned To => alostale
2012-06-28 13:13 ngarcia Modules => Core
2012-06-28 17:17 AugustoMauch Assigned To alostale => AugustoMauch
2012-06-28 17:24 AugustoMauch Regression level => Production - QA Approved
2012-06-28 17:24 AugustoMauch Regression date => 2012-03-05
2012-06-28 17:24 AugustoMauch Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/303dc1728c72bccac5be5f0df86590bd17348e0f [^]
2012-06-28 17:24 AugustoMauch Relationship added related to 0020345
2012-06-29 10:01 hgbot Checkin
2012-06-29 10:01 hgbot Note Added: 0050269
2012-06-29 10:01 hgbot Status new => resolved
2012-06-29 10:01 hgbot Resolution open => fixed
2012-06-29 10:01 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/419121245486f9d90b05f7c8793f330acc9873c4 [^]
2012-06-29 11:03 AugustoMauch Note Added: 0050275
2012-06-29 16:27 marvintm Status resolved => closed
2012-06-29 16:27 marvintm Fixed in Version => 3.0MP12.1
2012-06-30 05:10 hudsonbot Checkin
2012-06-30 05:10 hudsonbot Note Added: 0050299


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker