Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0020872
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2012-06-26 13:422012-09-26 17:18
ReporterpsarobeView Statuspublic 
Assigned ToAugustoMauch 
PriorityurgentResolutionfixedFixed in Version3.0MP15
StatusclosedFix in branchFixed in SCM revisiondf2620bbba16
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Toguilleaer
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0020872: Bad behaviour when using context menu in child tabs

DescriptionBad behaviour when using contextual menu in child tabs. When you create the header of a sales order, for example, and then you change the price list, for example, so the status of the header is "editing" and you move to lines clicking the right button of the mouse (context menu)the system gets crashed and the header does not get saved, the price list value gets back to the original and the line disappears

see attach
Steps To Reproduce1. Go to sales order window
2. Click new and fill the mandatory fields. Save
3. Change the price list and don't save
4. Move to lines tabby clicking the blank space with the right button of the mouse
5. It gets opened the context menu. Click insert row
6. Notice the header didn't get saved and the status is still "Editing". This is wrong
7. Notice the product cannot be selected. This is wrong
TagsNo tags attached.
Attached Filesjpg file icon sales_order_editing.JPG [^] (157,480 bytes) 2012-06-26 13:42

- Relationships Relation Graph ] Dependency Graph ]
has duplicate defect 00216353.0MP17 closedAugustoMauch Auto save triggered unintentionally 

-  Notes
(0050103)
alostale (developer)
2012-06-26 17:33

Downgrading priority as it is not a regression: tested in mp6.1
(0051917)
hgbot (developer)
2012-09-07 11:16

Repository: erp/devel/pi
Changeset: df2620bbba16e462319c7663d4ef4b4652e48f89
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Fri Sep 07 11:11:35 2012 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/df2620bbba16e462319c7663d4ef4b4652e48f89 [^]

Fixes issue 20872: Context menu works even if focus in another tab

The root cause of this issue was that if the user opened the context menu in a view when the focus was in another view, the tab were the action was going to take place was not set as active.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
---
(0052376)
guilleaer (developer)
2012-09-24 20:13

code reviewed and tested in pi@4c4431d17dbd
(0052704)
hudsonbot (developer)
2012-09-26 17:18

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b780e90c6452 [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2012-06-26 13:42 psarobe New Issue
2012-06-26 13:42 psarobe Assigned To => alostale
2012-06-26 13:42 psarobe Modules => Core
2012-06-26 13:42 psarobe File Added: sales_order_editing.JPG
2012-06-26 13:42 psarobe Description Updated View Revisions
2012-06-26 17:33 alostale Note Added: 0050103
2012-06-26 17:33 alostale Priority immediate => urgent
2012-06-26 17:50 alostale Target Version 3.0MP13 => 3.0MP14
2012-07-23 15:54 alostale Target Version 3.0MP14 =>
2012-08-09 13:48 AugustoMauch Assigned To alostale => AugustoMauch
2012-09-07 11:09 AugustoMauch Closed by => guilleaer
2012-09-07 11:16 hgbot Checkin
2012-09-07 11:16 hgbot Note Added: 0051917
2012-09-07 11:16 hgbot Status new => resolved
2012-09-07 11:16 hgbot Resolution open => fixed
2012-09-07 11:16 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/df2620bbba16e462319c7663d4ef4b4652e48f89 [^]
2012-09-13 09:59 AugustoMauch Relationship added has duplicate 0021635
2012-09-24 20:13 guilleaer Note Added: 0052376
2012-09-24 20:13 guilleaer Status resolved => closed
2012-09-24 20:13 guilleaer Fixed in Version => 3.0MP15
2012-09-26 17:18 hudsonbot Checkin
2012-09-26 17:18 hudsonbot Note Added: 0052704


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker