Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0020657
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 07. Sales managementmajoralways2012-05-31 16:272012-06-19 08:36
ReporterVictorVillarView Statuspublic 
Assigned Tojecharri 
PriorityurgentResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revisionb918c284db12
ProjectionnoneETAnoneTarget Version3.0MP13
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0020657: voided invoices process does not copy alternate taxable amount lines

DescriptionDue to voided invoices process does not copy alternate taxable amount lines from sales/purchase invoices the total gross amount are not the same between the original invoice and its voided.
Steps To ReproduceAs group admin role,
Go to Tax rate window,
Configure Ca sales tax as Alternate tax amount.

Go to Sales or Purchase Invoice,
Create a new register:
  (For purchase invoices) Business partner: Happy drinks
   Navigate to Lines tab:
   Create a new one:
      - Product: Ale beer
      - tax: CA Sales Tax
      - Qty: 1
Complete it
      Total gross amount: 1.91

Void the invoice created before.
We can see in the total gross amount for the voided invoice: 1.76
Something that it is wrong because we can see that the taxz line has not been created in the new invoice voided created.

TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0049616)
hgbot (developer)
2012-06-05 11:53

Repository: erp/devel/pi
Changeset: b918c284db12746ba8085c8021afc3f84d5c7ea0
Author: Javier Etxarri <javier.echarri <at> openbravo.com>
Date: Tue Jun 05 11:53:09 2012 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/b918c284db12746ba8085c8021afc3f84d5c7ea0 [^]

Fixes issue 20657: voided invoices process does not copy alternate taxable amount lines

---
M src-db/database/model/functions/C_INVOICE_POST.xml
---
(0049906)
VictorVillar (developer)
2012-06-19 08:36

Verified

- Issue History
Date Modified Username Field Change
2012-05-31 16:27 VictorVillar New Issue
2012-05-31 16:27 VictorVillar Assigned To => mirurita
2012-05-31 16:27 VictorVillar Modules => Core
2012-05-31 16:27 VictorVillar Issue Monitored: networkb
2012-05-31 17:03 mirurita Assigned To mirurita => jonalegriaesarte
2012-06-05 09:05 jecharri Assigned To jonalegriaesarte => jecharri
2012-06-05 11:53 hgbot Checkin
2012-06-05 11:53 hgbot Note Added: 0049616
2012-06-05 11:53 hgbot Status new => resolved
2012-06-05 11:53 hgbot Resolution open => fixed
2012-06-05 11:53 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/b918c284db12746ba8085c8021afc3f84d5c7ea0 [^]
2012-06-19 08:36 VictorVillar Note Added: 0049906
2012-06-19 08:36 VictorVillar Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker