Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0020386
TypeCategorySeverityReproducibilityDate SubmittedLast Update
design defect[Openbravo ERP] A. Platformminoralways2012-05-02 10:372012-08-24 15:41
ReporterjecharriView Statuspublic 
Assigned ToAugustoMauch 
PriorityhighResolutionfixedFixed in Version3.0MP15
StatusclosedFix in branchpiFixed in SCM revision87caa2784ab4
ProjectionnoneETAnoneTarget Version3.0MP15
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Tomarvintm
Web browserGoogle Chrome
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0020386: Filter by Financial Account it does not work in grid view

DescriptionFilter by Financial Account it does not work in grid view
Steps To ReproduceAs "Group Admin" go to window "Busines Partner":
-select "Alimentos y Supermercados, S.A" busines partner.
-go to tab "Customer"
-see that the related "Financial Account" is "Cuenta de Banco"
-Now, in grid view, write in column "Financial account" --> C

You will see that the grid is empty ("The applied filter resulted in 0 results.Clear Filter(s)")
TagsRiskyFix
Attached Filesdiff file icon issue20386.diff [^] (6,419 bytes) 2012-06-21 16:18 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]
depends on defect 0020449 closedalostale Error when navigating to a Template record 
related to defect 0019717 closedAugustoMauch Issue filtering Financial Accounts in Payment In Window. 

-  Notes
(0048441)
alostale (developer)
2012-05-08 13:00

This can be reproduced in case of Table reference where the referenced table's identifier's first field is a FK. It is incorrectly computing the property to filter in this case because it should use the column defined in the Table reference.

This fix modifies a very central component of OB which is json service in charge of filtering, though the risk is low.

Test plan:
-Check what is defined in the steps to reproduce
-Do additional testing filtering different types of fields
(0048442)
hgbot (developer)
2012-05-08 13:02

Repository: erp/devel/pi
Changeset: 4642910e52d10d372640573eee7fc1cf2356e38f
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Tue May 08 13:02:27 2012 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/4642910e52d10d372640573eee7fc1cf2356e38f [^]

fixed issue 20386: Incorrect filter of table references in some circumstances

  Table reference property to use in filter was incorrectly computed as it took
  the first field in the identifier of the referenced table instead of the
  displayed field as it should.

---
M modules/org.openbravo.service.json/src/org/openbravo/service/json/JsonUtils.java
---
(0048493)
hgbot (developer)
2012-05-09 10:43

Repository: erp/devel/pi
Changeset: 1582d1dc7250976053698019f0fd68481743ed2b
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Wed May 09 10:43:24 2012 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/1582d1dc7250976053698019f0fd68481743ed2b [^]

fixed bug 20449, related to bug 20386

Revert original fix for 0020386 as it causes 0020449

---
M modules/org.openbravo.service.json/src/org/openbravo/service/json/JsonUtils.java
---
(0049048)
hudsonbot (developer)
2012-05-25 12:10

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/5401e185a8b0 [^]

Maturity status: Test
(0049077)
hudsonbot (developer)
2012-05-25 12:11

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/5401e185a8b0 [^]

Maturity status: Test
(0049994)
AugustoMauch (developer)
2012-06-21 16:35

A fix for this issue has been attached. It will not been pushed to pi until it has been tested further, because it might be risky
(0050017)
alostale (developer)
2012-06-22 09:23

Updated target version to mp15 as the fix is risky
(0050829)
jonalegriaesarte (reporter)
2012-07-25 12:46

Changed to design defect because it is a risky change and needs to be tested in depth. In any case, it will be included in MP15
(0051106)
hgbot (developer)
2012-08-06 09:10

Repository: erp/devel/pi
Changeset: 87caa2784ab49fa584c64c8c4e44055055b69816
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Mon Aug 06 09:08:58 2012 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/87caa2784ab49fa584c64c8c4e44055055b69816 [^]

Fixes issue 20386: Filtering fields with multiple identifier now works

Prior to this fix, if a field identifier was composed by the concatenation of several fields and if its reference was Table, in certain conditions it was not possible to use this field in the filter. This happened because in the server the field used to filter was the first one used in the identifier, when the filter should have been done on the displayed field.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-grid.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
M modules/org.openbravo.client.kernel/src/org/openbravo/client/kernel/reference/FKComboUIDefinition.java
---
(0051283)
AugustoMauch (developer)
2012-08-14 14:17

Issue reopened to enter Closed by field

- Issue History
Date Modified Username Field Change
2012-05-02 10:37 jecharri New Issue
2012-05-02 10:37 jecharri Assigned To => alostale
2012-05-02 10:37 jecharri Web browser => Google Chrome
2012-05-02 10:37 jecharri Modules => Core
2012-05-08 13:00 alostale Note Added: 0048441
2012-05-08 13:02 hgbot Checkin
2012-05-08 13:02 hgbot Note Added: 0048442
2012-05-08 13:02 hgbot Status new => resolved
2012-05-08 13:02 hgbot Resolution open => fixed
2012-05-08 13:02 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/4642910e52d10d372640573eee7fc1cf2356e38f [^]
2012-05-09 10:41 alostale Relationship added depends on 0020449
2012-05-09 10:43 hgbot Checkin
2012-05-09 10:43 hgbot Note Added: 0048493
2012-05-09 10:44 alostale Status resolved => new
2012-05-09 10:44 alostale Resolution fixed => open
2012-05-25 12:10 hudsonbot Checkin
2012-05-25 12:10 hudsonbot Note Added: 0049048
2012-05-25 12:11 hudsonbot Checkin
2012-05-25 12:11 hudsonbot Note Added: 0049077
2012-06-04 14:06 alostale Relationship added related to 0019717
2012-06-15 12:48 AugustoMauch Assigned To alostale => AugustoMauch
2012-06-21 16:18 AugustoMauch File Added: issue20386.diff
2012-06-21 16:35 AugustoMauch Note Added: 0049994
2012-06-22 09:22 alostale Tag Attached: RiskyFix
2012-06-22 09:23 alostale Web browser Google Chrome => Google Chrome
2012-06-22 09:23 alostale Target Version 3.0MP13 => 3.0MP15
2012-06-22 09:23 alostale Note Added: 0050017
2012-06-22 10:07 jecharri Web browser Google Chrome => Google Chrome
2012-07-25 12:46 jonalegriaesarte Web browser Google Chrome => Google Chrome
2012-07-25 12:46 jonalegriaesarte Note Added: 0050829
2012-07-25 12:46 jonalegriaesarte Type defect => design defect
2012-08-06 09:10 hgbot Checkin
2012-08-06 09:10 hgbot Note Added: 0051106
2012-08-06 09:11 hgbot Status new => resolved
2012-08-06 09:11 hgbot Resolution open => fixed
2012-08-06 09:11 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/4642910e52d10d372640573eee7fc1cf2356e38f [^] => http://code.openbravo.com/erp/devel/pi/rev/87caa2784ab49fa584c64c8c4e44055055b69816 [^]
2012-08-14 14:17 AugustoMauch Note Added: 0051283
2012-08-14 14:17 AugustoMauch Status resolved => new
2012-08-14 14:17 AugustoMauch Resolution fixed => open
2012-08-14 14:17 AugustoMauch Closed by => marvintm
2012-08-14 14:17 AugustoMauch Web browser Google Chrome => Google Chrome
2012-08-14 14:18 AugustoMauch Status new => scheduled
2012-08-14 14:18 AugustoMauch fix_in_branch => pi
2012-08-14 14:18 AugustoMauch Status scheduled => resolved
2012-08-14 14:18 AugustoMauch Resolution open => fixed
2012-08-24 15:41 marvintm Status resolved => closed
2012-08-24 15:41 marvintm Fixed in Version => 3.0MP15


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker