Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0020242
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2012-04-11 18:132012-04-17 05:31
ReporteralostaleView Statuspublic 
Assigned Toalostale 
PriorityimmediateResolutionfixedFixed in Version3.0MP11
StatusclosedFix in branchFixed in SCM revisiondffa60da8b37
ProjectionnoneETAnoneTarget Version3.0MP11
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product Version3.0MP9SCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0020242: Window Personalization removes status bar fields

DescriptionIn a window containing fields within status bar, when window personlaization is opened these fields are not shown in the status bar section in the left list. If any other field is relocated and the personalization is saved, status bar becomes empty.

Workaround: Default view can be recovered by clicking on Save View > Standard View
Steps To Reproduce-Go to Sales Order window (check there are fields in status bar)
-Open window personalization, check status bar section in left list is empty even when it is expanded (wrong)
-Relocate any field and save
-Note status bar section is empty now
TagsRegression
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00192343.0MP8 closedmtaal View Personalization is not working properly in some cases 

-  Notes
(0047514)
alostale (developer)
2012-04-12 11:51
edited on: 2012-04-12 12:13

Regression since 3.0MP8

Introduced by changeset c58405dd0b91 to fix issue 0019234

(0047518)
alostale (developer)
2012-04-12 12:45

Test plan:

-Follow steps to reproduce and check it works properly
-Recheck 0019234

This fix is not risky

Note that personalizations for tabs with status bar fields saved from mp8 are actually removing this info, so they should be recreated after this fix is applied.
(0047519)
hgbot (developer)
2012-04-12 12:49

Repository: erp/devel/pi
Changeset: dffa60da8b3766f1ba850f97a104979f606319c6
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Thu Apr 12 12:48:06 2012 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/dffa60da8b3766f1ba850f97a104979f606319c6 [^]

fixed bug 20242: Window Personalization removes status bar fields

  After fix for 0019234, isStatusBarField property was deleted and not set back
  because parentName was already present. Therefore it didn't appear in status
  bar section.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/personalization/ob-personalization.js
---
(0047539)
mtaal (developer)
2012-04-12 17:38

Reviewed
(0047639)
hudsonbot (developer)
2012-04-17 05:31

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/cedf57621434 [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2012-04-11 18:13 alostale New Issue
2012-04-11 18:13 alostale Assigned To => alostale
2012-04-11 18:13 alostale Modules => Core
2012-04-12 11:51 alostale Tag Attached: Regression
2012-04-12 11:51 alostale Note Added: 0047514
2012-04-12 12:13 alostale Note Edited: 0047514 View Revisions
2012-04-12 12:19 alostale Relationship added related to 0019234
2012-04-12 12:45 alostale Note Added: 0047518
2012-04-12 12:49 hgbot Checkin
2012-04-12 12:49 hgbot Note Added: 0047519
2012-04-12 12:49 hgbot Status new => resolved
2012-04-12 12:49 hgbot Resolution open => fixed
2012-04-12 12:49 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/dffa60da8b3766f1ba850f97a104979f606319c6 [^]
2012-04-12 17:38 mtaal Note Added: 0047539
2012-04-12 17:38 mtaal Status resolved => closed
2012-04-12 17:38 mtaal Fixed in Version => 3.0MP11
2012-04-17 05:31 hudsonbot Checkin
2012-04-17 05:31 hudsonbot Note Added: 0047639


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker