Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0020234
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2012-04-11 09:332012-05-10 16:45
ReporteregoitzView Statuspublic 
Assigned Todbaz 
PriorityimmediateResolutionfixedFixed in Version3.0MP11
StatusclosedFix in branchFixed in SCM revision5d52d838f233
ProjectionnoneETAnoneTarget Version3.0MP11
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product Version3.0MP9SCM revision 
Review Assigned To
Web browserGoogle Chrome
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0020234: Not possible to print reports on pdf using the last release of Chrome (18.x.x)

DescriptionAfter upgrade Chrome to the last releases reports on pdf are not printed.
Steps To ReproduceUsing the last release of chrome, try to print a pdf from the application.
TagsRegression
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0047459)
egoitz (developer)
2012-04-11 10:37

on utils.js, the order d.submit on submitForm method seems that is not doing anything.
(0047472)
dbaz (developer)
2012-04-11 12:16

The issue is that if you try to print a document (example: "Sales Order" document) nothing happens. In "classic mode" it works ok.

In my research I have concluded that the problem is here:

https://code.openbravo.com/erp/devel/pi/file/9547870c49c8/src/org/openbravo/erpCommon/utility/reporting/printing/PrintOptions.html#l58 [^]

It seems that due to an internal js engine change in Chrome, this closePage is executed too quickly and something strange happens because, although the submission has been done to the hidden frame, the pdf never is downloaded.

It is important remark that in 3.0 mode the closePage at the end does a Smartclient popup close-click, and in 'classic mode' a simple "window.close()". It seems that Chrome handles ok the "window.close()" case, but whatever Smartclient does internally in this close-click crashes Chrome js engine for this specific action.

The only solution that seems to work is set a timeout (even with a 1ms timeout is enough).

This closePage() is widely used in classic processes, so maybe more classic popups could be broken because the same described problem.
Briefing, there are two different solutions:

a) Include the timeout in "PrintOptions.html" to fix this particular issue.

b) "Dead dogs don't bite", so include the timeout here
https://code.openbravo.com/erp/devel/pi/file/9547870c49c8/web/js/utils.js#l5441 [^]
so all the existing "closePage()" will have the timeout so all the potential issues mentioned before will be avoided.
(0047473)
dbaz (developer)
2012-04-11 12:17

Finally is going to be implemented solution "b" in order to avoid other classic popups using "closePage" could have the same issue
(0047479)
hgbot (developer)
2012-04-11 12:39

Repository: erp/devel/pi
Changeset: 5d52d838f233e929de906971f97e41a8b907ea74
Author: David Baz Fayos <david.baz <at> openbravo.com>
Date: Wed Apr 11 12:38:56 2012 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/5d52d838f233e929de906971f97e41a8b907ea74 [^]

Fixed issue 20234: 'Print' now works ok using Google Chrome 18.x.x.x

---
M src/org/openbravo/erpCommon/security/Login.html
M src/org/openbravo/erpCommon/security/Login_F1.html
M web/js/utils.js
---
(0047486)
alostale (developer)
2012-04-11 13:19

Code reviewed and verified using Chrome 18.0.1025.142
(0047626)
hudsonbot (developer)
2012-04-17 05:31

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/cedf57621434 [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2012-04-11 09:33 egoitz New Issue
2012-04-11 09:33 egoitz Assigned To => alostale
2012-04-11 09:33 egoitz Web browser => Google Chrome
2012-04-11 09:33 egoitz Modules => Core
2012-04-11 09:33 egoitz Web browser Google Chrome => Google Chrome
2012-04-11 10:24 egoitz Web browser Google Chrome => Google Chrome
2012-04-11 10:24 egoitz Priority urgent => immediate
2012-04-11 10:24 egoitz Severity major => critical
2012-04-11 10:24 egoitz Web browser Google Chrome => Google Chrome
2012-04-11 10:24 egoitz Severity critical => major
2012-04-11 10:37 egoitz Note Added: 0047459
2012-04-11 10:50 alostale Assigned To alostale => dbaz
2012-04-11 12:16 dbaz Note Added: 0047472
2012-04-11 12:17 dbaz Note Added: 0047473
2012-04-11 12:39 hgbot Checkin
2012-04-11 12:39 hgbot Note Added: 0047479
2012-04-11 12:39 hgbot Status new => resolved
2012-04-11 12:39 hgbot Resolution open => fixed
2012-04-11 12:39 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/5d52d838f233e929de906971f97e41a8b907ea74 [^]
2012-04-11 13:19 alostale Note Added: 0047486
2012-04-11 13:19 alostale Status resolved => closed
2012-04-11 13:19 alostale Fixed in Version => 3.0MP11
2012-04-17 05:31 hudsonbot Checkin
2012-04-17 05:31 hudsonbot Note Added: 0047626
2012-05-10 16:45 plujan Tag Attached: Regression


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker