Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0020188
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 00. Application dictionaryminoralways2012-04-02 17:302012-04-21 14:24
ReporterSandrahuguetView Statuspublic 
Assigned ToSandrahuguet 
PrioritynormalResolutionfixedFixed in Version3.0MP11
StatusclosedFix in branchpiFixed in SCM revision1899cc7a420b
ProjectionnoneETAnoneTarget Versionpi
OSLinux 32 bitDatabasePostgreSQLJava version1.6.0_18
OS VersionCommunity ApplianceDatabase version8.3.9Ant version1.7.1
Product VersionpiSCM revision 
Review Assigned To
Web browserGoogle Chrome
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0020188: Paymentrule is mandatory in the database in c_invoice table, and this field is deprecated now.

DescriptionPaymentrule is mandatory in the database in c_invoice table, and this field is deprecated now.
Steps To ReproduceNot necessary
Proposed SolutionPut this field no mandatory in the database
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0020004 closedvmromanos ERROR: null value in column "paymentrule" violates not-null constraint 
blocks defect 0018820 closedSandrahuguet Create Purchase Invoices from Deliveries process seems not to work. 

-  Notes
(0047420)
Sandrahuguet (developer)
2012-04-10 14:56

Test Plan:
Display Form of Payment field (System Administrator)
Go to Purchase Invoice, create one with form of payment= blank and you can save.
(0047704)
vmromanos (developer)
2012-04-18 14:06

Alternative test plan:
1. Try to save a new Sales Invoice header. The system should allow you as usual
2. Try to save a new Purchase Invoice header. The system should allow you as usual
3. Query the C_INVOICE table and check paymentrule=null for the newly created invoices
(0047705)
hgbot (developer)
2012-04-18 14:07

Repository: erp/devel/pi
Changeset: 1899cc7a420b812850cc8cd614d0f29f63070a2a
Author: Sandra Huguet <sandra.huguet <at> openbravo.com>
Date: Thu Apr 12 17:32:18 2012 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/1899cc7a420b812850cc8cd614d0f29f63070a2a [^]

Fixed issue 20188 Paymentrule not mandatory in c_invoice
Paymentrule not mandatory in c_invoice table because this
field is deprecated now.

---
M src-db/database/model/tables/C_INVOICE.xml
M src-db/database/sourcedata/AD_COLUMN.xml
---
(0047706)
vmromanos (developer)
2012-04-18 14:07

code review + testing OK
(0047834)
hudsonbot (developer)
2012-04-21 14:24

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/2eb57286c1fc [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2012-04-02 17:30 Sandrahuguet New Issue
2012-04-02 17:30 Sandrahuguet Assigned To => Sandrahuguet
2012-04-02 17:30 Sandrahuguet Web browser => Google Chrome
2012-04-02 17:30 Sandrahuguet Modules => Core
2012-04-10 12:20 Sandrahuguet Status new => scheduled
2012-04-10 12:20 Sandrahuguet fix_in_branch => pi
2012-04-10 14:56 Sandrahuguet Note Added: 0047420
2012-04-13 09:14 Sandrahuguet Relationship added blocks 0018820
2012-04-18 14:06 vmromanos Note Added: 0047704
2012-04-18 14:07 hgbot Checkin
2012-04-18 14:07 hgbot Note Added: 0047705
2012-04-18 14:07 hgbot Status scheduled => resolved
2012-04-18 14:07 hgbot Resolution open => fixed
2012-04-18 14:07 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/1899cc7a420b812850cc8cd614d0f29f63070a2a [^]
2012-04-18 14:07 vmromanos Note Added: 0047706
2012-04-18 14:07 vmromanos Status resolved => closed
2012-04-18 14:07 vmromanos Fixed in Version => 3.0MP11
2012-04-19 19:45 vmromanos Relationship added related to 0020004
2012-04-21 14:24 hudsonbot Checkin
2012-04-21 14:24 hudsonbot Note Added: 0047834


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker