Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0019857
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2012-02-23 18:132012-03-02 15:39
ReporterioritzCiaView Statuspublic 
Assigned Tomarvintm 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision650146191c5f
ProjectionnoneETAnoneTarget Version
OSLinux 32 bitDatabasePostgreSQLJava version1.6.0_22
OS VersionUbuntu 10.04Database version8.4Ant version1.7.1
Product VersionSCM revision 
Review Assigned To
Web browserGoogle Chrome, Mozilla Firefox
ModulesUser Interface Application
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0019857: OBPAttributeSearchItem's isDisabled function is not well defined.

DescriptionOBPAttributeSearchItem's isDisabled function puts to readOnly some components when it should not.
Steps To Reproduce- Follow the following steps in MP8.
- Create a module that replicates an existing window in the application as Goods Shipment.
- Take care to replicate all needed components as for example auxiliary inputs.
- The new window needs to have a field that is an attribute selector. As happens in Goods Shipment window.
- After creating everything needed, go to the new window and see that the field is always readonly when it should not.
TagsRegression
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to design defect 0017166 closedmarvintm Attribute set value popup not necessary 

-  Notes
(0045422)
ioritzCia (developer)
2012-02-23 18:16

To have quick access to an instance where you can reproduce this issue talk with Ioritz.
(0045445)
hgbot (developer)
2012-02-24 13:33

Repository: erp/devel/pi
Changeset: 650146191c5f0cbda2f7fc75cad15a3aabcd9130
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Fri Feb 24 13:32:08 2012 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/650146191c5f0cbda2f7fc75cad15a3aabcd9130 [^]

Related to issue 17166. Fixed issue 19857. Revert change until the auxiliary input naming rules have been changed

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-search-attribute.js
---
(0045522)
iperdomo (developer)
2012-02-28 11:52

Reverted change introduced for issue 0017166.

Another module window was failing due to missing auxiliary input ATTRIBUTESET
(0045952)
hudsonbot (developer)
2012-03-02 15:39

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/544d64e0c159 [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2012-02-23 18:13 ioritzCia New Issue
2012-02-23 18:13 ioritzCia Assigned To => marvintm
2012-02-23 18:13 ioritzCia Web browser => Google Chrome, Mozilla Firefox
2012-02-23 18:13 ioritzCia Modules => User Interface Application
2012-02-23 18:14 ioritzCia Issue Monitored: networkb
2012-02-23 18:15 ioritzCia Tag Attached: Regression
2012-02-23 18:16 ioritzCia Note Added: 0045422
2012-02-23 20:22 ioritzCia Relationship added related to 0017166
2012-02-24 13:33 hgbot Checkin
2012-02-24 13:33 hgbot Note Added: 0045445
2012-02-24 13:33 hgbot Status new => resolved
2012-02-24 13:33 hgbot Resolution open => fixed
2012-02-24 13:33 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/650146191c5f0cbda2f7fc75cad15a3aabcd9130 [^]
2012-02-28 11:52 iperdomo Note Added: 0045522
2012-02-28 11:52 iperdomo Status resolved => closed
2012-03-02 15:39 hudsonbot Checkin
2012-03-02 15:39 hudsonbot Note Added: 0045952


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker