Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0019186
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2011-11-25 10:362011-12-05 18:03
ReporterrgorisView Statuspublic 
Assigned Tomtaal 
PriorityhighResolutionfixedFixed in Version3.0MP5.2
StatusclosedFix in branchpiFixed in SCM revisionfb4d253fd479
ProjectionnoneETAnoneTarget Version3.0MP6
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0019186: Dropdown remains open when tabbing out from selection

DescriptionWhen editing a row in a grid and selecting (using keyboard) a value and (instead of hitting Enter) hitting TAB, the focus jumps to the next field but two odd things happen:
1) Focus also seems to remain in the dropdown field
2) Dropdown does not close
Steps To ReproduceSales Order Lines
Edit row
OPen product dropdown using alt-arrow-down
Arrow-down to select a product
HIt TAB key
See that two focuses appear and dropdown remains open
TagsRegression
Attached Filespng file icon DropdownBlijftOpen.PNG [^] (118,153 bytes) 2011-11-25 10:36

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00192123.0MP6 closedmtaal The suggestion feature in the dropdowns is broken 
related to defect 0019248 closedmtaal Focus does not move to next field when selecting a value in a combo box 
related to defect 00192363.0MP9 closedmtaal Automatic text selection doesn't work sometimes 

-  Notes
(0043586)
mtaal (developer)
2011-11-30 14:41

Happens in firefox but not in chrome.
(0043679)
hgbot (developer)
2011-12-02 01:06

Repository: erp/devel/pi
Changeset: fb4d253fd47980dc8752f163b5bcd1581331620a
Author: Martin Taal <martin.taal <at> openbravo.com>
Date: Fri Dec 02 01:06:17 2011 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/fb4d253fd47980dc8752f163b5bcd1581331620a [^]

Fixes issue 19222: Focus lost when changing the organization in any window
Related to issue 19212: The suggestion feature in the dropdowns is broken
Fixes issue 19211: Tab level does not change until third try
Fixes issue 19186: Dropdown remains open when tabbing out from selection

The code which was there prevented additional focus calls if the form item already
had focus (it seemed), but apparently firefox needs these extra focus calls to
really set the focus correctly.

---
M modules/org.openbravo.userinterface.smartclient/web/org.openbravo.userinterface.smartclient/js/ob-smartclient.js
---
(0043689)
hudsonbot (developer)
2011-12-02 08:11

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/bdc6462da2f2 [^]

Maturity status: Test
(0043698)
dbaz (developer)
2011-12-02 16:14

Reviewed @ changeset 14794 - 65882216c761
(0043711)
psarobe (manager)
2011-12-05 13:58

Reopened. Why?

FF: Although the combo box gets closed the focus disappears and it seems the focus is two different places. Line No. and Ordered Quantity

Expected behaviour: The focus must be moved to Ordered Quantity

This is the behaviour in chrome and that's the correct one
(0043712)
dbaz (developer)
2011-12-05 14:01

psarobe, your comment it seems to be the same issue of:
https://issues.openbravo.com/view.php?id=19236 [^]
(0043720)
psarobe (manager)
2011-12-05 18:03

The issue itself is resolved but two issues are related to this one

- Issue History
Date Modified Username Field Change
2011-11-25 10:36 rgoris New Issue
2011-11-25 10:36 rgoris Assigned To => mtaal
2011-11-25 10:36 rgoris File Added: DropdownBlijftOpen.PNG
2011-11-25 10:36 rgoris Modules => Core
2011-11-30 14:41 mtaal Note Added: 0043586
2011-12-01 09:38 iperdomo Tag Attached: Regression
2011-12-01 09:38 iperdomo Relationship added related to 0019212
2011-12-01 10:55 iperdomo Target Version => 3.0MP6
2011-12-02 01:06 hgbot Checkin
2011-12-02 01:06 hgbot Note Added: 0043679
2011-12-02 01:06 hgbot Status new => resolved
2011-12-02 01:06 hgbot Resolution open => fixed
2011-12-02 01:06 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/fb4d253fd47980dc8752f163b5bcd1581331620a [^]
2011-12-02 08:11 hudsonbot Checkin
2011-12-02 08:11 hudsonbot Note Added: 0043689
2011-12-02 16:14 dbaz Note Added: 0043698
2011-12-02 16:14 dbaz Status resolved => closed
2011-12-02 16:14 dbaz Fixed in Version => 3.0MP6
2011-12-05 13:55 psarobe Status closed => new
2011-12-05 13:55 psarobe Resolution fixed => open
2011-12-05 13:55 psarobe Fixed in Version 3.0MP6 =>
2011-12-05 13:58 psarobe Note Added: 0043711
2011-12-05 14:01 dbaz Note Added: 0043712
2011-12-05 18:02 psarobe Status new => scheduled
2011-12-05 18:02 psarobe fix_in_branch => pi
2011-12-05 18:02 psarobe Relationship added related to 0019248
2011-12-05 18:02 psarobe Relationship added related to 0019236
2011-12-05 18:02 psarobe Status scheduled => resolved
2011-12-05 18:02 psarobe Resolution open => fixed
2011-12-05 18:03 psarobe Note Added: 0043720
2011-12-05 18:03 psarobe Status resolved => closed
2011-12-05 18:03 psarobe Fixed in Version => 3.0MP5.2


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker