Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0019090
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 00. Application dictionarymajoralways2011-11-16 18:142011-11-22 03:50
ReporterxabiermerinoView Statuspublic 
Assigned Toalostale 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revisione12facb86555
ProjectionnoneETAnoneTarget Version3.0MP5.1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product Version3.0MP5SCM revision 
Review Assigned To
Web browser
ModulesUser Interface Application
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0019090: Error when you save a view

DescriptionThere are some times that length of the column value (table: OBUIAPP_UIPersonalization) is not enough. This error appears:

...abSetHeight":332}}}) is too long, it has length 41712, the maximum allowed length is 40000 (http://pastebin.com/6NME496S [^])

See file attached
Steps To ReproduceGo to Application dictionary, table OBUIAPP_UIPersonalization, column value.

Realize that the value is 40000.
Proposed SolutionChange the length of the column to 100000
TagsNo tags attached.
Attached Filespng file icon saveview.png [^] (192,149 bytes) 2011-11-16 18:14

- Relationships Relation Graph ] Dependency Graph ]
related to design defect 0019092 acknowledgedplatform DAL forces column length check when saving 

-  Notes
(0042924)
alostale (developer)
2011-11-17 12:04

I was not able to reproduce the issue, trying to save view in Financial Account window in Spanish is no higher than 35K.

Applying proposed solution anyway.

This change shouldn't create any regression, as it is localized in a single column definition.
(0042925)
hgbot (developer)
2011-11-17 12:05

Repository: erp/devel/pi
Changeset: e12facb86555f88591e488fd82a84fc20d8edc8a
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Thu Nov 17 12:04:41 2011 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/e12facb86555f88591e488fd82a84fc20d8edc8a [^]

fixed bug 19090: Error when you save a view

---
M modules/org.openbravo.client.application/src-db/database/sourcedata/AD_COLUMN.xml
---
(0042941)
marvintm (developer)
2011-11-17 16:17

Reviewed diff, and tried to reproduce the original issue as reported. Like Asier, I could not generate a view as long as the one reported. However, with the new size, the problem should no longer happen in any situation.
(0042997)
shuehner (administrator)
2011-11-18 20:02

Retested in MP5.1 appliance. Using system administrator role just saving view of the 'Reference' windows leads to have around a saved datasize of 37k which is already near the old 40k limit. Adding some really long values for some of the filter fields (which need to get saved also) allows to easily produce saved size of 40-50k thus allowing to verify that saving of those sized still works correctly (it does).
(0043043)
hudsonbot (developer)
2011-11-22 03:50

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/ebd713dfe507 [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2011-11-16 18:14 xabiermerino New Issue
2011-11-16 18:14 xabiermerino Assigned To => alostale
2011-11-16 18:14 xabiermerino File Added: saveview.png
2011-11-16 18:14 xabiermerino Modules => User Interface Application
2011-11-16 18:19 xabiermerino Issue Monitored: networkb
2011-11-17 11:17 shuehner Priority urgent => immediate
2011-11-17 11:17 shuehner Target Version 3.0MP6 => 3.0MP5.1
2011-11-17 12:01 alostale Relationship added related to 0019092
2011-11-17 12:04 alostale Note Added: 0042924
2011-11-17 12:05 hgbot Checkin
2011-11-17 12:05 hgbot Note Added: 0042925
2011-11-17 12:05 hgbot Status new => resolved
2011-11-17 12:05 hgbot Resolution open => fixed
2011-11-17 12:05 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/e12facb86555f88591e488fd82a84fc20d8edc8a [^]
2011-11-17 16:16 marvintm Status resolved => closed
2011-11-17 16:17 marvintm Note Added: 0042941
2011-11-18 20:02 shuehner Note Added: 0042997
2011-11-22 03:50 hudsonbot Checkin
2011-11-22 03:50 hudsonbot Note Added: 0043043


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker