Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0019070
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2011-11-15 12:122011-12-22 11:53
ReportermiruritaView Statuspublic 
Assigned Tomtaal 
PrioritynormalResolutionfixedFixed in Version3.0MP7
StatusclosedFix in branchFixed in SCM revisionb35b26fe024d
ProjectionnoneETAnoneTarget Version3.0MP7
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0019070: When you enter a date previous to 01-01-0100 the date changed when you save

DescriptionWhen you enter a date previous to 01-01-0100 the date selector is allowing to do it (no warnings shown) but when you save the record the date is recalculated.

For example, if you enter 01-01-0001, you will see after saving it 01-01-1901 (in database 01-01-0001 is stored).

In 2.50 it is allowed to enter 01-01-0001 and it is working fine, is correctly stored in database.

In fact, if you come from a 2.50 and you have documents in a date previous to 01-01-0100 (for example we recommend it for opening a balance http://wiki.openbravo.com/wiki/ERP_2.50:Configuration_Manual/Setting_up_accounting#Setting_the_opening_balance [^]) although in database is stored properly because it was saved in 2.50, the user will see other value in the interface.
Steps To Reproduce1) Create a new sales order
2) Enter in any date selector: 01-01-0001
2) Click on save button
Realize that the date is changed to 01-01-1901
TagsNo tags attached.
Attached Filespng file icon Date changed when saving.png [^] (67,256 bytes) 2011-11-15 12:12

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00184843.0MP5 closedmtaal Fields Updated and Created do not have the hour 

-  Notes
(0043851)
hgbot (developer)
2011-12-13 17:29

Repository: erp/devel/pi
Changeset: b35b26fe024d10617f8e1eba1e056eed3a613173
Author: Martin Taal <martin.taal <at> openbravo.com>
Date: Tue Dec 13 17:29:23 2011 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/b35b26fe024d10617f8e1eba1e056eed3a613173 [^]

Fixes issue 19070: When you enter a date previous to 01-01-0100 the date changed when you save
Change parsing of xml schema date to use js date function setFullYear

---
M modules/org.openbravo.userinterface.smartclient/web/org.openbravo.userinterface.smartclient/js/ob-smartclient.js
---
(0043852)
mtaal (developer)
2011-12-13 17:32

The change touches the parsing of all dates which are returned when reading data from the server. The change is a copy of existing SC code which is being replaced to make one small change in the method:
d.setFullYear instead of d.setYear

So the change (compared to the original SC code) is on the other hand very small. See this SC forum post:
http://forums.smartclient.com/showthread.php?t=20062 [^]

To test: test setting dates in sales order and other windows.
(0043866)
hudsonbot (developer)
2011-12-14 10:44

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/8dbb94fbbb00 [^]

Maturity status: Test
(0044005)
dbaz (developer)
2011-12-22 11:53

Reviewed @ changeset 14953 - 296d6aad21a5

- Issue History
Date Modified Username Field Change
2011-11-15 12:12 mirurita New Issue
2011-11-15 12:12 mirurita Assigned To => alostale
2011-11-15 12:12 mirurita File Added: Date changed when saving.png
2011-11-15 12:12 mirurita Modules => Core
2011-11-15 16:30 mirurita Target Version => 3.0MP7
2011-11-15 16:56 alostale Relationship added related to 0018484
2011-12-12 10:00 mtaal Assigned To alostale => mtaal
2011-12-13 17:29 hgbot Checkin
2011-12-13 17:29 hgbot Note Added: 0043851
2011-12-13 17:29 hgbot Status new => resolved
2011-12-13 17:29 hgbot Resolution open => fixed
2011-12-13 17:29 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/b35b26fe024d10617f8e1eba1e056eed3a613173 [^]
2011-12-13 17:32 mtaal Note Added: 0043852
2011-12-14 10:44 hudsonbot Checkin
2011-12-14 10:44 hudsonbot Note Added: 0043866
2011-12-22 11:53 dbaz Note Added: 0044005
2011-12-22 11:53 dbaz Status resolved => closed
2011-12-22 11:53 dbaz Fixed in Version => 3.0MP7


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker