Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0017596
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2011-06-10 13:372013-05-23 01:32
ReporterpsanjuanView Statuspublic 
Assigned ToSandrahuguet 
PriorityurgentResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision0596b23501e1
ProjectionnoneETAnoneTarget Version
OSLinux 32 bitDatabaseOracleJava version1.6
OS VersionUbuntu 8.04.1Database version11.1.0.6.0Ant version1.7.0
Product VersionSCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0017596: It is not possible to select a product in a purchase invoice if there is no "Warehouse" created and setup for an organization

DescriptionIt is not possible to select a product in a purchase invoice if there is no "Warehouse" created and setup for an organization, because it seems that the system is applying a wrong filter in the product selector.
It filters by a warehouse named "España Región Norte" which does not exit in the new organization created.
When that filter is removed, it is possible to select the product in the product selector.
Steps To ReproduceCreate a new Client
Create a new Organization, set it as active
Create basic setup such as: A Fiscal Year, open period, price list, BP, Product..everything required to at least register in the system a purchase invoice in the new organization, but a warehouse.

Create a purchase Invoice, save and go to the lines
Try to select the product.
Realize that nothing is shown. See screen attached 1.

Press the (lupa).
Realize that a warehouse named "España Región Norte" is shown...which prevents from selecting the product, because that organization does not exit in the newly created organization.
See screen attached 2.
TagsOB3-Reviewed
Attached Filespng file icon 17596_1.png [^] (77,650 bytes) 2011-06-10 13:41


png file icon 17596_2.png [^] (16,272 bytes) 2011-06-10 13:42


png file icon 17596_3.png [^] (15,425 bytes) 2011-06-10 13:42

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0052257)
shankarb (developer)
2012-09-20 10:58

I think in the Product.java line 128, we are retrieving the warehouse value from the Global context.
if (strWarehouse.equals(""))
       strWarehouse = Utility.getContext(this, vars, "M_Warehouse_ID", windowId);
And again in 187, we get the Warehouse Global variable
String strWarehouse = vars.getGlobalVariable("inpWarehouse", "Product.warehouse", "");
And based on the value set in the Session Variables, we are filtering the grid.
(0058485)
hgbot (developer)
2013-05-07 13:15

Repository: erp/devel/pi
Changeset: 0596b23501e146401cea7a6541f715943956bd45
Author: Sandra Huguet <sandra.huguet <at> openbravo.com>
Date: Mon May 06 11:20:31 2013 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/0596b23501e146401cea7a6541f715943956bd45 [^]

Fixed bug 17596 Product selector is not work in purchase if there is not a warehouse created

---
M src-db/database/model/views/M_PRODUCT_PRICE_WAREHOUSE_V.xml
M src-db/database/sourcedata/AD_COLUMN.xml
M src-db/database/sourcedata/AD_ELEMENT.xml
M src-db/database/sourcedata/OBUISEL_SELECTOR.xml
---
(0058486)
dmiguelez (developer)
2013-05-07 13:15

Code Review + Testing Ok
(0058774)
hudsonbot (developer)
2013-05-23 01:32

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/97c7f6256af7 [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2011-06-10 13:37 psanjuan New Issue
2011-06-10 13:37 psanjuan Assigned To => alostale
2011-06-10 13:37 psanjuan Modules => Core
2011-06-10 13:41 psanjuan File Added: 17596_1.png
2011-06-10 13:42 psanjuan File Added: 17596_2.png
2011-06-10 13:42 psanjuan File Added: 17596_3.png
2011-06-30 09:14 alostale Status new => scheduled
2011-06-30 09:14 alostale Assigned To alostale => iperdomo
2011-06-30 09:14 alostale fix_in_branch => pi
2011-07-04 17:02 psarobe Target Version 3.0MP1 => 3.0MP2
2011-07-04 17:02 psarobe fix_in_branch pi =>
2011-08-01 21:04 iperdomo Target Version 3.0MP2 => 3.0MP3
2011-09-01 16:09 iperdomo Target Version 3.0MP3 => 3.0MP4
2011-09-06 11:58 iperdomo Assigned To iperdomo => dbaz
2011-09-26 12:51 dbaz Target Version 3.0MP4 =>
2011-10-29 19:31 psarobe Tag Attached: OB3-Reviewed
2012-06-01 15:51 dbaz Assigned To dbaz => AugustoMauch
2012-09-20 10:58 shankarb Assigned To AugustoMauch => dmiguelez
2012-09-20 10:58 shankarb Note Added: 0052257
2013-04-30 11:07 Sandrahuguet Assigned To dmiguelez => Sandrahuguet
2013-05-07 13:15 hgbot Checkin
2013-05-07 13:15 hgbot Note Added: 0058485
2013-05-07 13:15 hgbot Status scheduled => resolved
2013-05-07 13:15 hgbot Resolution open => fixed
2013-05-07 13:15 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/0596b23501e146401cea7a6541f715943956bd45 [^]
2013-05-07 13:15 dmiguelez Note Added: 0058486
2013-05-07 13:15 dmiguelez Status resolved => closed
2013-05-23 01:32 hudsonbot Checkin
2013-05-23 01:32 hudsonbot Note Added: 0058774


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker