Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0017544
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 01. General setupmajoralways2011-06-07 15:402011-06-22 11:43
ReporterpsanjuanView Statuspublic 
Assigned Toiperdomo 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchpiFixed in SCM revision21d4cc3011a1
ProjectionnoneETAnoneTarget Version3.0MP0
OSLinux 32 bitDatabaseOracleJava version1.6
OS VersionUbuntu 8.04.1Database version11.1.0.6.0Ant version1.7.0
Product VersionpiSCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0017544: Not possible to add a location / Address for a BP

DescriptionNot possible to add a location / Address for a BP
Steps To ReproduceNavigate to BP window
create a new one record and enter:
search key
name
save
Inn the tab "Customer" remove the flag: Customer
Go to Vendor/Creditor tab and enter the information required.
Go to Location tab and create a new record
Grid view is available.
Press in the (lupa).
A new window is shown.
Enter Estados Unidos as Country and press ok.
Try to save.

Below error is shown, related to column "Name" as null.

If the column "Name" is shown: a new record can be created (the column "Name" has a value (.) but the record can not be saved.

It is only possible to create locations in form view.

Creating the location in grid view provides an error in the column "Name" as it is created as null.
TagsNo tags attached.
Attached Filespng file icon 17544.png [^] (54,125 bytes) 2011-06-07 15:42

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0038139)
dalsasua (reporter)
2011-06-07 16:22

Can you, please, Patricia, set the Product Version? That will be helpful!
Thanks.
(0038157)
psanjuan (manager)
2011-06-07 19:05

pi
Openbravo 3 MP0
(0038175)
hgbot (developer)
2011-06-08 17:07

Repository: erp/devel/pi
Changeset: 6b877e50e7f5a15981a0714df89e3f65e59b5fb9
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Wed Jun 08 17:03:35 2011 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/6b877e50e7f5a15981a0714df89e3f65e59b5fb9 [^]

fixed bug 17544: Not possible to add a location for a BP

  Missing mandatory field in grid

---
M src-db/database/sourcedata/AD_FIELD.xml
---
(0038197)
psanjuan (manager)
2011-06-09 14:59

Seems this bug is not fixed. It keeps failing regardless "Name" column is shown in grid view.
(0038211)
alostale (developer)
2011-06-10 09:23

I misunderstood the problem. By adding this column to the grid, it is possible to manually change its value, in this case it doesn't fail.

The actual problem is that name value should be automatically calculated when creating the location. It seems to be an issue with the Location Selector in new UI.
(0038253)
hgbot (developer)
2011-06-10 17:07

Repository: erp/devel/pi
Changeset: e86c00971aa158e4bbf6e48581b59922654bfbbe
Author: Iván Perdomo <ivan.perdomo <at> openbravo.com>
Date: Fri Jun 10 17:00:30 2011 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/e86c00971aa158e4bbf6e48581b59922654bfbbe [^]

Issue 17544: Rollback changeset 6b877e50e7f5

---
M src-db/database/sourcedata/AD_FIELD.xml
---
(0038254)
hgbot (developer)
2011-06-10 17:07

Repository: erp/devel/pi
Changeset: 21d4cc3011a1eee3fe360c01152c9411ef97b92f
Author: Iván Perdomo <ivan.perdomo <at> openbravo.com>
Date: Fri Jun 10 17:03:01 2011 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/21d4cc3011a1eee3fe360c01152c9411ef97b92f [^]

Fixes issue 17544: Use storeValue for storing the PB Location
- The issue was only reproducible in Firefox 4. The locationAddress property
    was set to null when sending the request to the server. Using storeValue
    makes it work in all targeted browsers.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-search.js
---
(0038257)
marvintm (developer)
2011-06-10 17:36

Tested in Safari, Firefox and Chrome. Worked in all of them.
(0038444)
hudsonbot (developer)
2011-06-22 11:43

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/abb438586c0e [^]

Maturity status: Test
(0038445)
hudsonbot (developer)
2011-06-22 11:43

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/abb438586c0e [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2011-06-07 15:40 psanjuan New Issue
2011-06-07 15:40 psanjuan Assigned To => dalsasua
2011-06-07 15:40 psanjuan Modules => Core
2011-06-07 15:42 psanjuan File Added: 17544.png
2011-06-07 15:46 psanjuan Steps to Reproduce Updated View Revisions
2011-06-07 15:49 psanjuan Steps to Reproduce Updated View Revisions
2011-06-07 16:22 dalsasua Note Added: 0038139
2011-06-07 16:22 dalsasua Status new => feedback
2011-06-07 19:05 psanjuan Note Added: 0038157
2011-06-07 19:05 psanjuan version => pi
2011-06-07 19:05 psanjuan Status feedback => new
2011-06-08 10:52 dalsasua Assigned To dalsasua => alostale
2011-06-08 17:07 hgbot Checkin
2011-06-08 17:07 hgbot Note Added: 0038175
2011-06-08 17:07 hgbot Status new => resolved
2011-06-08 17:07 hgbot Resolution open => fixed
2011-06-08 17:07 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/6b877e50e7f5a15981a0714df89e3f65e59b5fb9 [^]
2011-06-09 14:59 psanjuan Note Added: 0038197
2011-06-10 09:23 alostale Note Added: 0038211
2011-06-10 09:23 alostale Status resolved => new
2011-06-10 09:23 alostale Resolution fixed => open
2011-06-10 09:33 alostale Status new => scheduled
2011-06-10 09:33 alostale Assigned To alostale => iperdomo
2011-06-10 09:33 alostale fix_in_branch => pi
2011-06-10 17:07 hgbot Checkin
2011-06-10 17:07 hgbot Note Added: 0038253
2011-06-10 17:07 hgbot Checkin
2011-06-10 17:07 hgbot Note Added: 0038254
2011-06-10 17:07 hgbot Status scheduled => resolved
2011-06-10 17:07 hgbot Resolution open => fixed
2011-06-10 17:07 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/6b877e50e7f5a15981a0714df89e3f65e59b5fb9 [^] => http://code.openbravo.com/erp/devel/pi/rev/21d4cc3011a1eee3fe360c01152c9411ef97b92f [^]
2011-06-10 17:36 marvintm Note Added: 0038257
2011-06-10 17:36 marvintm Status resolved => closed
2011-06-22 11:43 hudsonbot Checkin
2011-06-22 11:43 hudsonbot Note Added: 0038444
2011-06-22 11:43 hudsonbot Checkin
2011-06-22 11:43 hudsonbot Note Added: 0038445


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker