Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0017075
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2011-05-09 15:202011-08-11 15:18
ReportergbisheimerView Statuspublic 
Assigned Toalostale 
PrioritynormalResolutionfixedFixed in Version3.0MP2
StatusclosedFix in branchFixed in SCM revisionfad122168625
ProjectionnoneETAnoneTarget Version3.0MP2
OSWindowsDatabasePostgreSQLJava versionjdk 6u25 x64
OS VersionVersión 6.1.7600Database version9.0.4-1 64 bitsAnt version1.8.2
Product Version3.0RC6.1SCM revision 
Review Assigned To
Web browser
ModulesOpenbravo 3.0
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0017075: Install from sources fails when using Tomcat 7 onwards

DescriptionThe Manager application has been re-structured for Tomcat 7 onwards and some of URLs have changed. All URLs used to access the Manager application should now start with one of the following options:

    /manager/html for the HTML GUI
    /manager/text for the text interface
    /manager/jmxproxy for the JMX proxy
    /manager/status for the status pages

Changing line 87 in Openbravo.properties file from:
tomcat.manager.url=http://localhost:8080/manager [^]
to
tomcat.manager.url=http://localhost:8080/manager/text [^]

raises a new problems because of the new forward-slash in the URL (for isntance \src-util\diagnostic\src\org\openbravo\utils\ServerConnection.java : line 36 ).
Steps To ReproduceInstall Openbravo ERP from sources using tomcat version 7
Proposed SolutionChange line 87 in Openbravo.properties file from:
tomcat.manager.url=http://localhost:8080/manager [^]
to
tomcat.manager.url=http://localhost:8080/manager/text [^]

Update code in ServerConnection.java on line 36 (and other similar files that modifies tomcat manager URL) to a smarter way to parse the URL in order to recognize the format:

http://[server]:[port]/[manager-url] [^]

where [manager-url] may contain anything
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00170803.0MP2 closedalostale Tomcat fails excecuting ANT tasks during diagnostic build 

-  Notes
(0036589)
gbisheimer (reporter)
2011-05-09 22:21

I used this patch in file \src-util\diagnostic\src\org\openbravo\utils\ServerConnection.java

  private URL getUrl(String action, String additionalParameters) throws MalformedURLException {
    String serverUrl=new PropertiesManager("config/Openbravo.properties").getProperty("tomcat.manager.url");
    String[] tokens = serverUrl.split("[/]+");
    serverUrl = tokens[0] + "//" + tokens[1];
    return new URL(serverUrl+ "/OpenbravoDiagnostics/Check.html?Command=" + action + additionalParameters);
  }
(0039371)
alostale (developer)
2011-07-26 13:11

Updated documentation
http://wiki.openbravo.com/wiki/Openbravo.properties#Tomcat_Manager [^]
(0039373)
hgbot (developer)
2011-07-26 13:14

Repository: erp/devel/pi
Changeset: fad122168625621e9acc7faa970e0db0a5740a7f
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Tue Jul 26 13:13:53 2011 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/fad122168625621e9acc7faa970e0db0a5740a7f [^]

fixed bug 17075: Automatic deploy in tomcat 7

  -Updated Openbravo.properties to explain differences between Tomcat 6 and 7
  -Updated documentation: http://wiki.openbravo.com/wiki/Openbravo.properties [^]
  -ant dagnostic task now uses context.url to determine server url rather than tomcat.manager.url

---
M config/Openbravo.properties.template
M src-util/diagnostic/src/org/openbravo/utils/ServerConnection.java
---
(0039681)
hudsonbot (developer)
2011-08-01 14:21

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/cf2afed6e8ef [^]

Maturity status: Test
(0040129)
jonalegriaesarte (reporter)
2011-08-11 15:18

Verified

- Issue History
Date Modified Username Field Change
2011-05-09 15:20 gbisheimer New Issue
2011-05-09 15:20 gbisheimer Assigned To => alostale
2011-05-09 15:20 gbisheimer Modules => Openbravo 3.0
2011-05-09 22:21 gbisheimer Note Added: 0036589
2011-05-16 10:03 alostale Relationship added duplicate of 0017080
2011-05-16 10:04 alostale Status new => scheduled
2011-05-16 10:04 alostale fix_in_branch => pi
2011-05-16 10:04 alostale Target Version => 3.0MP0
2011-05-16 10:04 alostale fix_in_branch pi =>
2011-06-02 10:53 dmitry_mezentsev Target Version 3.0MP0 => 3.0MP1
2011-06-22 19:57 dmitry_mezentsev Target Version 3.0MP1 => 3.0MP2
2011-07-12 14:30 alostale Relationship replaced related to 0017080
2011-07-26 13:11 alostale Note Added: 0039371
2011-07-26 13:14 hgbot Checkin
2011-07-26 13:14 hgbot Note Added: 0039373
2011-07-26 13:14 hgbot Status scheduled => resolved
2011-07-26 13:14 hgbot Resolution open => fixed
2011-07-26 13:14 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/fad122168625621e9acc7faa970e0db0a5740a7f [^]
2011-08-01 14:21 hudsonbot Checkin
2011-08-01 14:21 hudsonbot Note Added: 0039681
2011-08-11 15:18 jonalegriaesarte Note Added: 0040129
2011-08-11 15:18 jonalegriaesarte Status resolved => closed
2011-08-11 15:18 jonalegriaesarte Fixed in Version => 3.0MP2


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker