Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0016765
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2011-04-12 13:142011-08-31 12:41
ReportermiruritaView Statuspublic 
Assigned Toadrianromero 
PrioritynormalResolutionfixedFixed in Version3.0MP3
StatusclosedFix in branchFixed in SCM revisiond61db4a5e84b
ProjectionnoneETAnoneTarget Version3.0MP3
OSLinux 32 bitDatabasePostgreSQLJava version1.6.0_18
OS VersionCommunity ApplianceDatabase version8.3.9Ant version1.7.1
Product VersionSCM revision 
Review Assigned To
Web browser
ModulesUser Interface Selector
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0016765: Selector in manual window: not possible to remove the selected value and fire onchange event

DescriptionIf you create a selector (using user interface selector module) in a manual window is not possible to remove a selected element (or value).
In this case if the selector is a optional field after selecting a value is not possible to leave empty again.

The event should not be launched until the field is empty. With the proposed solution if the user removes one character it launched the onchange event as any value has been selected.

From a performance perspective (with APR) depending on the filter a grid dynamically creating, imagine each time a character is removed all the grid is loading again.
Steps To Reproduce1) Go to Financial Account || Transactions tab
2) Click on Add Transaction button
3) Click on Add Payment button
4) Enter a value for the business partner selector
5) Try to remove it
Proposed SolutionSee attached diff
TagsNo tags attached.
Attached Filesdiff file icon issue16765.diff [^] (1,997 bytes) 2011-04-13 16:26 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00180563.0MP3 closedmirurita Business partner selector in Add Payment window fires the reload of the results in every change 

-  Notes
(0035993)
mirurita (developer)
2011-04-15 15:13
edited on: 2011-04-15 15:14

Should be solved also in userinterface.selector module for 2.50.

(0036529)
dmitry_mezentsev (developer)
2011-05-06 18:16

Moving to MP0 now. Please rise the flag in case it is critical not to do it.
(0039035)
iperdomo (developer)
2011-07-13 12:52

The issue with APR was solved in a different way. Is this issue is still valid?
(0039300)
adrianromero (manager)
2011-07-21 17:20
edited on: 2011-07-21 17:21

The patch attached is valid and using it the event callOut and onValueChange are invoked in every change of the selector.

But there is an unwanted side effect in this case when applied this patch that is that callOut and onValueChange are invoked in every change, even when the user is typing in the selector field making the window to invoke the server in every key event.

To fix this side effect it must be modified the window overwriting the method onValueChange of the selector instead of the method callOut because onValueChange has all the information of the value changed.

In the body of the event onValueChange, to identify whether there is a value selected or the field is empty there is needed to use the following expressions:

* this.selectorField.getValue() to get the text typed in the selector where this is the javascript selector object.
* selectedObj that is the parameter of the event onValueChange, to know whether a value has been selected or not.

(0039301)
adrianromero (manager)
2011-07-21 17:30

This issue must be fixed in coordination with the related issue 18056
(0040443)
hgbot (developer)
2011-08-23 14:29

Repository: erp/devel/pi
Changeset: d61db4a5e84b6459ca4b389c181a4fb84a81ee0e
Author: Adrián Romero <adrianromero <at> openbravo.com>
Date: Thu Aug 18 13:04:35 2011 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/d61db4a5e84b6459ca4b389c181a4fb84a81ee0e [^]

Fixes issue 0016765: Selector in manual window: not possible to remove the selected value and fire onchange event
Now the event callout is fired in every change of the selector

---
M modules/org.openbravo.userinterface.selector/web/org.openbravo.userinterface.selector/js/ob-selector-widget.js
---
(0040446)
adrianromero (manager)
2011-08-23 14:33

* Testing the issue

Kindly follow the steps to test and verify that now when the business partner value is removed the list is updated.

* Other areas affected

This must be verified in other selectors of the same kind in other manual windows because it has been modified the general behavior of the selector when the hook functions are invoked.
(0040466)
hudsonbot (developer)
2011-08-24 01:08

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/ae0285ee1597 [^]

Maturity status: Test
(0040617)
jonalegriaesarte (reporter)
2011-08-31 12:41

Verified

- Issue History
Date Modified Username Field Change
2011-04-12 13:14 mirurita New Issue
2011-04-12 13:14 mirurita Assigned To => iperdomo
2011-04-12 13:14 mirurita Modules => User Interface Selector
2011-04-13 16:25 mirurita Description Updated View Revisions
2011-04-13 16:25 mirurita Proposed Solution updated
2011-04-13 16:26 mirurita File Added: issue16765.diff
2011-04-15 15:13 mirurita Note Added: 0035993
2011-04-15 15:14 mirurita Note Edited: 0035993 View Revisions
2011-05-02 10:40 alostale Status new => scheduled
2011-05-06 18:16 dmitry_mezentsev Note Added: 0036529
2011-05-06 18:16 dmitry_mezentsev Target Version 3.0RC7 => 3.0MP0
2011-05-17 09:15 iperdomo Priority high => normal
2011-06-02 10:53 dmitry_mezentsev Target Version 3.0MP0 => 3.0MP1
2011-06-22 19:57 dmitry_mezentsev Target Version 3.0MP1 => 3.0MP2
2011-07-13 12:52 iperdomo Note Added: 0039035
2011-07-13 12:52 iperdomo Status scheduled => feedback
2011-07-19 11:38 iperdomo Status feedback => scheduled
2011-07-19 11:38 iperdomo Assigned To iperdomo => adrianromero
2011-07-19 11:38 iperdomo fix_in_branch => pi
2011-07-21 17:20 adrianromero Note Added: 0039300
2011-07-21 17:21 adrianromero Note Edited: 0039300 View Revisions
2011-07-21 17:21 adrianromero Target Version 3.0MP2 => 3.0MP3
2011-07-21 17:21 adrianromero fix_in_branch pi =>
2011-07-21 17:28 adrianromero Issue cloned 0018056
2011-07-21 17:28 adrianromero Relationship added related to 0018056
2011-07-21 17:30 adrianromero Note Added: 0039301
2011-08-23 14:29 hgbot Checkin
2011-08-23 14:29 hgbot Note Added: 0040443
2011-08-23 14:29 hgbot Status scheduled => resolved
2011-08-23 14:29 hgbot Resolution open => fixed
2011-08-23 14:29 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/d61db4a5e84b6459ca4b389c181a4fb84a81ee0e [^]
2011-08-23 14:33 adrianromero Note Added: 0040446
2011-08-24 01:08 hudsonbot Checkin
2011-08-24 01:08 hudsonbot Note Added: 0040466
2011-08-31 12:41 jonalegriaesarte Note Added: 0040617
2011-08-31 12:41 jonalegriaesarte Status resolved => closed
2011-08-31 12:41 jonalegriaesarte Fixed in Version => 3.0MP3


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker