Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0016534
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementminoralways2011-03-29 13:512011-05-26 07:46
ReportermalsasuaView Statuspublic 
Assigned Toadrianromero 
PriorityhighResolutionfixedFixed in Version3.0RC7
StatusclosedFix in branchpiFixed in SCM revision3299a3e1ad8f
ProjectionnoneETAnoneTarget Version3.0RC7
OSLinux 32 bitDatabasePostgreSQLJava version1.6.0_18
OS VersionCommunity ApplianceDatabase version8.3.9Ant version1.7.1
Product VersionpiSCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0016534: the invoice date, when the invoice is voided, should be updatable

Descriptionwhen you void an invoice, the invoice date is not updatable.
It should be updatable, because the date of invoice, and the document number shuld be correlative.

Steps To Reproduce. create a new invoice
. process and void it
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on defect 00167533.0RC7 closedalostale Read only Date fields can be changed 
related to feature request 0023678 newTriage Finance It would be nice to be able to specify the reversal document date and accounting date, when voiding Sales Invoice and Shipment 
blocks backport 00165332.50MP30 closedadrianromero the invoice date, when the invoice is voided, should be updatable 

-  Notes
(0036304)
hgbot (developer)
2011-05-03 12:27

Repository: erp/devel/pi
Changeset: 7110a118178cc19ef8094a1c44654788dc005bde
Author: Adrián Romero <adrianromero <at> openbravo.com>
Date: Tue May 03 12:26:37 2011 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/7110a118178cc19ef8094a1c44654788dc005bde [^]

Fixes issue 0016534: the invoice date, when the invoice is voided, should be updatable
It has been modified the READ ONLY LOGIC condition to make the invoice date editable for void invoices not only for the reversed void invoice

---
M src-db/database/sourcedata/AD_COLUMN.xml
---
(0036305)
adrianromero (manager)
2011-05-03 12:32

* Testing the issue

Create and invoice, process it and void it. Before posting it verify that the invoice date can be modified in the voided invoice and in the reverse voided invoice.

* Other areas affected

No other areas affected. Only the read only logic of the invoice date field
(0036395)
adrianromero (manager)
2011-05-05 13:20

this issue has been reopened because it is blocked by related issue 16753
(0036598)
adrianromero (manager)
2011-05-10 10:36

Verified
(0036802)
hudsonbot (developer)
2011-05-12 13:28

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/c40e579fcd38 [^]

Maturity status: Test
(0036903)
hgbot (developer)
2011-05-12 16:47

Repository: erp/devel/pi
Changeset: 3299a3e1ad8f29d6c90f463b066a92827fa404b6
Author: Adrián Romero <adrianromero <at> openbravo.com>
Date: Thu May 12 16:44:43 2011 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/3299a3e1ad8f29d6c90f463b066a92827fa404b6 [^]

Fixes issue 0016534: the invoice date, when the invoice is voided, should be updatable
It has been modified also the condition needed in the trigger to finish fixing this issue

---
M src-db/database/model/triggers/C_INVOICE_TRG.xml
---
(0036906)
adrianromero (manager)
2011-05-12 16:52

* Testing the issue

Create and invoice, process it and void it. Before posting it verify that the invoice date can be modified and saved in the voided invoice and in the reverse voided invoice.

* Other areas affected

No other areas affected. Only the read only logic of the invoice date field
(0036941)
hudsonbot (developer)
2011-05-13 06:23

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/d221ad9e329e [^]

Maturity status: Test
(0037005)
malsasua (developer)
2011-05-16 11:08

tested: it works fine
(0037324)
hgbot (developer)
2011-05-23 13:23

Repository: erp/devel/pi
Changeset: 933d6e1d7dec2e6513f00f50bac091085466732e
Author: Adrián Romero <adrianromero <at> openbravo.com>
Date: Mon May 23 13:22:01 2011 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/933d6e1d7dec2e6513f00f50bac091085466732e [^]

Issue 0016534: the invoice date, when the invoice is voided, should be updatable
removal of dead code lines

---
M src-db/database/model/triggers/C_INVOICE_TRG.xml
---
(0037534)
hudsonbot (developer)
2011-05-26 07:46

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/728387046be6 [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2011-03-29 13:51 malsasua New Issue
2011-03-29 13:51 malsasua Assigned To => dalsasua
2011-03-29 13:51 malsasua Modules => Core
2011-03-29 13:51 malsasua Issue generated from 0016533
2011-03-29 13:51 malsasua Relationship added blocks 0016533
2011-04-06 10:57 jonalegriaesarte Target Version 3.0RC6 => 3.0RC7
2011-04-26 16:21 dalsasua Issue Monitored: networkb
2011-04-29 08:43 dalsasua Assigned To dalsasua => adrianromero
2011-05-02 17:03 adrianromero Status new => scheduled
2011-05-02 17:03 adrianromero fix_in_branch => pi
2011-05-03 12:27 hgbot Checkin
2011-05-03 12:27 hgbot Note Added: 0036304
2011-05-03 12:27 hgbot Status scheduled => resolved
2011-05-03 12:27 hgbot Resolution open => fixed
2011-05-03 12:27 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/7110a118178cc19ef8094a1c44654788dc005bde [^]
2011-05-03 12:32 adrianromero Note Added: 0036305
2011-05-05 13:20 adrianromero Note Added: 0036395
2011-05-05 13:20 adrianromero Status resolved => new
2011-05-05 13:20 adrianromero Resolution fixed => open
2011-05-05 13:20 adrianromero Relationship added depends on 0016753
2011-05-10 10:36 adrianromero Status new => scheduled
2011-05-10 10:36 adrianromero Status scheduled => resolved
2011-05-10 10:36 adrianromero Resolution open => fixed
2011-05-10 10:36 adrianromero Note Added: 0036598
2011-05-10 10:36 adrianromero Status resolved => closed
2011-05-12 13:28 hudsonbot Checkin
2011-05-12 13:28 hudsonbot Note Added: 0036802
2011-05-12 16:47 hgbot Checkin
2011-05-12 16:47 hgbot Note Added: 0036903
2011-05-12 16:47 hgbot Status closed => resolved
2011-05-12 16:47 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/7110a118178cc19ef8094a1c44654788dc005bde [^] => http://code.openbravo.com/erp/devel/pi/rev/3299a3e1ad8f29d6c90f463b066a92827fa404b6 [^]
2011-05-12 16:52 adrianromero Note Added: 0036906
2011-05-13 06:23 hudsonbot Checkin
2011-05-13 06:23 hudsonbot Note Added: 0036941
2011-05-16 11:08 malsasua Note Added: 0037005
2011-05-16 11:08 malsasua Status resolved => closed
2011-05-16 11:08 malsasua Fixed in Version => 3.0RC7
2011-05-23 13:23 hgbot Checkin
2011-05-23 13:23 hgbot Note Added: 0037324
2011-05-26 07:46 hudsonbot Checkin
2011-05-26 07:46 hudsonbot Note Added: 0037534
2018-04-13 11:56 ngarcia Relationship added related to 0022678
2018-04-13 11:56 ngarcia Relationship deleted related to 0022678
2018-04-13 12:03 ngarcia Relationship added related to 0023678


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker