Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0016368
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] Z. Othersminoralways2011-03-17 17:342011-06-22 11:43
ReportermaiteView Statuspublic 
Assigned Toalostale 
PriorityhighResolutionfixedFixed in Version3.0MP0
StatusclosedFix in branchpiFixed in SCM revisionb6a1677b7894
ProjectionnoneETAnoneTarget Version2.50MP31
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product Version2.50MP27SCM revision 
Review Assigned To
Web browser
ModulesAdvanced Payables and Receivables Mngmt
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0016368: Error when accessing Cleared Items tab from Reconciliations grid

DescriptionIf go to Reconciliations tab in grid mode, select one reconciliation different from first or last one and navigate to Cleared Items tab you will be carried to cleared item of another reconciliation

Steps To Reproduce0. As System Administrator go to Application Dictionary || Tables and Columns || Table >> Column: column "FIN_Reconciliation_ID" of table "APRM_Reconciliation_v" (that is a necessary workaround to skip bug 16068)
1. Go to Financial Management || Receivables & Payables || Transactions || Financial Account || Account >> Transactions: add 3 transactions
2. Select one reconciliation and press Reconcile button. Set proper amount and press "Reconcile" button. Reconciliation 1 will be created.
3. Follow same procedure and reconcile second transaction. Reconciliation 2 will be created.
4. Follow same procedure and reconcile third transaction. Reconciliation 3 will be created.
5. Go to "Reconciliations" tab in grid mode. Select Reconciliation2 and navigate to "cleared items". Realize that you are visualizing items of other reconciliation.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
duplicate of defect 00170703.0RC7 closedalostale Reconcilliation child tab (cleared items) is not filtered by parent 
depends on backport 00160682.50MP29 closedalostale Error when accessing Cleared Items tab from Reconciliations grid view 
depends on backport 00176012.50MP31 closedalostale Error when accessing Cleared Items tab from Reconciliations grid 

-  Notes
(0035584)
mirurita (developer)
2011-04-05 10:04

Solved in the issue 16068.
(0035614)
maite (developer)
2011-04-05 16:18

it is actually reproducible in http://live.builds.openbravo.com/int-full-pgsql/security/Login_FS.html [^] in Financial Account "Banco de España - Cuenta 1"
(0037002)
alostale (developer)
2011-05-16 10:19

Working fine in 2.50 this is a 3.0 issue
(0037141)
gorkaion (developer)
2011-05-18 14:00

the issue can be reproduced on 2.50 and in 3.0 using classic mode
(0038246)
hgbot (developer)
2011-06-10 14:31

Repository: erp/devel/pi
Changeset: b6a1677b78947242023f0088fba6b1a2f49c895b
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Fri Jun 10 14:30:20 2011 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/b6a1677b78947242023f0088fba6b1a2f49c895b [^]

fixed bug 16368: Error when accessing Cleared Items tab from Reconciliations

  Fixed in 2.50 UI navigation in grid from parent tab to child tab, when child
  tab defines relationship based on secondary key column.

---
M src-wad/src/org/openbravo/wad/Fields_data.xsql
M src-wad/src/org/openbravo/wad/Wad.java
M src-wad/src/org/openbravo/wad/datasource.xml
M src-wad/src/org/openbravo/wad/datasource.xsqlxml
M src-wad/src/org/openbravo/wad/javasource.javaxml
M src-wad/src/org/openbravo/wad/javasource.xml
---
(0038291)
maite (developer)
2011-06-13 12:09

verified
(0038440)
hudsonbot (developer)
2011-06-22 11:43

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/abb438586c0e [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2011-03-17 17:34 maite New Issue
2011-03-17 17:34 maite Assigned To => adrianromero
2011-03-17 17:34 maite Modules => Advanced Payables and Receivables Mngmt
2011-03-17 17:35 maite Issue Monitored: networkb
2011-03-18 11:53 adrianromero Relationship added related to 0016068
2011-03-18 11:53 adrianromero Relationship deleted related to 0016068
2011-03-18 11:53 adrianromero Relationship added depends on 0016068
2011-03-18 11:54 adrianromero Assigned To adrianromero => eduardo_Argal
2011-04-05 10:02 mirurita Assigned To eduardo_Argal => mirurita
2011-04-05 10:03 mirurita Status new => scheduled
2011-04-05 10:03 mirurita fix_in_branch => pi
2011-04-05 10:04 mirurita Note Added: 0035584
2011-04-05 10:04 mirurita Status scheduled => resolved
2011-04-05 10:04 mirurita Fixed in SCM revision => 56d82c750c87
2011-04-05 10:04 mirurita Resolution open => fixed
2011-04-05 16:16 maite Assigned To mirurita => alostale
2011-04-05 16:16 maite Status resolved => new
2011-04-05 16:16 maite Resolution fixed => open
2011-04-05 16:18 maite Note Added: 0035614
2011-04-05 16:18 maite fix_in_branch pi =>
2011-04-05 16:18 maite Description Updated View Revisions
2011-04-11 08:59 alostale Status new => scheduled
2011-04-11 08:59 alostale fix_in_branch => pi
2011-05-16 10:19 alostale Note Added: 0037002
2011-05-16 10:20 alostale Relationship added duplicate of 0017070
2011-05-16 10:20 alostale Status scheduled => closed
2011-05-16 10:20 alostale Resolution open => duplicate
2011-05-18 13:59 gorkaion Status closed => new
2011-05-18 13:59 gorkaion Resolution duplicate => open
2011-05-18 14:00 gorkaion Note Added: 0037141
2011-05-23 08:02 alostale Target Version 2.50MP30 => 2.50MP31
2011-05-23 08:02 alostale fix_in_branch pi =>
2011-05-23 08:08 alostale Status new => scheduled
2011-06-10 14:28 alostale Status scheduled => feedback
2011-06-10 14:28 alostale Status feedback => new
2011-06-10 14:28 alostale Status new => scheduled
2011-06-10 14:28 alostale fix_in_branch => pi
2011-06-10 14:31 hgbot Checkin
2011-06-10 14:31 hgbot Note Added: 0038246
2011-06-10 14:31 hgbot Status scheduled => resolved
2011-06-10 14:31 hgbot Resolution open => fixed
2011-06-10 14:31 hgbot Fixed in SCM revision 56d82c750c87 => http://code.openbravo.com/erp/devel/pi/rev/b6a1677b78947242023f0088fba6b1a2f49c895b [^]
2011-06-13 12:09 maite Note Added: 0038291
2011-06-13 12:09 maite Status resolved => closed
2011-06-13 12:09 maite Fixed in Version => 3.0MP0
2011-06-22 11:43 hudsonbot Checkin
2011-06-22 11:43 hudsonbot Note Added: 0038440


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker