Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0015728
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2011-01-21 11:462011-09-01 17:52
ReporteriperdomoView Statuspublic 
Assigned Tomarvintm 
PrioritynormalResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision073bf9bf00fe
ProjectionnoneETAnoneTarget Version3.0MP3
OSLinux 32 bitDatabasePostgreSQLJava version1.6.0_22
OS Version2.6.35-gentoo-r12Database version8.3.12Ant version1.7.1
Product VersionSCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0015728: Images provided by ShowImageLogo and are not cached in the browser

DescriptionThe calls to the servlet ShowImageLogo returns always the image. This prevents caching of the images in the browser.

Steps To ReproduceUsing Apache HTTP in front of Apache Tomcat, go the login page, and refresh the page several times.

e.g

127.0.0.1 - - [21/Jan/2011:11:38:36 +0100] "GET /openbravo/utility/ShowImageLogo?logo=yourcompanymenu HTTP/1.1" 200 5643

127.0.0.1 - - [21/Jan/2011:11:44:59 +0100] "GET /openbravo/utility/ShowImageLogo?logo=yourcompanymenu HTTP/1.1" 200 5643
Proposed Solution* Implement etag based on the md5 hash of the image content
* Reply HTTP 304 code when the image hasn't changed
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0033804)
shuehner (administrator)
2011-01-21 12:09

Note: there are 2-3 similar servlet to retrieve images.
(0040629)
hgbot (developer)
2011-08-31 15:29

Repository: erp/devel/pi
Changeset: 073bf9bf00feb03b6215fa3d43e2bc0ab64f8e21
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Wed Aug 31 15:28:11 2011 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/073bf9bf00feb03b6215fa3d43e2bc0ab64f8e21 [^]

Fixed issue 15728. The following changes have been made:
- The logic which gets the image and sends it to the client has been moved to a series of methods in the new ImageUtils class
- ShowImage and ShowImageLogo now use this class
- An ETag is now calculated when an image is sent. This ETag is based on the audit information of the image object.
- If the ETag is sent in the request, and is equal to the current ETag of the image, then the image is now sent, because it hasn't changed.

---
M src/org/openbravo/erpCommon/utility/ShowImage.java
M src/org/openbravo/erpCommon/utility/ShowImageLogo.java
A src/org/openbravo/erpCommon/utility/ImageUtils.java
---
(0040630)
hgbot (developer)
2011-08-31 15:52

Repository: erp/devel/pi
Changeset: 14d6a595b95683637a313fb4dc9f181d0ec896e2
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Wed Aug 31 15:51:58 2011 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/14d6a595b95683637a313fb4dc9f181d0ec896e2 [^]

Related to issue 15728. Added admin mode. Made new class non-public (because it's only needed in the Image servlets)

---
M src/org/openbravo/erpCommon/utility/ImageUtils.java
---
(0040639)
hgbot (developer)
2011-08-31 18:05

Repository: erp/devel/pi
Changeset: 0324c4da6bd2191182243cadd3473090f67acc8a
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Wed Aug 31 18:05:14 2011 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/0324c4da6bd2191182243cadd3473090f67acc8a [^]

Related to issue 15728. Added information about the contributor (Francois Le Roux)

---
M CONTRIBUTORS
M src/org/openbravo/erpCommon/utility/ImageUtils.java
---
(0040670)
hudsonbot (developer)
2011-09-01 14:35

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6b7e3ac301b9 [^]

Maturity status: Test
(0040671)
hudsonbot (developer)
2011-09-01 14:35

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6b7e3ac301b9 [^]

Maturity status: Test
(0040673)
hudsonbot (developer)
2011-09-01 14:35

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6b7e3ac301b9 [^]

Maturity status: Test
(0040690)
iperdomo (developer)
2011-09-01 17:52

Tested on pi @ rev ecb8f9e371a5

- Issue History
Date Modified Username Field Change
2011-01-21 11:46 iperdomo New Issue
2011-01-21 11:46 iperdomo Assigned To => marvintm
2011-01-21 11:46 iperdomo Modules => Core
2011-01-21 12:09 shuehner Note Added: 0033804
2011-01-21 12:10 shuehner Issue Monitored: shuehner
2011-01-24 08:47 alostale Status new => scheduled
2011-05-17 09:15 iperdomo Priority urgent => normal
2011-06-02 10:53 dmitry_mezentsev Target Version 3.0MP0 => 3.0MP1
2011-06-22 19:41 dmitry_mezentsev Target Version 3.0MP1 => 3.0MP3
2011-08-31 15:29 hgbot Checkin
2011-08-31 15:29 hgbot Note Added: 0040629
2011-08-31 15:29 hgbot Status scheduled => resolved
2011-08-31 15:29 hgbot Resolution open => fixed
2011-08-31 15:29 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/073bf9bf00feb03b6215fa3d43e2bc0ab64f8e21 [^]
2011-08-31 15:52 hgbot Checkin
2011-08-31 15:52 hgbot Note Added: 0040630
2011-08-31 18:05 hgbot Checkin
2011-08-31 18:05 hgbot Note Added: 0040639
2011-09-01 14:35 hudsonbot Checkin
2011-09-01 14:35 hudsonbot Note Added: 0040670
2011-09-01 14:35 hudsonbot Checkin
2011-09-01 14:35 hudsonbot Note Added: 0040671
2011-09-01 14:35 hudsonbot Checkin
2011-09-01 14:35 hudsonbot Note Added: 0040673
2011-09-01 17:52 iperdomo Note Added: 0040690
2011-09-01 17:52 iperdomo Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker