Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0013935
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] Z. OtherscriticalN/A2010-07-09 18:132010-07-13 00:00
ReporteralostaleView Statuspublic 
Assigned Toalostale 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchpiFixed in SCM revision517a95b0c7a5
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0013935: try-api check 39 fails

Descriptionhttp://builds.openbravo.com/view/try/job/try-api/39/console [^]

Errors:

org.openbravo.services.webservice:
Missing
constructor org.openbravo.services.webservice.Module(java.lang.String, java.lang.String, org.openbravo.services.webservice.ModuleDependency[], java.lang.String, java.lang.String, org.openbravo.services.webservice.ModuleDependency[], java.lang.String, java.lang.String, java.lang.String, java.lang.String, java.lang.String, java.lang.String, java.lang.String, java.lang.String, java.lang.String, java.lang.String, java.lang.Boolean): missing in /srv/hudson/workspace/try-full-oracle/SANDBOX/api-checks/output/39
constructor org.openbravo.services.webservice.SimpleModule(java.lang.String, java.lang.String, java.lang.String, java.lang.String, java.lang.String, java.lang.String, java.lang.String, java.lang.String, java.lang.String, java.lang.String, java.lang.String, java.lang.String, java.lang.Boolean): missing in /srv/hudson/workspace/try-full-oracle/SANDBOX/api-checks/output/39
method org.openbravo.services.webservice.Module.getIsCommercial(): missing in /srv/hudson/workspace/try-full-oracle/SANDBOX/api-checks/output/39
method org.openbravo.services.webservice.Module.setIsCommercial(java.lang.Boolean): missing in /srv/hudson/workspace/try-full-oracle/SANDBOX/api-checks/output/39
method org.openbravo.services.webservice.SimpleModule.getIsCommercial(): missing in /srv/hudson/workspace/try-full-oracle/SANDBOX/api-checks/output/39
method org.openbravo.services.webservice.SimpleModule.setIsCommercial(java.lang.Boolean): missing in /srv/hudson/workspace/try-full-oracle/SANDBOX/api-checks/output/39
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0029196)
alostale (developer)
2010-07-09 18:16

This error is not in pi yet, it is in Modules Life Cycle Management branch.

For this project a new version of Central Repository Web Service has been developed and this api change is due the generated Java client is different.

It shouldn't be an issue since these services are only intended to be used by core, not by other modules. So suggestion: accept change.
(0029220)
alostale (developer)
2010-07-12 09:42

Already merged back to pi.
(0029226)
shuehner (administrator)
2010-07-12 13:02

I don't agree with this statement:
It shouldn't be an issue since these services are only intended to be used by core, not by other modules

As one utility program i wrote and use already had to be updated to work again.

However those client side function only make sense if they are in sync with the CR-serverside werservice -> suggestion: accept with low risk
(0029233)
pjuvara (reporter)
2010-07-12 15:19

Accepted. Please send notification with risk level low.
(0029239)
hgbot (developer)
2010-07-12 16:31

Repository: erp/devel/api-checks
Changeset: 517a95b0c7a519c63f60d5af4eb38b288cd23f2f
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Mon Jul 12 16:30:35 2010 +0200
URL: http://code.openbravo.com/erp/devel/api-checks/rev/517a95b0c7a519c63f60d5af4eb38b288cd23f2f [^]

fixed issue 13935: try-api check 39 fails

---
M java/reference/250.japi.gz
---

- Issue History
Date Modified Username Field Change
2010-07-09 18:13 alostale New Issue
2010-07-09 18:13 alostale Assigned To => adrianromero
2010-07-09 18:16 alostale Note Added: 0029196
2010-07-09 18:16 alostale Assigned To adrianromero => pjuvara
2010-07-12 09:42 alostale Note Added: 0029220
2010-07-12 13:02 shuehner Note Added: 0029226
2010-07-12 15:19 pjuvara Status new => scheduled
2010-07-12 15:19 pjuvara Note Added: 0029233
2010-07-12 15:19 pjuvara Assigned To pjuvara => alostale
2010-07-12 15:19 pjuvara fix_in_branch => pi
2010-07-12 16:31 hgbot Checkin
2010-07-12 16:31 hgbot Note Added: 0029239
2010-07-12 16:31 hgbot Status scheduled => resolved
2010-07-12 16:31 hgbot Resolution open => fixed
2010-07-12 16:31 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/api-checks/rev/517a95b0c7a519c63f60d5af4eb38b288cd23f2f [^]
2010-07-12 16:44 alostale Status resolved => closed
2010-07-13 00:00 anonymous sf_bug_id 0 => 3028669


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker