Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0012818
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 03. Procurement managementmajoralways2010-03-26 10:262010-05-14 15:27
ReporternetworkbView Statuspublic 
Assigned Toadrianromero 
PriorityurgentResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision19f1bedbb5ca
ProjectionnoneETAnoneTarget Version2.40MP13
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product Version2.40MP12SCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0012818: Error in 'Purchase Order Report'

DescriptionWhen we want to create a Purchase Order Report with a currency different from EURO, this error appears:

Error executing SQL statement for : ReportPurchaseOrder
Steps To Reproduce- Go to Procurement Management || Analysis Tools || Purchase Order Report
- Currency: USD and click 'Ok'
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00128562.40MP13 closedadrianromero Error in 'Purchase Order Report' 

-  Notes
(0026314)
adrianromero (manager)
2010-04-16 13:04

It also does not work selecting EUR.
It seems that the problem are the Starting Date and Ending Date fields. If these fields are empty, the reports works but if any of these fields has a valid date, it does not work.
(0026540)
hgbot (developer)
2010-04-21 13:08

Repository: erp/devel/pi
Changeset: 0d1ece383cd81f2ff5c525d8c09ddedc737b25a4
Author: Adrián Romero <adrianromero <at> openbravo.com>
Date: Wed Apr 21 13:23:06 2010 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/0d1ece383cd81f2ff5c525d8c09ddedc737b25a4 [^]

Fixes issue 0012818: Error in Purchase Order Report

---
M src/org/openbravo/base/secureApp/HttpSecureAppServlet.java
---
(0026664)
arunkumar (reporter)
2010-04-26 07:55

Now the error message is displayed as There is no conversion rate defined from (EUR-€) to (USD-$) for date '07-08-2006', Client 'SmallBazaar' and Organization 'Main'.

Tested & working fine
(0026681)
adrianromero (manager)
2010-04-26 15:24

Repository: erp/devel/pi
Changeset: 19f1bedbb5caa79ee914b4824633b874a4720b61
Author: Adrián Romero <adrianromero <at> openbravo.com>
Date: Mon Apr 26 15:10:45 2010 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/19f1bedbb5caa79ee914b4824633b874a4720b61 [^] [^]

Fixes issue 0012856: Error in 'Purchase Order Report

---
M src/org/openbravo/erpCommon/ad_reports/ReportPurchaseOrder.jrxml
---
(0026682)
adrianromero (manager)
2010-04-26 15:25
edited on: 2010-04-26 15:27

* Testing of the issue:
To test the issue just follow the steps to reproduce and execute the report with a currency different than EUR. Try to execute the report several times using different "Starting date" and "Ending date" values. The error message should always be similar to: There is no conversion rate defined from (EUR-€) to (USD-$) for date '07-08-2006', Client 'SmallBazaar' and Organization 'Main'.

* Explanation of the changeset that fixes the issue:
There has been modified the File HttpSecureAppServlet.java to get the causeException message instead of the JasperError Exception message. This is because the real message of the exception is in the causeException object.
It has been modified too the report template ReportPurchaseOrder.jrxml adding the function TO_DATE to the date parameters of the report to make the report work properly in Oracle and Postgresql.

* Other areas affected by the changeset:
The changes in the report template only affects to this report. And the changes in HttpSecureAppServlet.java affects to all jasper reports that throw an exception. The change is done the way if the causeException is an SQLException then use the SQLException message. That is the correct message that has to be translated and displayed to the user. In other case it will behave as before.

(0026683)
adrianromero (manager)
2010-04-26 15:26

It has been set as resolved again because it needed another changeset for Oracle
(0026712)
sureshbabu (developer)
2010-04-27 04:16

Retested in oracle context
(0027256)
hudsonbot (developer)
2010-05-14 15:27

A changeset related to this issue has been promoted to main after passing a series of tests and an OBX has been generated:

Changeset: http://code.openbravo.com/erp/devel/main/rev/0d1ece383cd8 [^]
Merge Changeset: http://code.openbravo.com/erp/devel/main/rev/36f76c8d7193 [^]
Tests: http://builds.openbravo.com/view/devel-int/ [^]
OBX: http://builds.openbravo.com/erp/core/obx/OpenbravoERP-2.50CI.17198.obx [^]

- Issue History
Date Modified Username Field Change
2010-03-26 10:26 networkb New Issue
2010-03-26 10:26 networkb Assigned To => adrianromero
2010-03-31 16:46 adrianromero Issue cloned 0012856
2010-03-31 16:46 adrianromero Relationship added depends on 0012856
2010-03-31 16:46 adrianromero Status new => scheduled
2010-03-31 16:46 adrianromero fix_in_branch => pi
2010-04-16 13:04 adrianromero Note Added: 0026314
2010-04-20 17:39 hgbot Checkin
2010-04-20 17:39 hgbot Note Added: 0026518
2010-04-20 17:39 hgbot Status scheduled => resolved
2010-04-20 17:39 hgbot Resolution open => fixed
2010-04-20 17:39 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/stable/2.40/rev/4110117ac7c437640eba5f95aed3113245b45e63 [^]
2010-04-20 17:45 adrianromero Status resolved => new
2010-04-20 17:45 adrianromero Resolution fixed => open
2010-04-20 17:45 adrianromero Status new => scheduled
2010-04-20 17:47 adrianromero Note Deleted: 0026518
2010-04-20 17:47 adrianromero Fixed in SCM revision http://code.openbravo.com/erp/stable/2.40/rev/4110117ac7c437640eba5f95aed3113245b45e63 [^] =>
2010-04-20 17:47 adrianromero fix_in_branch pi =>
2010-04-21 13:08 hgbot Checkin
2010-04-21 13:08 hgbot Note Added: 0026540
2010-04-21 13:08 hgbot Status scheduled => resolved
2010-04-21 13:08 hgbot Resolution open => fixed
2010-04-21 13:08 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/0d1ece383cd81f2ff5c525d8c09ddedc737b25a4 [^]
2010-04-26 07:55 arunkumar Note Added: 0026664
2010-04-26 07:55 arunkumar Status resolved => closed
2010-04-26 15:24 adrianromero Note Added: 0026681
2010-04-26 15:25 adrianromero Note Added: 0026682
2010-04-26 15:25 adrianromero Status closed => new
2010-04-26 15:25 adrianromero Status new => scheduled
2010-04-26 15:25 adrianromero fix_in_branch => pi
2010-04-26 15:26 adrianromero Note Added: 0026683
2010-04-26 15:26 adrianromero Status scheduled => resolved
2010-04-26 15:27 adrianromero Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/0d1ece383cd81f2ff5c525d8c09ddedc737b25a4 [^] => http://code.openbravo.com/erp/devel/pi/rev/19f1bedbb5caa79ee914b4824633b874a4720b61 [^]
2010-04-26 15:27 adrianromero fix_in_branch pi =>
2010-04-26 15:27 adrianromero Note Edited: 0026682 View Revisions
2010-04-27 04:16 sureshbabu Note Added: 0026712
2010-04-27 04:16 sureshbabu Status resolved => closed
2010-04-28 00:00 anonymous sf_bug_id 0 => 2993262
2010-05-14 15:27 hudsonbot Checkin
2010-05-14 15:27 hudsonbot Note Added: 0027256


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker