Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0012573
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformcriticalalways2010-03-05 11:412010-03-12 22:41
ReporternetworkbView Statuspublic 
Assigned Toalostale 
PriorityimmediateResolutionfixedFixed in Version2.50MP13
StatusclosedFix in branchFixed in SCM revisionb449a41b1922
ProjectionnoneETAnoneTarget Version2.50MP14
OSAnyDatabaseOracleJava version
OS VersionDatabase version10gAnt version
Product Version2.50MP12SCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0012573: The release 2.50mp12 can not be installed on a oracle 10g

DescriptionThe release 2.50mp12 can not be installed on a oracle 10g
wich is a supported database.
http://wiki.openbravo.com/wiki/ERP/2.50/Openbravo_environment_installation#Oracle_database [^]
Steps To ReproduceInstall the application on a oracle 10g database
You get the following error:

  [java] 1980 [main] INFO org.openbravo.wad.Wad - Updating table identifiers
     [java] 3927 [main] INFO org.openbravo.wad.Wad - Re-generating audit trail infrastructure
     [java] 3932 [main] ERROR org.openbravo.wad.WadData - SQL error in query: CALL AD_Create_Audit_Triggers(null)Exception:java.sql.SQLException: ORA-06575: La función o el paquete AD_CREATE_AUDIT_TRIGGERS tienen en un estado no válido
     [java]
     [java] Exception in thread "main" java.lang.Exception: javax.servlet.ServletException: @CODE=6575@ORA-06575: La función o el paquete AD_CREATE_AUDIT_TRIGGERS tienen en un estado no válido
     [java]
     [java] at org.openbravo.wad.Wad.main(Wad.java:428)
     [java] Caused by: javax.servlet.ServletException: @CODE=6575@ORA-06575: La función o el paquete AD_CREATE_AUDIT_TRIGGERS tienen en un estado no válido
     [java]
     [java] at org.openbravo.wad.WadData.updateAuditTrail(WadData.java:836)
     [java] at org.openbravo.wad.Wad.main(Wad.java:374)

BUILD FAILED
/home/openbravo/Apps/open250mp12ora/build.xml:333: The following error occurred while executing this line:
/home/openbravo/Apps/open250mp12ora/src/build.xml:393: Java returned: 1
Proposed SolutionChange the type of the code variable on the procedure
AD_CREATE_AUDIT_TRIGGERS
that actually is CLOB.
this procedure is not compiled on the oracle 10g database

TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0025086)
alostale (developer)
2010-03-05 15:42

Error(211,1): PL/SQL: Statement ignored
Error(211,18): PLS-00382: el tipo de la expresión no es correcto

is the error that appears when compiling the procedure.

The problem is that Oracle 10g does not support "execute immediate clob" (but Oracle 11g does).
(0025088)
hgbot (developer)
2010-03-05 16:11

Repository: erp/devel/pi
Changeset: b449a41b19229f6bbf8f40c52a1c3adc61ea2e9e
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Fri Mar 05 16:14:51 2010 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/b449a41b19229f6bbf8f40c52a1c3adc61ea2e9e [^]

fixed bug 12573: The release 2.50mp12 cannot be installed on a oracle 10g

---
M src-db/database/model/postscript-Oracle.sql
---
(0025399)
hudsonbot (developer)
2010-03-12 22:41

A changeset related to this issue has been promoted to main after passing a series of tests and an OBX has been generated:

Changeset: http://code.openbravo.com/erp/devel/main/rev/b449a41b1922 [^]
Merge Changeset: http://code.openbravo.com/erp/devel/main/rev/631c626866c1 [^]
Tests: http://builds.openbravo.com/view/devel-int/ [^]
OBX: http://builds.openbravo.com/erp/core/obx/OpenbravoERP-2.50CI.16685.obx [^]

- Issue History
Date Modified Username Field Change
2010-03-05 11:41 egoitz New Issue
2010-03-05 11:41 egoitz Assigned To => alostale
2010-03-05 11:45 networkb Reporter egoitz => networkb
2010-03-05 15:41 alostale Severity major => critical
2010-03-05 15:41 alostale Reproducibility have not tried => always
2010-03-05 15:42 alostale Note Added: 0025086
2010-03-05 16:11 hgbot Checkin
2010-03-05 16:11 hgbot Note Added: 0025088
2010-03-05 16:11 hgbot Status new => resolved
2010-03-05 16:11 hgbot Resolution open => fixed
2010-03-05 16:11 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/b449a41b19229f6bbf8f40c52a1c3adc61ea2e9e [^]
2010-03-08 16:05 jpabloae Target Version 2.50MP13 => 2.50MP14
2010-03-11 10:29 jpabloae Fixed in Version => 2.50MP13
2010-03-11 10:32 jpabloae Status resolved => closed
2010-03-12 00:00 anonymous sf_bug_id 0 => 2969006
2010-03-12 22:41 hudsonbot Checkin
2010-03-12 22:41 hudsonbot Note Added: 0025399


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker