Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0011520
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 00. Application dictionaryminoralways2009-11-26 16:492010-02-02 10:27
ReporternetworkbView Statuspublic 
Assigned Toalostale 
PriorityimmediateResolutionfixedFixed in Version2.50MP11
StatusclosedFix in branchFixed in SCM revision94d1960e6863
ProjectionnoneETAnoneTarget Version2.50MP11
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product Version2.50MP8SCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0011520: It's possible create a column with reserved names of java

DescriptionIt's possible create a column with reserved names of java. Application should not allow to include names with reserved values.
Steps To Reproduce-In your DB add a column, called 'Class', in a table.
-As System Adiministrator go to Application Dictionary || Tables and Columns || Table.
-Select the table which you had created the column, and click 'Create Columns From DB'

-Compile the table: ant compile.development -Dtab='Table's name'
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0010429 closedguilleaer Data Package allows invalid Java package names 

-  Notes
(0022853)
hgbot (developer)
2009-12-16 10:32

Repository: erp/devel/pi
Changeset: 38e79d643233e4f6054b4dafb0c0519f2dae513b
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Wed Dec 16 10:31:48 2009 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/38e79d643233e4f6054b4dafb0c0519f2dae513b [^]

fixed bug 11520: It's possible create a column with reserved names of java

---
M src-db/database/model/triggers/AD_COLUMN_TRG2.xml
M src-db/database/sourcedata/AD_MESSAGE.xml
---
(0022860)
hgbot (developer)
2009-12-16 13:08

Repository: erp/devel/pi
Changeset: 0f16f9e570fa78bba6a5911c50aadeb70cc4a48e
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Wed Dec 16 13:07:45 2009 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/0f16f9e570fa78bba6a5911c50aadeb70cc4a48e [^]

fixed bug 11520: added missing function

---
A src-db/database/model/functions/AD_ISJAVAWORD.xml
---
(0022945)
hudsonbot (developer)
2009-12-19 00:36

---
A changeset related to this issue has been promoted to main after passing a series of tests and an OBX has been generated:

Changeset: http://code.openbravo.com/erp/devel/main/rev/38e79d643233 [^]
Merge Changeset: http://code.openbravo.com/erp/devel/main/rev/867059305a34 [^]
Tests: http://builds.openbravo.com/view/devel-int/ [^]
OBX: http://builds.openbravo.com/erp/obx/core/OpenbravoERP-2.50CI.15773.obx [^]
---
(0022948)
hudsonbot (developer)
2009-12-19 00:36

---
A changeset related to this issue has been promoted to main after passing a series of tests and an OBX has been generated:

Changeset: http://code.openbravo.com/erp/devel/main/rev/0f16f9e570fa [^]
Merge Changeset: http://code.openbravo.com/erp/devel/main/rev/867059305a34 [^]
Tests: http://builds.openbravo.com/view/devel-int/ [^]
OBX: http://builds.openbravo.com/erp/obx/core/OpenbravoERP-2.50CI.15773.obx [^]
---
(0022972)
sureshbabu (reporter)
2009-12-21 09:35

System not allowing the user to create a column with java reserved names.

Right now system throws the below error message, when we click the 'Create columns from DB' button in Application Dictionary || Tables and Columns || Table after adding a column name 'Class' in a table.
      
"Error:
Not allowed column name "Class" is a reserved java keyword."
(0023843)
iperdomo (developer)
2010-01-28 10:06

This fix prevents users to modify existing tables that have a isDefault column already in core, e.g. C_CashBook
http://wiki.openbravo.com/wiki/ERP/2.50/Developers_Guide/Database_Model/org.openbravo.model.financialmgmt.cashmgmt/C_CashBook [^]
(0023846)
alostale (developer)
2010-01-28 10:35

The problem is the current fix is an overreaction to the initial issue. DAL doesn't generate physical members in the classes for the columns, but it does just add properties with getters and setters. So there's no problem with having columns named like Java reserved words, unless the generated getter and/or setter creates a conflict. This is the case of "class" name with creates a getClass method.

The final fix will prevent just columns named "class", but it will allow other Java reserved words.
(0023847)
eduardo_Argal (developer)
2010-01-28 11:23

Fix done in 0f16f9e570fa, is preventing the creation of new column for tables that already contains column that do not follow Java reserved words validation.
An example is any table containing column named IsDefault as its name results in Default which is a reserved name in java.
(0023906)
sureshbabu (reporter)
2010-02-02 10:27

Tested working fine

- Issue History
Date Modified Username Field Change
2009-11-26 16:49 networkb New Issue
2009-11-26 16:49 networkb Assigned To => rafaroda
2009-12-07 10:33 psarobe Status new => scheduled
2009-12-07 10:33 psarobe Assigned To rafaroda => alostale
2009-12-07 10:33 psarobe fix_in_branch => pi
2009-12-09 08:51 rafaroda Priority immediate => urgent
2009-12-09 08:51 rafaroda fix_in_branch pi =>
2009-12-16 09:31 alostale Relationship added related to 0010429
2009-12-16 10:01 alostale Note Added: 0022851
2009-12-16 10:02 alostale Note Deleted: 0022851
2009-12-16 10:32 hgbot Checkin
2009-12-16 10:32 hgbot Note Added: 0022853
2009-12-16 10:32 hgbot Status scheduled => resolved
2009-12-16 10:32 hgbot Resolution open => fixed
2009-12-16 10:32 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/38e79d643233e4f6054b4dafb0c0519f2dae513b [^]
2009-12-16 13:08 hgbot Checkin
2009-12-16 13:08 hgbot Note Added: 0022860
2009-12-16 13:08 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/38e79d643233e4f6054b4dafb0c0519f2dae513b [^] => http://code.openbravo.com/erp/devel/pi/rev/0f16f9e570fa78bba6a5911c50aadeb70cc4a48e [^]
2009-12-19 00:36 hudsonbot Checkin
2009-12-19 00:36 hudsonbot Note Added: 0022945
2009-12-19 00:36 hudsonbot Checkin
2009-12-19 00:36 hudsonbot Note Added: 0022948
2009-12-21 09:35 sureshbabu Note Added: 0022972
2009-12-21 09:35 sureshbabu Status resolved => closed
2009-12-21 09:35 sureshbabu Fixed in Version => 2.50MP10
2009-12-22 00:00 anonymous sf_bug_id 0 => 2918981
2010-01-28 10:06 iperdomo Note Added: 0023843
2010-01-28 10:06 iperdomo Status closed => new
2010-01-28 10:06 iperdomo Resolution fixed => open
2010-01-28 10:06 iperdomo Fixed in Version 2.50MP10 =>
2010-01-28 10:06 iperdomo Status new => scheduled
2010-01-28 10:06 iperdomo fix_in_branch => pi
2010-01-28 10:06 iperdomo Priority urgent => immediate
2010-01-28 10:06 iperdomo fix_in_branch pi =>
2010-01-28 10:35 alostale Note Added: 0023846
2010-01-28 11:23 eduardo_Argal Note Added: 0023847
2010-01-28 12:26 alostale Status scheduled => resolved
2010-01-28 12:26 alostale Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/0f16f9e570fa78bba6a5911c50aadeb70cc4a48e [^] => https://code.openbravo.com/erp/devel/pi/rev/94d1960e6863 [^]
2010-01-28 12:26 alostale Resolution open => fixed
2010-02-02 10:27 sureshbabu Note Added: 0023906
2010-02-02 10:27 sureshbabu Status resolved => closed
2010-02-02 10:27 sureshbabu Fixed in Version => 2.50MP11


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker