Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0011228
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2009-11-03 12:382010-01-23 00:00
ReporternetworkbView Statuspublic 
Assigned Toalostale 
PriorityurgentResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision5e7d82341f80
ProjectionnoneETAnoneTarget Version2.50MP11
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product Version2.50MP6SCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0011228: The ad_menu is not correctly managed with modularity

DescriptionThe ad_menu is not correctly managed with modularity.
If you create a new menu entry using the OpenbravoAdmin role
then, when exporting to xml the module, it is exported with ad_client=1000000
wich is a problem if you try to install the module
in another applciation where the client_ID=1000000 does not exist
Steps To Reproduce-Login as system administrator
-Define a new module
-Logout
-Login to the application as OpenbravoAdmin
-Create a menu entry for the module created before
-Export the module.
-See that the menu entry has been exported with ad_client_id=1000000
wich can cause problems when installing the module in an aplication
where the ad_client_id=1000000 does not exist
Proposed Solution-Export only entries with ad_client_id=0

-Don't allow OpenbravoAdmin roles to create elements of the
 Application dictionary as menu entries.


TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on feature request 0011247 closediciordia Add capability to modules to execute postScripts 

-  Notes
(0021546)
rafaroda (developer)
2009-11-04 09:02

Asier,

Can you please comment on this issue?

Thanks.
(0021560)
alostale (developer)
2009-11-04 15:49

Even though it is possible to define menu within a client, currently Openbravo ERP doesn't support this feature, which means the menu will be the same for all clients.

The fix would be to set AD_Menu table to System accesslevel (currently it is System/Client), but this could create inconsistencies in the data for instances with menu entries in a client different to 0. Therefore it would be necessary to execute a script to move menu data from other clients to 0 when upgrading to this new version. As currently this is not possible this is not going to be fixed till feature request 0011247 is not implemented.

Anyway, there is an easy workarround which consists in moving existent menu entries from other clients to 0 and not entering data in other clients.
(0021561)
alostale (developer)
2009-11-04 15:51

Lowed priority because it is not going to be fixed till 0011247 is implemented.
(0023338)
alostale (developer)
2010-01-12 10:46

It's fixed without waiting for 0011247.

In case there're data in the menu table for clients different than 0, they should be moved to 0 or deleted.

To move them execute this script:

update ad_menu set ad_client_id ='0' where ad_client_id !='0';
(0023340)
hgbot (developer)
2010-01-12 10:47

Repository: erp/devel/pi
Changeset: 5e7d82341f808af6f508d6f60f2eda8e2290bed3
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Tue Jan 12 10:46:48 2010 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/5e7d82341f808af6f508d6f60f2eda8e2290bed3 [^]

fixed bug 11228: The ad_menu is not correctly managed with modularity

---
M src-db/database/sourcedata/AD_TABLE.xml
---
(0023542)
hudsonbot (developer)
2010-01-19 01:41

A changeset related to this issue has been promoted to main after passing a series of tests and an OBX has been generated:

Changeset: http://code.openbravo.com/erp/devel/main/rev/5e7d82341f80 [^]
Merge Changeset: http://code.openbravo.com/erp/devel/main/rev/7f3a35240cf9 [^]
Tests: http://builds.openbravo.com/view/devel-int/ [^]
OBX: http://builds.openbravo.com/erp/obx/core/OpenbravoERP-2.50CI.15846.obx [^]
(0023735)
marvintm (developer)
2010-01-22 10:59

The window can no longer be accessed with the Openbravo admin role.

- Issue History
Date Modified Username Field Change
2009-11-03 12:38 networkb New Issue
2009-11-03 12:38 networkb Assigned To => rafaroda
2009-11-04 09:02 rafaroda Note Added: 0021546
2009-11-04 09:02 rafaroda Assigned To rafaroda => alostale
2009-11-04 09:02 rafaroda Issue Monitored: rafaroda
2009-11-04 15:49 alostale Note Added: 0021560
2009-11-04 15:49 alostale Relationship added depends on 0011247
2009-11-04 15:51 alostale Note Added: 0021561
2009-11-04 15:51 alostale Priority immediate => urgent
2009-11-11 16:21 hgbot Checkin
2009-11-11 16:21 hgbot Note Added: 0021728
2009-11-11 16:21 hgbot Status new => resolved
2009-11-11 16:21 hgbot Resolution open => fixed
2009-11-11 16:21 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/1a8c8b1006b108529be68be4fbb7f41df72cf846 [^]
2009-11-11 16:27 alostale Status resolved => new
2009-11-11 16:27 alostale Resolution fixed => open
2009-11-11 16:27 alostale Note Added: 0021729
2009-11-12 11:20 alostale Note Deleted: 0021728
2009-11-12 11:20 alostale Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/1a8c8b1006b108529be68be4fbb7f41df72cf846 [^] =>
2009-11-12 11:21 alostale Note Deleted: 0021729
2009-11-16 11:26 rafaroda Status new => acknowledged
2010-01-12 10:46 alostale Note Added: 0023338
2010-01-12 10:47 hgbot Checkin
2010-01-12 10:47 hgbot Note Added: 0023340
2010-01-12 10:47 hgbot Status acknowledged => resolved
2010-01-12 10:47 hgbot Resolution open => fixed
2010-01-12 10:47 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/5e7d82341f808af6f508d6f60f2eda8e2290bed3 [^]
2010-01-19 01:41 hudsonbot Checkin
2010-01-19 01:41 hudsonbot Note Added: 0023542
2010-01-22 10:59 marvintm Note Added: 0023735
2010-01-22 10:59 marvintm Status resolved => closed
2010-01-23 00:00 anonymous sf_bug_id 0 => 2937516


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker