Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0011200
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementmajoralways2009-10-30 18:432009-11-06 00:00
ReporternetworkbView Statuspublic 
Assigned Tovmromanos 
PriorityurgentResolutionfixedFixed in Version2.50MP9
StatusclosedFix in branchpiFixed in SCM revisione0eecec749cf
ProjectionnoneETAnoneTarget Version2.40MP11
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product Version2.40MP10SCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0011200: ReportBankJR doesn't group data properly

DescriptionIf you have two bankstatements with different name but with same statementdate they are not properly grouped, because lines of same bankstatement are not grouped.

Steps To ReproduceIn an application with BigBazaar data:

1. Financial Management || Receivables & Payables || Transactions || Bank Statement || Header : search for bankstatement with name "18-10-2006"
2. Modify the name of the bankstatement with ending balance=241.41
3. Check that it has 4 lines
4. Execute Financial Management || Receivables & Payables || Analysis Tools || Bank Report || Bank Report with dates= 18-10-2006
5. Check that lines from same bankstatement are not grouped
TagsNo tags attached.
Attached Filespng file icon bankreport18.png [^] (83,301 bytes) 2009-10-30 18:43

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00112242.40MP11 closedvmromanos ReportBankJR doesn't group data properly 

-  Notes
(0021498)
rafaroda (developer)
2009-11-02 06:04

David,

Can you please comment on this issue?

Thanks.
(0021515)
vmromanos (developer)
2009-11-02 17:00

Rafa,
David is on holidays...

The issue is a bug: the bank statement lines should be grouped.
(0021534)
hgbot (developer)
2009-11-03 13:59

Repository: erp/devel/pi
Changeset: e0eecec749cf4d1f974d7fa41cc534ba0f84861e
Author: Víctor Martínez Romanos <victor.martinez <at> openbravo.com>
Date: Tue Nov 03 14:00:56 2009 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/e0eecec749cf4d1f974d7fa41cc534ba0f84861e [^]

Fixed bug 11200: ReportBankJR does not group data properly

---
M src/org/openbravo/erpCommon/ad_reports/ReportBankJR.jrxml
M src/org/openbravo/erpCommon/ad_reports/ReportBankJR_data.xsql
---
(0021583)
arunkumar (reporter)
2009-11-05 09:36

Tested & Working fine.

- Issue History
Date Modified Username Field Change
2009-10-30 18:43 networkb New Issue
2009-10-30 18:43 networkb Assigned To => rafaroda
2009-10-30 18:43 networkb File Added: bankreport18.png
2009-11-02 06:04 rafaroda Note Added: 0021498
2009-11-02 06:04 rafaroda Assigned To rafaroda => dalsasua
2009-11-02 06:04 rafaroda Status new => acknowledged
2009-11-02 17:00 vmromanos Note Added: 0021515
2009-11-03 08:25 rafaroda Assigned To dalsasua => vmromanos
2009-11-03 08:25 rafaroda Priority immediate => urgent
2009-11-03 08:25 rafaroda Status acknowledged => scheduled
2009-11-03 08:25 rafaroda Status scheduled => feedback
2009-11-03 08:25 rafaroda Status feedback => scheduled
2009-11-03 08:25 rafaroda fix_in_branch => pi
2009-11-03 13:59 hgbot Checkin
2009-11-03 13:59 hgbot Note Added: 0021534
2009-11-03 13:59 hgbot Status scheduled => resolved
2009-11-03 13:59 hgbot Resolution open => fixed
2009-11-03 13:59 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/e0eecec749cf4d1f974d7fa41cc534ba0f84861e [^]
2009-11-05 09:36 arunkumar Status resolved => closed
2009-11-05 09:36 arunkumar Note Added: 0021583
2009-11-05 09:36 arunkumar Fixed in Version => 2.50MP9
2009-11-06 00:00 anonymous sf_bug_id 0 => 2892915


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker