Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0010704
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformcriticalalways2009-09-22 17:282009-09-23 00:00
ReporteriperdomoView Statuspublic 
Assigned Toiperdomo 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchpiFixed in SCM revisiona480d431ba09
ProjectionnoneETAnoneTarget Version2.50MP6
OSLinux 32 bitDatabasePostgreSQLJava version1.6.0_15
OS Version2.6.30-gentoo-r5Database version8.3.8Ant version1.7.1
Product VersionpiSCM revision12c30a4b5d14 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0010704: API check 147 fails due to change in new CR implementation

DescriptionError Summary:
Methods: 11 missing, 2 abs.add.
Constructors: 3 missing.

Errors:

org.openbravo.services.webservice:
Missing
constructor org.openbravo.services.webservice.Module(java.lang.String, java.lang.String, org.openbravo.services.webservice.ModuleDependency[], java.lang.String, java.lang.String, org.openbravo.services.webservice.ModuleDependency[], java.lang.String, java.lang.String, java.lang.String, java.lang.String, java.lang.String, java.lang.String, java.lang.String, java.lang.String, java.lang.String, java.lang.String): missing in /var/www/localhost/htdocs/japi/147
constructor org.openbravo.services.webservice.ModuleDependency(java.lang.String, java.lang.String, java.lang.String, java.lang.String, java.lang.String, java.lang.String): missing in /var/www/localhost/htdocs/japi/147
constructor org.openbravo.services.webservice.SimpleModule(java.lang.String, java.lang.String, java.lang.String, java.lang.String, java.lang.String, java.lang.String, java.lang.String, java.lang.String, java.lang.String, java.lang.String, java.lang.String, java.lang.String): missing in /var/www/localhost/htdocs/japi/147
method org.openbravo.services.webservice.ModuleDependency.getModuleVersionID(): missing in /var/www/localhost/htdocs/japi/147
method org.openbravo.services.webservice.ModuleDependency.setModuleVersionID(java.lang.String): missing in /var/www/localhost/htdocs/japi/147
method org.openbravo.services.webservice.WebServiceImpl.getCustomer(int, int, java.lang.String, java.lang.String): missing in /var/www/localhost/htdocs/japi/147
method org.openbravo.services.webservice.WebServiceImpl.getCustomer(int, java.lang.String, java.lang.String, java.lang.String, java.lang.String): missing in /var/www/localhost/htdocs/japi/147
method org.openbravo.services.webservice.WebServiceImpl.getCustomerAddresses(int, int, java.lang.String, java.lang.String): missing in /var/www/localhost/htdocs/japi/147
method org.openbravo.services.webservice.WebServiceImpl.getCustomerContact(int, int, int, java.lang.String, java.lang.String): missing in /var/www/localhost/htdocs/japi/147
method org.openbravo.services.webservice.WebServiceImpl.getCustomerLocation(int, int, int, java.lang.String, java.lang.String): missing in /var/www/localhost/htdocs/japi/147
method org.openbravo.services.webservice.WebServiceImpl.getCustomers(int, java.lang.String, java.lang.String): missing in /var/www/localhost/htdocs/japi/147
method org.openbravo.services.webservice.WebServiceImpl.updateAddress(org.openbravo.services.webservice.Location, java.lang.String, java.lang.String): missing in /var/www/localhost/htdocs/japi/147
method org.openbravo.services.webservice.WebServiceImpl.updateContact(org.openbravo.services.webservice.Contact, java.lang.String, java.lang.String): missing in /var/www/localhost/htdocs/japi/147
method org.openbravo.services.webservice.WebServiceImpl.updateCustomer(org.openbravo.services.webservice.BusinessPartner, java.lang.String, java.lang.String): missing in /var/www/localhost/htdocs/japi/147
Abs.add
method org.openbravo.services.webservice.WebServiceImpl.getURLforDownload(java.lang.String): new interface method in /var/www/localhost/htdocs/japi/147
method org.openbravo.services.webservice.WebServiceImpl.isCommercial(java.lang.String): new interface method in /var/www/localhost/htdocs/japi/147
Proposed SolutionApprove the changes that are due to auto generated classes based on a WSDL definition.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0020278)
iperdomo (developer)
2009-09-22 17:32

Type: Missing java method (constructor)

Description: This classes are generated with the wsdl2java application. This changes are due to a change in the Central Repository implementation. This classes are used by the Module Management Console.

Risk: Low
(0020280)
shuehner (administrator)
2009-09-22 18:00

@iperdomo: do the new client classes need to work with the old server-side version? Or can we exclude that by synchronously updating the cr itself?

Did we change any classes exported (serverside) by a running ob-instance?
(0020281)
iperdomo (developer)
2009-09-22 18:04

Q. do the new client classes need to work with the old server-side version? Or can we exclude that by synchronously updating the cr itself?
A. The new version uses a new version of the CR, old versions of Openbravo will use the old version of the CR

Q. Did we change any classes exported (serverside) by a running ob-instance?
A. No
(0020282)
iciordia (manager)
2009-09-22 18:13

I approve it on Paolo's behalf
(0020284)
hgbot (developer)
2009-09-22 18:53

Repository: erp/devel/api-checks
Changeset: a480d431ba09dc8f4b64484c8213050ffb68c16a
Author: Iván Perdomo <ivan.perdomo <at> openbravo.com>
Date: Tue Sep 22 18:52:49 2009 +0200
URL: http://code.openbravo.com/erp/devel/api-checks/rev/a480d431ba09dc8f4b64484c8213050ffb68c16a [^]

Fixes issue 10704: Updated Java API

---
M java/reference/250.japi.gz
---
(0020285)
iperdomo (developer)
2009-09-22 18:55

Updated Java API reference file.

- Issue History
Date Modified Username Field Change
2009-09-22 17:28 iperdomo New Issue
2009-09-22 17:28 iperdomo Assigned To => iperdomo
2009-09-22 17:28 iperdomo Status new => scheduled
2009-09-22 17:28 iperdomo fix_in_branch => pi
2009-09-22 17:32 iperdomo Note Added: 0020278
2009-09-22 17:32 iperdomo Assigned To iperdomo => pjuvara
2009-09-22 17:37 iciordia Assigned To pjuvara => iciordia
2009-09-22 18:00 shuehner Note Added: 0020280
2009-09-22 18:04 iperdomo Note Added: 0020281
2009-09-22 18:13 iciordia Note Added: 0020282
2009-09-22 18:13 iciordia Assigned To iciordia => iperdomo
2009-09-22 18:53 hgbot Checkin
2009-09-22 18:53 hgbot Note Added: 0020284
2009-09-22 18:53 hgbot Status scheduled => resolved
2009-09-22 18:53 hgbot Resolution open => fixed
2009-09-22 18:53 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/api-checks/rev/a480d431ba09dc8f4b64484c8213050ffb68c16a [^]
2009-09-22 18:55 iperdomo Note Added: 0020285
2009-09-22 18:55 iperdomo Fixed in SCM revision http://code.openbravo.com/erp/devel/api-checks/rev/a480d431ba09dc8f4b64484c8213050ffb68c16a [^] => https://code.openbravo.com/erp/devel/api-checks/rev/a480d431ba09 [^]
2009-09-22 18:55 iperdomo Status resolved => closed
2009-09-23 00:00 anonymous sf_bug_id 0 => 2864626


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker