Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0010319
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2009-08-18 21:002009-10-23 00:00
ReporternetworkbView Statuspublic 
Assigned Tovmromanos 
PriorityurgentResolutionfixedFixed in Version
StatusclosedFix in branchpiFixed in SCM revision908a09f23ff5
ProjectionnoneETAnoneTarget Version2.50MP7
OSLinux 32 bitDatabasePostgreSQLJava version
OS VersionDatabase versionAnt version
Product Version2.50MP2SCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0010319: Field "Document Status" not translated in Search window

DescriptionRunning OPenbravo in Spanish,when search a Purchase Order, the list values of Document Status filter appears in English.

The application doesn't translate these reference_lst values but the list is translated correctly in window (edition view)
Steps To Reproduce-Go to Gestión de Compras || Transacciones || Pedido de compra || Cabecera
-Click Search button
-See "Estado del documento", all the list values are in english (Closed, Draft, etc..) You can see that in Purchase ORder window the list values Estado del doc. appear in Spanish.
TagsNo tags attached.
Attached Filespng file icon Nottranslated.png [^] (24,639 bytes) 2009-08-19 09:17


jpg file icon issue10319.JPG [^] (192,889 bytes) 2009-10-08 09:51

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0019037)
rafaroda (developer)
2009-08-19 09:17

Updated to Major since it is a Platform related issue with Translation handling.

Please notice that if you make Project Status column as "searchable" in Application Dictionary and then click on the Search icon you get the Project Status also in English even if you are logged in Spanish.

Both Document and Project Status are correctly translated in the Spanish Localization Pack:

SELECT RE.NAME AS REFERENCE, REL.NAME AS EN, RELT.NAME AS ES
FROM AD_REFERENCE RE, AD_REF_LIST REL, AD_REF_LIST_TRL RELT
WHERE RE.AD_REFERENCE_ID = REL.AD_REFERENCE_ID
AND REL.AD_REF_LIST_ID = RELT.AD_REF_LIST_ID
AND RELT.AD_LANGUAGE = 'es_ES'
AND (UPPER(RE.NAME) LIKE '%PROJECTSTATUS%' OR UPPER(RE.NAME) LIKE '%ALL_DOCUMENT_STATUS%')
ORDER BY REFERENCE
(0020222)
rafaroda (developer)
2009-09-21 06:30

No more an OBPS issue.
(0020309)
hgbot (developer)
2009-09-23 12:19

Repository: erp/devel/pi
Changeset: 908a09f23ff5c5d9fd5a9f4cf7a3d074a606ea80
Author: Stefan Hühner <stefan.huehner <at> openbravo.com>
Date: Wed Sep 23 12:19:29 2009 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/908a09f23ff5c5d9fd5a9f4cf7a3d074a606ea80 [^]

Fixed 10319: Fix translation of combo fields in search popup
New search popup code does not use getContext to disable default values.
However #AD_LANGUAGE needs an exception to make translations work

---
M src/org/openbravo/erpCommon/utility/Utility.java
---
(0020504)
hgbot (developer)
2009-09-29 14:17

Repository: erp/devel/pi-pageddatagrid
Changeset: 908a09f23ff5c5d9fd5a9f4cf7a3d074a606ea80
Author: Stefan Hühner <stefan.huehner <at> openbravo.com>
Date: Wed Sep 23 12:19:29 2009 +0200
URL: http://code.openbravo.com/erp/devel/pi-pageddatagrid/rev/908a09f23ff5c5d9fd5a9f4cf7a3d074a606ea80 [^]

Fixed 10319: Fix translation of combo fields in search popup
New search popup code does not use getContext to disable default values.
However #AD_LANGUAGE needs an exception to make translations work

---
M src/org/openbravo/erpCommon/utility/Utility.java
---
(0020868)
arunkumar (reporter)
2009-10-08 09:50

When I retest in amazon PI postgres context I still see the list values are not translated in Spanish.Please refer the screenshot I added for this and also can you please tell me whether did I test properly? Since you have resolved it I would like to know how do I test to see this as resolved?
(0020988)
shuehner (administrator)
2009-10-13 15:44

Re-checked: If a value for the translation of the combobox-entry is present in i.e. spanish, then now after the fix this value is used.

However it seems that the values for the translation of this combo are not present at all in the spanish translation pack.

This can be verified by checking that the translation for this combo is present in edit mode which it was not in my tests.
Or this can be checked by examining the translation for the reference entry 'All_Document Status' or by using the sql provided in the first comment (by Rafa). However this info seems to contradict the claim by Rafa that the translation is present.
(0021062)
shuehner (administrator)
2009-10-15 15:16

Reassigned to localization. Technically the popup nows shows a translation if it exists. However the latest released spanish translation obx did not contain a translation for this part (ad_ref_list_trl).

This issue should be finally closed when the next/correct translation obx is released.
(0021084)
vmromanos (developer)
2009-10-15 18:26

Fixed in the Spanish Translation Module version 1.0.4, available at the Central Repository or at http://forge.openbravo.com/plugins/module/index.php?group_id=172 [^]

- Issue History
Date Modified Username Field Change
2009-08-18 21:00 networkb New Issue
2009-08-18 21:00 networkb Assigned To => rafaroda
2009-08-18 21:01 networkb Issue Monitored: networkb
2009-08-19 09:17 rafaroda Note Added: 0019037
2009-08-19 09:17 rafaroda Assigned To rafaroda => alostale
2009-08-19 09:17 rafaroda Priority immediate => urgent
2009-08-19 09:17 rafaroda Severity minor => major
2009-08-19 09:17 rafaroda Status new => scheduled
2009-08-19 09:17 rafaroda Category E. Translation => A. Platform
2009-08-19 09:17 rafaroda File Added: Nottranslated.png
2009-08-20 09:54 networkb Target Version => 2.50MP6
2009-08-31 10:42 rafaroda Relationship added related to 0010205
2009-09-09 12:25 iciordia Assigned To alostale => shuehner
2009-09-15 13:20 networkb Target Version 2.50MP6 =>
2009-09-21 06:30 rafaroda Note Added: 0020222
2009-09-23 12:13 shuehner Relationship deleted related to 0010205
2009-09-23 12:19 hgbot Checkin
2009-09-23 12:19 hgbot Note Added: 0020309
2009-09-23 12:19 hgbot Status scheduled => resolved
2009-09-23 12:19 hgbot Resolution open => fixed
2009-09-23 12:19 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/908a09f23ff5c5d9fd5a9f4cf7a3d074a606ea80 [^]
2009-09-23 16:11 psarobe Target Version => 2.50MP6
2009-09-23 16:12 psarobe Tag Attached: 250mp6
2009-09-24 19:21 psarobe Tag Detached: 250mp6
2009-09-24 19:21 psarobe Target Version 2.50MP6 => 2.50MP7
2009-09-29 14:17 hgbot Checkin
2009-09-29 14:17 hgbot Note Added: 0020504
2009-09-29 14:17 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/908a09f23ff5c5d9fd5a9f4cf7a3d074a606ea80 [^] => http://code.openbravo.com/erp/devel/pi-pageddatagrid/rev/908a09f23ff5c5d9fd5a9f4cf7a3d074a606ea80 [^]
2009-10-08 09:50 arunkumar Status resolved => new
2009-10-08 09:50 arunkumar Resolution fixed => open
2009-10-08 09:50 arunkumar Note Added: 0020868
2009-10-08 09:51 arunkumar File Added: issue10319.JPG
2009-10-09 09:06 psarobe Status new => scheduled
2009-10-09 09:06 psarobe fix_in_branch => pi
2009-10-13 15:44 shuehner Note Added: 0020988
2009-10-15 15:14 shuehner Assigned To shuehner => vmromanos
2009-10-15 15:16 shuehner Note Added: 0021062
2009-10-15 18:26 vmromanos Status scheduled => resolved
2009-10-15 18:26 vmromanos Resolution open => fixed
2009-10-15 18:26 vmromanos Note Added: 0021084
2009-10-22 11:21 plujan Status resolved => closed
2009-10-23 00:00 anonymous sf_bug_id 0 => 2884246


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker