Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0010246
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementmajoralways2009-08-12 10:322009-08-19 00:00
ReportermgerkeView Statuspublic 
Assigned Tovinothbabu 
PriorityurgentResolutionfixedFixed in Versionpi
StatusclosedFix in branchFixed in SCM revision0711d379842e
ProjectionnoneETAnoneTarget Version
OSLinux 32 bitDatabasePostgreSQLJava version1.6.0_11
OS VersionrPath LinuxDatabase version8.3.5Ant version1.7.1
Product Version2.50MP2SCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0010246: missing unique constraint on c_elemenvalue.value

DescriptionIn 2.50 MP1 there was a unique constraint on c_elemenvalue.value

In MP2 it was proposed to delete the unique constraint and add an unique index, see
http://wiki.openbravo.com/wiki/ERP/2.50/Developers_Guide/Database_Model/org.openbravo.model.financialmgmt.accounting.coa/C_ElementValue#Indexes [^]
and
//www.mail-archive.com/openbravo-commits@lists.sourceforge.net/msg03514.html">http://www.mail-archive.com/openbravo-commits@lists.sourceforge.net/msg03514.html [//www.mail-archive.com/openbravo-commits@lists.sourceforge.net/msg03514.html" target="_blank">^]

The unique constraint was deleted, but the unique index was not inserted

Now it is possible to insert 2 or more accounts with the same value (=searchkey). This behavior violates the accounting rules e.g. in Germany.
Steps To Reproducesee DB with pgAdmin or C_ELEMENTVALUE.xml

Proposed SolutionAdd the unique index
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0010313 closedvinothbabu API check build 112 fails - part2 

-  Notes
(0018934)
rafaroda (developer)
2009-08-13 13:28

Vinoth,

Can you please take action on this issue? Was the constraint deleted by some particular reason? https://code.openbravo.com/erp/devel/pi/diff/3cb40e9246fc/src-db/database/model/tables/C_ELEMENTVALUE.xml [^]

Has it to be re-placed by another constraint? https://code.openbravo.com/erp/devel/pi/rev/3cb40e9246fc [^]

Thanks.
(0018938)
hgbot (developer)
2009-08-13 18:54

Repository: erp/devel/pi
Changeset: 0711d379842ee1f28f4a05a1c34632bf6f7861f5
Author: Vinoth Babu <vinoth.babu <at> openbravo.com>
Date: Thu Aug 13 22:22:50 2009 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/0711d379842ee1f28f4a05a1c34632bf6f7861f5 [^]

Fixes bug 10246 Missing unique constraint on c_elemenvalue.value

---
M src-db/database/model/tables/C_ELEMENTVALUE.xml
---
(0018988)
sureshbabu (reporter)
2009-08-18 09:09

Closing this issue since i am not able to reproduce this issue (Informed to Pablo Lujan)

- Issue History
Date Modified Username Field Change
2009-08-12 10:32 mgerke New Issue
2009-08-12 10:32 mgerke Assigned To => rafaroda
2009-08-13 13:28 rafaroda Note Added: 0018934
2009-08-13 13:28 rafaroda Assigned To rafaroda => vinothbabu
2009-08-13 13:28 rafaroda Priority normal => urgent
2009-08-13 13:28 rafaroda Severity critical => major
2009-08-13 13:28 rafaroda Status new => scheduled
2009-08-13 18:54 hgbot Checkin
2009-08-13 18:54 hgbot Note Added: 0018938
2009-08-13 18:54 hgbot Status scheduled => resolved
2009-08-13 18:54 hgbot Resolution open => fixed
2009-08-13 18:54 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/0711d379842ee1f28f4a05a1c34632bf6f7861f5 [^]
2009-08-18 09:09 sureshbabu Status resolved => closed
2009-08-18 09:09 sureshbabu Note Added: 0018988
2009-08-18 09:09 sureshbabu Fixed in Version => pi
2009-08-18 15:06 rafaroda Relationship added related to 0010313
2009-08-19 00:00 anonymous sf_bug_id 0 => 2839904


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker