Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0049614
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo Localizations] Localization Francemajoralways2022-06-21 11:012022-08-03 14:06
ReporterrfaconView Statuspublic 
Assigned Tosebastien_liron 
PrioritynormalResolutionduplicateFixed in Version
StatusclosedFix in branchFixed in SCM revision
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Regression date
Regression introduced by commit
Regression level
Regression introduced in release
Summary

0049614: Wrong tax calculation for sales to exempt customers (conflict between Metropolitan/DOMTOM tax)

DescriptionWhen two discounts Tax Exempt = Y are configured the same way for an Organization, the most recent 'Valid from Date' is applied.
Regions defined in the Tax Zone subtab should be considered in addition.
Steps To Reproduce1. Having two different Tax rates configured for the same Organization with :
- Country : France, Destination Country : France
- Tax Exempt = Yes
- Rate : 0,00

2. For one discount, "TVA Normale Exonérée", apply in the Tax Zone :
- From Country : France
- From Region : Hauts-de-France
- Destination Country : France
- Destination Region : Hauts-de-France

3. For one discount, "Export DOM-TOM Normale", apply in the Tax Zone :
- From Country : France
- From Region : Guadeloupe
- Destination Country : France
- Destination Region : Guadeloupe

4. Login a French WebPOS located in one of the two Regions defined, add an article with normal tax and a customer tagged as Tax Exempt.
You will see that the discount is applied according to the most recent 'Valid from Date' of the two discounts. If both are equal, the two taxes will be applied (picture joined).
The region should be taken into account also when selecting the appropriate discount
TagsNOR
Attached Filespng file icon 2 Taxes applied.png [^] (61,155 bytes) 2022-06-21 11:01


png file icon Screenshot from 2022-07-13 14-56-05.png [^] (109,095 bytes) 2022-07-13 15:02


png file icon Screenshot from 2022-07-13 14-56-19.png [^] (108,798 bytes) 2022-07-13 15:03


png file icon Screenshot from 2022-07-13 14-56-36.png [^] (174,136 bytes) 2022-07-13 15:03


png file icon Screenshot from 2022-07-13 14-56-52.png [^] (139,041 bytes) 2022-07-13 15:03


png file icon Screenshot from 2022-07-13 14-57-00.png [^] (279,544 bytes) 2022-07-13 15:04

- Relationships Relation Graph ] Dependency Graph ]
duplicate of defect 0049939 closedTriage Omni OMS Openbravo Localizations Two exempt taxes are applied for a tax exempt customer 
related to defect 0048580 closedebecerra POS2 2693: Tax engine is not working well when several tax zones are defined 

-  Notes
(0139307)
aferraz (developer)
2022-07-13 15:02
edited on: 2022-07-15 11:32

POS applies the correct tax taking into account the store region.
See attached images.
Probably fixed in 0048580.

(0139594)
sebastien_liron (developer)
2022-07-25 11:01

0048580 is for POS 2, not POS 1, and the issue is in 20q3
(0139607)
aferraz (developer)
2022-07-26 12:15

The fix you need to apply is 0048619.
(0139608)
sebastien_liron (developer)
2022-07-26 12:31

re -applying mantis 48619 for mantis 49614 resolution, regression included with mantis 48737
(0139719)
aferraz (developer)
2022-07-29 12:22

Pending to validate from project team if reapplying 0048619 solves the issue.
(0139841)
rafaroda (developer)
2022-08-03 14:05

Here confirmed that we still have the issue: new Mantis has been opened 0049939

- Issue History
Date Modified Username Field Change
2022-06-21 11:01 rfacon New Issue
2022-06-21 11:01 rfacon File Added: 2 Taxes applied.png
2022-06-21 11:47 sebastien_liron Assigned To => psanjuan
2022-06-22 14:32 rafaroda Tag Attached: NOR
2022-06-22 14:33 rafaroda Steps to Reproduce Updated View Revisions
2022-07-13 15:02 aferraz Note Added: 0139307
2022-07-13 15:02 aferraz Status new => closed
2022-07-13 15:02 aferraz Resolution open => unable to reproduce
2022-07-13 15:02 aferraz File Added: Screenshot from 2022-07-13 14-56-05.png
2022-07-13 15:03 aferraz File Added: Screenshot from 2022-07-13 14-56-19.png
2022-07-13 15:03 aferraz File Added: Screenshot from 2022-07-13 14-56-36.png
2022-07-13 15:03 aferraz File Added: Screenshot from 2022-07-13 14-56-52.png
2022-07-13 15:04 aferraz File Added: Screenshot from 2022-07-13 14-57-00.png
2022-07-13 15:10 aferraz Note Edited: 0139307 View Revisions
2022-07-13 15:10 aferraz Relationship added related to 0048580
2022-07-13 15:10 aferraz Assigned To psanjuan => aferraz
2022-07-15 11:32 aferraz Note Edited: 0139307 View Revisions
2022-07-25 11:01 sebastien_liron Note Added: 0139594
2022-07-25 11:01 sebastien_liron Status closed => new
2022-07-26 12:15 aferraz Note Added: 0139607
2022-07-26 12:31 sebastien_liron Note Added: 0139608
2022-07-29 12:22 aferraz Note Added: 0139719
2022-07-29 12:22 aferraz Assigned To aferraz => sebastien_liron
2022-07-29 12:22 aferraz Status new => feedback
2022-08-03 13:51 rafaroda Relationship added related to 0049939
2022-08-03 14:05 rafaroda Note Added: 0139841
2022-08-03 14:06 rafaroda Relationship replaced duplicate of 0049939
2022-08-03 14:06 rafaroda Status feedback => closed
2022-08-03 14:06 rafaroda Resolution unable to reproduce => duplicate


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker