Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0047814
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[POS2] POSmajoralways2021-10-05 17:472021-10-22 13:11
ReporterjmelinView Statuspublic 
Assigned Toprakashmurugesan88 
PriorityurgentResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0047814: JIRA 2396 - When loading an existing order, product details linked to sales order is not loaded

DescriptionWhen opening a existing sales order, only the product id and the name of the product of a menu component is retrieved

Because of that, there are missing information for custom process
Steps To ReproduceCreate a new order with a menu and complete it

Look for this order in "Sales" window and do a verified return of all the product.

The following informations are needed for menu items of menu:
ticket.lines[].menuItems.product => retrieve product informations (including taxCategory and custom field)
ticket.lines[].menuItems.product.schemas
ticket.lines[].taxes
ticket.lines[].grossUnitAmount
ticket.lines[].baseGrossUnitAmount
ticket.lines[].grossUnitAmountWithoutTicketDiscounts
ticket.lines[].grossUnitPriceWithoutTicketDiscounts
ticket.lines[].promotions
Proposed SolutionLoad data linked to the componenet product like done for regular product and menu or when completing a new order
TagsNo tags attached.
Attached Filespng file icon Add line id to paid receipt.png [^] (33,467 bytes) 2021-10-19 13:08

- Relationships Relation Graph ] Dependency Graph ]
duplicate of defect 0047880 closedguilleaer Required data to work with productBoms is not being loaded when working with Restaurants menus 
depends on backport 0047834TAP closedRetail JIRA 2249 - When loading an existing order, product details linked to sales order is not loaded 

-  Notes
(0132445)
jmelin (developer)
2021-10-19 13:07

To correctly retrieve the taxCategory customly, we need to have the lineId from the order menu line item in the request to get the paid receipt.



(0132592)
guilleaer (manager)
2021-10-22 13:10

https://gitlab.com/openbravo/product/pmods/org.openbravo.pos2.restaurant/-/commit/9012b6b8c17ef7b9a6e47cccbf0b98ddab03f368 [^]
(0132593)
guilleaer (manager)
2021-10-22 13:10

https://gitlab.com/openbravo/product/pmods/org.openbravo.pos2.restaurant/-/commit/9012b6b8c17ef7b9a6e47cccbf0b98ddab03f368 [^]

- Issue History
Date Modified Username Field Change
2021-10-05 17:47 jmelin New Issue
2021-10-05 17:47 jmelin Assigned To => Retail
2021-10-05 17:47 jmelin Triggers an Emergency Pack => No
2021-10-11 12:57 guilleaer Status new => acknowledged
2021-10-11 12:57 guilleaer Status acknowledged => scheduled
2021-10-11 12:57 guilleaer Status scheduled => acknowledged
2021-10-11 12:58 guilleaer Assigned To Retail => prakashmurugesan88
2021-10-13 10:29 guilleaer Status acknowledged => scheduled
2021-10-13 18:51 jmelin Steps to Reproduce Updated View Revisions
2021-10-13 18:51 jmelin Summary JIRA 2249 - When loading an existing order, product details linked to sales order is not loaded => JIRA 2396 - When loading an existing order, product details linked to sales order is not loaded
2021-10-14 09:19 jmelin Steps to Reproduce Updated View Revisions
2021-10-19 13:07 jmelin Note Added: 0132445
2021-10-19 13:08 jmelin File Added: Add line id to paid receipt.png
2021-10-22 13:10 guilleaer Note Added: 0132592
2021-10-22 13:10 guilleaer Status scheduled => resolved
2021-10-22 13:10 guilleaer Resolution open => fixed
2021-10-22 13:10 guilleaer Review Assigned To => AugustoMauch
2021-10-22 13:10 guilleaer Note Added: 0132593
2021-10-22 13:10 guilleaer Status resolved => closed
2021-10-22 13:11 guilleaer Relationship added duplicate of 0047880


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker