Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0047773
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 07. Sales managementmajoralways2021-09-28 18:442021-10-21 09:37
ReporterlbressanView Statuspublic 
Assigned Tofernando_merino 
PriorityhighResolutioninvalidFixed in VersionPR22Q1
StatusclosedFix in branchFixed in SCM revision
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Tovmromanos
Web browser
ModulesCore
Regression level
Regression date2021-11-01
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0047773: Sales dimensional report - shipping address

DescriptionA customer report that in Sales dimensional report when selecting the dimension 'Shipping address' the report data shows the order address instead of the delivery address.
Steps To Reproduce1 - Create an address to the Business Partner, the Active check-in "Invoicing Address" and we remove the check "Shipping Address"
2 - In the standard address we change the check "Shipping Address" and we remove the check "Invoicing Address"
3- Create sales order indicating a different delivery address than the order address
4 - In the tab "Lines" we add two randoms products
5 - Select the process a dimensional sales report by selecting the dimensions 'Shipping address' and 'Product'
TagsNo tags attached.
Attached Files? file icon ticket29272.mp4 [^] (3,546,616 bytes) 2021-09-28 18:44

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0132276)
vmromanos (developer)
2021-10-08 14:44

Proposed solution: rename report's dimension from "Ship to address" to "Partner Address", which reflects the current report's behavior.
(0132315)
hgbot (developer)
2021-10-13 11:50

Merge Request created: https://gitlab.com/openbravo/product/openbravo/-/merge_requests/440 [^]
(0132344)
hgbot (developer)
2021-10-14 11:26

Directly closing issue as related merge request is already approved.

Repository: https://gitlab.com/openbravo/product/openbravo [^]
Changeset: ad287eb6150fd7b28cbda7b837eab9b184ea8e21
Author: fernando_merino <fernando.merino@openbravo.com>
Date: 2021-10-14T11:24:32+02:00
URL: https://gitlab.com/openbravo/product/openbravo/-/commit/ad287eb6150fd7b28cbda7b837eab9b184ea8e21 [^]

Fixes ISSUE-47773: Rename Sales Dimensional Report dimension from 'Ship to Address' to 'Partner Address'

Renamed the 'Ship to Address' dimension of the Sales Dimensional Report to 'Partner Address' as it reflects
better the report's behavior. The report groups by the order address, equivalent to the Business Partner
Address, so the 'Partner Address' name is more suitable than the 'Ship to Address' name for this dimension.

---
M src-db/database/sourcedata/AD_REF_LIST.xml
---
(0132345)
hgbot (developer)
2021-10-14 11:26

Merge request merged: https://gitlab.com/openbravo/product/openbravo/-/merge_requests/440 [^]
(0132466)
lbressan (developer)
2021-10-19 19:49

Dear,
After the client tried the patch, it did not solve the problem
(0132507)
lbressan (developer)
2021-10-20 19:42

The report "Dimensional Analysis of Sales Orders" continues to fail because when selecting the "Shipping Address" field as one of the available dimensions, it continues to be displayed in the Address field in the header of the Sales Orders, when The logical thing is that it shows the Delivery Address field that appears within the submenu and also in the Orders header

1- Create sales orders indicating a delivery address different from the order address

2- List a dimensional analysis of sales orders by selecting the dimensions 'Shipping address' and Product.

3- Check that the report groups by order address instead of by shipping address.
(0132516)
vmromanos (developer)
2021-10-21 09:37

The report has always shown the Partner Address. The problem was in the dimension name when launching the report, which was wrongly labeled as 'Ship to Address'.

The fix properly changes the dimension's name from 'Ship to Address' to 'Partner Address', which clearly represents the current behavior. You can check it in live builds.

Not sure what you're really expecting by reopening the issue. If you want to implement a new dimension 'Ship to Address', this would be a feature request.

- Issue History
Date Modified Username Field Change
2021-09-28 18:44 lbressan New Issue
2021-09-28 18:44 lbressan Assigned To => Triage Finance
2021-09-28 18:44 lbressan File Added: ticket29272.mp4
2021-09-28 18:44 lbressan Modules => Core
2021-09-28 18:44 lbressan Regression date => 2021-10-12
2021-09-28 18:44 lbressan Triggers an Emergency Pack => No
2021-10-08 14:44 vmromanos Note Added: 0132276
2021-10-08 15:07 aferraz Regression date 2021-10-12 =>
2021-10-08 15:07 aferraz Assigned To Triage Finance => fernando_merino
2021-10-13 11:50 hgbot Note Added: 0132315
2021-10-14 11:26 hgbot Resolution open => fixed
2021-10-14 11:26 hgbot Status new => closed
2021-10-14 11:26 hgbot Fixed in Version => PR22Q1
2021-10-14 11:26 hgbot Note Added: 0132344
2021-10-14 11:26 hgbot Note Added: 0132345
2021-10-19 19:47 lbressan Status closed => new
2021-10-19 19:49 lbressan Note Added: 0132466
2021-10-20 19:42 lbressan Regression date => 2021-11-01
2021-10-20 19:42 lbressan Note Added: 0132507
2021-10-21 09:37 vmromanos Review Assigned To => vmromanos
2021-10-21 09:37 vmromanos Note Added: 0132516
2021-10-21 09:37 vmromanos Status new => closed
2021-10-21 09:37 vmromanos Resolution fixed => invalid


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker