Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0047449
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[POS2] Coretrivialalways2021-07-22 17:452021-10-22 13:06
ReporterdbazView Statuspublic 
Assigned Toprakashmurugesan88 
PrioritynormalResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toguilleaer
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0047449: Ripple effect while pressing on buttons, is not the Material Design one

DescriptionRipple effect while pressing on buttons, is not the Material Design one.

The Material Design should start the ripple effect in the exact point where it has been pressed. In current application the ripple effect always start from the center of the button

https://material-ui.com/components/buttons/ [^]
https://jsfiddle.net/qtp5re1o/ [^]

Also, due to the current implementation, there is
.obc2BaseButton-overlay {
...
   transition: background 0.8s;
...
}

which causes an undesired transition effect while moving a button to 'disabled' state, accompanied with a shining effect. (this effect was wrongly added during scss-refactor project)

Steps To Reproduce.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0046533 closedprakashmurugesan88 Offline X icon problems due to SCSS Button refactor 
blocks defect 0046987 closedprakashmurugesan88 [UX] Weird "flash" animation when picking a Payment Method 

-  Notes
(0132195)
hgbot (developer)
2021-10-06 12:10

Merge Request created: https://gitlab.com/openbravo/product/pmods/org.openbravo.core2/-/merge_requests/644 [^]
(0132559)
hgbot (developer)
2021-10-22 10:03

Merge request merged: https://gitlab.com/openbravo/product/pmods/org.openbravo.core2/-/merge_requests/644 [^]
(0132590)
guilleaer (manager)
2021-10-22 13:06

This is the commit that fixes this issue with an error in the commit message

https://gitlab.com/openbravo/product/pmods/org.openbravo.core2/-/commit/c8f837f96089e6197499a9c8c024cef9d81b80cb [^]

- Issue History
Date Modified Username Field Change
2021-07-22 17:45 dbaz New Issue
2021-07-22 17:45 dbaz Assigned To => Retail
2021-07-22 17:45 dbaz Triggers an Emergency Pack => No
2021-07-22 17:52 dbaz Description Updated View Revisions
2021-07-23 11:36 dmiguelez Relationship added related to 0046987
2021-07-23 11:36 dmiguelez Assigned To Retail => migueldejuana
2021-07-23 11:36 dmiguelez Status new => acknowledged
2021-07-23 11:39 dmiguelez Relationship deleted related to 0046987
2021-07-23 11:39 dmiguelez Relationship added blocks 0046987
2021-07-23 11:41 dmiguelez Resolution time => 1628200800
2021-07-23 13:18 dmiguelez Relationship deleted blocks 0046987
2021-07-23 13:18 dmiguelez Relationship added blocks 0046533
2021-07-27 15:54 dmiguelez Relationship added blocks 0046987
2021-08-06 11:33 dmiguelez Resolution time 1628200800 => 1633039200
2021-09-15 09:40 prakashmurugesan88 Assigned To migueldejuana => prakashmurugesan88
2021-09-15 09:40 prakashmurugesan88 Status acknowledged => scheduled
2021-09-16 12:29 dbaz Description Updated View Revisions
2021-10-06 12:10 hgbot Note Added: 0132195
2021-10-22 10:03 hgbot Note Added: 0132559
2021-10-22 13:06 guilleaer Note Added: 0132590
2021-10-22 13:06 guilleaer Status scheduled => resolved
2021-10-22 13:06 guilleaer Resolution open => fixed
2021-10-22 13:06 guilleaer Review Assigned To => guilleaer
2021-10-22 13:06 guilleaer Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker